Home » SQL & PL/SQL » Client Tools » SqlPlus Environment Setting for "Define"
SqlPlus Environment Setting for "Define" [message #193197] Fri, 15 September 2006 04:39 Go to next message
anil_sapra
Messages: 35
Registered: May 2006
Location: DELHI
Member

Hi all,

Can anybody help me in environment setting of SqlPlus
for "Define" Option. I have to run many scripts
from dos prompt using SqlPlus. In my scripts
"&" is used on many occasions due to that
I am facing problem.

Pl. suggest where can we change default setting for
"Define" without "&"

Thanks

Anil


Re: SqlPlus Environment Setting for "Define" [message #193206 is a reply to message #193197] Fri, 15 September 2006 05:00 Go to previous messageGo to next message
JRowbottom
Messages: 5933
Registered: June 2006
Location: Sunny North Yorkshire, ho...
Senior Member
SET DEFINE <chr of your choice>
Re: SqlPlus Environment Setting for "Define" [message #193210 is a reply to message #193206] Fri, 15 September 2006 05:28 Go to previous messageGo to next message
anil_sapra
Messages: 35
Registered: May 2006
Location: DELHI
Member

Thank you very much for your reply.

Can you please do let me know where can I define
"Set define OFF" For my Sqlplus Environment

I have to run around 2000 scripts in which "Exit"
is used which takes me out of sqlplus.

Hence I want to set define off.

Pl. help.

Anil
Re: SqlPlus Environment Setting for "Define" [message #193256 is a reply to message #193210] Fri, 15 September 2006 07:56 Go to previous messageGo to next message
joy_division
Messages: 4640
Registered: February 2005
Location: East Coast USA
Senior Member
Either in the directory you start sqlplus, place a file called login.sql or in $ORACLE_HOME/sqlplus/admin, put a file called glogin.sql with SET DEFINE OFF in it.
Re: SqlPlus Environment Setting for "Define" [message #193387 is a reply to message #193256] Sat, 16 September 2006 01:42 Go to previous message
anil_sapra
Messages: 35
Registered: May 2006
Location: DELHI
Member

Thank you very much.
This has solved my problem.

Regards,

Anil Sapra
Previous Topic: working with isql*plus
Next Topic: isql*plus Session as sysdba user
Goto Forum:
  


Current Time: Sun Dec 04 20:46:49 CST 2016

Total time taken to generate the page: 0.08257 seconds