Home » RDBMS Server » Server Administration » RUSSIAN_RUSSIA.UTF8 language parameter is not working in windows registry
RUSSIAN_RUSSIA.UTF8 language parameter is not working in windows registry [message #192157] Mon, 11 September 2006 05:27 Go to next message
amit.pandey
Messages: 64
Registered: August 2006
Location: Bangalore, India
Member
Hi All,

I'm working on a Russian DB, and for that we use SQL*PLUS as a client under windows environment using oracle 9i. I've set the following value of
NLS_LANG = RUSSIAN_CIS.CL8MSWIN1251 under following registry entry.
HKEY_LOCAL_MACHINE-->SOFTWARE-->ORACLE-->HOME0-->NLS_LANG.

This was working fine.

Now my problem is that i want to store some hindi data in some tables in same database. for that i set the NLS_LANG parameter value to
NLS_LANG=RUSSIAN_RUSSIA.UTF8 (as i read in ora documentation), as my most of the data is in RUSSIAN so i set this setting, as per my knowledge i can view the russian as well as any language characters also, bcoz of "UTF8".

But when i'm trying to connect sql*plus after changing this value, it said
INVALID VALUE SPECIFIED FOR NLS PARAMETER.

Can anybody tell me is thr other setting to be changed when we set RUSSIAN_RUSSIA.UTF8.
If any body have any solution then Please help me out.

Thanks & Regards

Amit
Re: RUSSIAN_RUSSIA.UTF8 language parameter is not working in windows registry [message #192336 is a reply to message #192157] Mon, 11 September 2006 23:14 Go to previous messageGo to next message
amit.pandey
Messages: 64
Registered: August 2006
Location: Bangalore, India
Member
Hi All,

Please help me out. I Read several documents but it is not working, can anybody tells me where i did the mistake.

What i actually needed is that when i use sql*plus as a client then it must show the exact russian data which stored in database. I tried RUSSIAN_CIS.CL8MSWIN1251 and RUSSIAN_CIS.CL8ISO8859P5 they r working properly, but i want to use RUSSIAN_RUSSIA.UTF8, bcoz of, in future i've to store some hindi(indian language) data into the same database.

Please help me out.

AMIT
Re: RUSSIAN_RUSSIA.UTF8 language parameter is not working in windows registry [message #198189 is a reply to message #192336] Mon, 16 October 2006 02:25 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Don't you have to specify the NLS_LANG in both the database and on the client PC?

David
Re: RUSSIAN_RUSSIA.UTF8 language parameter is not working in windows registry [message #198580 is a reply to message #198189] Tue, 17 October 2006 14:52 Go to previous message
andrew again
Messages: 2577
Registered: March 2000
Senior Member
Try this from sqlplus - see what client NLS_LANG it is picking up.

SQL> @%NLS_LANG%
SP2-0310: unable to open file "AMERICAN_AMERICA.WE8MSWIN1252"
Previous Topic: Remove rule from the streams
Next Topic: Managing memory in shared mode
Goto Forum:
  


Current Time: Sat Dec 10 14:57:36 CST 2016

Total time taken to generate the page: 0.05184 seconds