Home » Developer & Programmer » Forms » Problem in Passing Parameter List
icon5.gif  Problem in Passing Parameter List [message #191211] Tue, 05 September 2006 03:47 Go to next message
qadeerahmed
Messages: 63
Registered: July 2006
Location: Pakistan
Member
Hi Everybody,

When Passing I call the Second Form It generates error as
" NO such parameter SHIFT exists"
I'm passing only single parameter the code is as:
	ADD_PARAMETER(VAR,'SEMESTER',TEXT_PARAMETER,:SEMESTER);

Waiting for your reply

regards,
qadeer ahmed
Re: Problem in Passing Parameter List [message #191332 is a reply to message #191211] Tue, 05 September 2006 15:04 Go to previous messageGo to next message
RJ.Zijlstra
Messages: 104
Registered: December 2005
Location: Netherlands - IJmuiden
Senior Member
Hello Qadeer Ahmed,

Well, I also ONLY see the parameter named 'SEMESTER' in this code.
Are you sure you also have something like

ADD_PARAMETER(VAR,'SHIFT',TEXT_PARAMETER,:SEMESTER);


Regards,

Rob Zijlstra
Re: Problem in Passing Parameter List [message #191503 is a reply to message #191332] Wed, 06 September 2006 14:34 Go to previous messageGo to next message
qadeerahmed
Messages: 63
Registered: July 2006
Location: Pakistan
Member
Thanks Rob,
It is solved.

But one other problem i'm facing now....

I've about 8 TEXT_ITEMS and i want to assign the value of the parameter to these fields.
But the value is assigned only to the first TEXT_ITEM.
The same value of the parameter is not assigned to others.

I have tried different ways by changing the properties of TEXT_ITEMS as 'Synchronize item with' and also 'copy value from item', but it does not work.

Parameter Value was assigned to first TEXT_ITEM; by writing this code in its 'Initial Value'
:PARAMETER.PROGRAM


Thanks Very Much!!
Regards
Qadeer Ahmed
Re: Problem in Passing Parameter List [message #191523 is a reply to message #191211] Wed, 06 September 2006 21:57 Go to previous messageGo to next message
qadeerahmed
Messages: 63
Registered: July 2006
Location: Pakistan
Member
Looking Forward For The Solution
Regards
Qadeer Ahmed
Re: Problem in Passing Parameter List [message #191658 is a reply to message #191332] Thu, 07 September 2006 10:19 Go to previous messageGo to next message
RJ.Zijlstra
Messages: 104
Registered: December 2005
Location: Netherlands - IJmuiden
Senior Member
<snip>
I've about 8 TEXT_ITEMS...
<end snip>

in when-new-forms trigger put something like:

:blockname.itemname1 := :parameter.SHIFT;
:blockname.itemname2 := :parameter.SHIFT;
:blockname.itemname3 := :parameter.SHIFT;
:blockname.itemname4 := :parameter.SHIFT;
:blockname.itemname5 := :parameter.SHIFT;

etc...


Regards
Rob Zijlstra
Re: Problem in Passing Parameter List [message #192313 is a reply to message #191658] Mon, 11 September 2006 16:04 Go to previous message
qadeerahmed
Messages: 63
Registered: July 2006
Location: Pakistan
Member
Thanks Rob,

I've solved my problem with all the ways i wrote and you suggested.
The only problem with mine was; I was not compiling the Called Form. I simply Run the First Form.

Thanks Again
Regards
Qadeer ahmed
Previous Topic: problem Attaching a library
Next Topic: Help me!! file information
Goto Forum:
  


Current Time: Sun Dec 04 22:42:28 CST 2016

Total time taken to generate the page: 0.07420 seconds