Home » Developer & Programmer » Forms » Problem in calling procedure that uses DBMS_LOB
Problem in calling procedure that uses DBMS_LOB [message #189206] Wed, 23 August 2006 11:07 Go to next message
boyet-x
Messages: 23
Registered: August 2006
Junior Member
Hello guys,

I have a stored procedure that processes clob data and inserted into the db. I then call this procedure in an Oracle Forms 6i app. But an oracle error pops up Ora-22921.

I tried to trace the cause of the error. It seems that the "DBMS_LOB.Read" call in the stored procedure wouldnt able to read positions more than 65k.

The weird thing is that when I try to run the procedure outside the form (using exactly the same parameters), it works (it was able to read clob data at position more than 65k).

Any idea? Is it on my client setup or anything?

Thanks! I really badly needed you advise..

Boyet
Re: Problem in calling procedure that uses DBMS_LOB [message #191582 is a reply to message #189206] Thu, 07 September 2006 03:17 Go to previous message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Have you solved your problem?

David
Previous Topic: enter key to select a form not working
Next Topic: Switch of runtime help in Oracle 9i & How to switch off runtime help in Oracle 9i (merged)
Goto Forum:
  


Current Time: Sat Dec 10 08:55:51 CST 2016

Total time taken to generate the page: 0.06682 seconds