Home » RDBMS Server » Backup & Recovery » Problem with IMP utility ....
Problem with IMP utility .... [message #188742] Mon, 21 August 2006 07:11 Go to next message
frank.svs
Messages: 162
Registered: February 2006
Senior Member
Hi Team,

Small problem.

I created one user say "demo". Initially i've taken schema bkp of scott user.
as follows .

exp scott/tiger@<service-name> file=scott.dmp log=scott.log

It expoted 4 tables i.e BONUS,DEPT,EMP,SALGRADE


Now, i imported this dump file into newly created user accout "demo". as follows
imp system/pwd@<service-name> file=scott.dmp log=imp.log fromuser=scott touser=demo

Successfully the 4 tables got imported without any warnings.

Now the actual problem,
Now i connected to scott and made 2 modifications
One is i created a new "Sample" with some data.
secondly i added one more column "newcol" to EMP table as follows
SCOTT >alter table emp add newcol varchar2(20) default 'testing';

Now again i taken a fresh exp but this time rows=n
exp scott/tiger<service-name> file=scott2.dmp log=scott2.log rows=n

Now i tried to apply these changes to my "demo" user.What is happening is that, the new table
is getting created with no data. that's fine but my EMP table is not getting modified.is there any
problem with ignore=y

This is stmt i've given

imp system/pwd@<service-name> file=scott2.dmp log=imp2.log fromuser=scott touser=demo ignore=y

But why my EMP table is getting modified.I dont mind even if i loose my data for the tables which
have been modified "structure-wise"


Can anyone pls help me.

Regards,
franky
Re: Problem with IMP utility .... [message #188744 is a reply to message #188742] Mon, 21 August 2006 07:23 Go to previous messageGo to next message
Mahesh Rajendran
Messages: 10672
Registered: March 2002
Location: oracleDocoVille
Senior Member
Account Moderator
Cross forum posting?
Re: Problem with IMP utility .... [message #188910 is a reply to message #188742] Tue, 22 August 2006 06:27 Go to previous messageGo to next message
dinu_dba
Messages: 8
Registered: August 2006
Location: Hyderabad
Junior Member

whats ur problem franky
u asked data is not modified again u told even i dont mind to lose of data ..what really u want to be
Re: Problem with IMP utility .... [message #189156 is a reply to message #188910] Wed, 23 August 2006 07:50 Go to previous message
frank.svs
Messages: 162
Registered: February 2006
Senior Member
Dear dinu,

I mean i want only the modified structures and new table structures to get imported. That's it.

Regards,
Franky
Previous Topic: RMAN Backup issue
Next Topic: log shipping ..
Goto Forum:
  


Current Time: Sat Dec 03 05:41:09 CST 2016

Total time taken to generate the page: 0.05363 seconds