Home » Developer & Programmer » Forms » htree
htree [message #187697] Tue, 15 August 2006 00:24 Go to next message
whocracks
Messages: 4
Registered: August 2006
Junior Member
I have 1 htree item on form....i have creted 1 recordgroup with query " select * from table1".... table having 3 columns...

and have folowing code

DECLARE
   htree   ITEM;
   rg_data RECORDGROUP;
BEGIN
   -- Find the tree itself.
   htree := Find_Item('tree1');
 
   -- Find the record group.
   rg_data := FIND_GROUP('RG1');
 
   -- Add the new node at the top level and children.
   Ftree.Add_Tree_Data(htree,
                     Ftree.ROOT_NODE,
                     Ftree.PARENT_OFFSET,
                     Ftree.LAST_CHILD,
                     Ftree.RECORD_GROUP,
                     rg_data);
          
END;


When I run above code i dont get any error..but it doesnot display anything...
and in the status bar i get following msg...
FRM-47321 Data used to populate the tree is invalid...

So, what is the way if i want to populate the tree with recordgroup.
Re: htree [message #188058 is a reply to message #187697] Wed, 16 August 2006 21:39 Go to previous message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
I did a search of the forum for 'Add_Tree_Data' and found http://www.orafaq.com/forum/m/81239/67467/?srch=Add_Tree_Data#msg_81239

Does this help?

I see that your code is based on the example in the reference manual. However, you have not defined the 'block' in your Find_Item statement.

David
Previous Topic: Initial Form Sizing Differences
Next Topic: how to put file on client side
Goto Forum:
  


Current Time: Tue Dec 06 04:37:55 CST 2016

Total time taken to generate the page: 0.11941 seconds