Home » Developer & Programmer » Reports & Discoverer » After Printing ?
icon5.gif  After Printing ? [message #186973] Thu, 10 August 2006 06:45 Go to next message
qadeerahmed
Messages: 63
Registered: July 2006
Location: Pakistan
Member
Hi,
I want to do as :-
I call Report from Form, and After Report prints, The Status of the column named as 'PRINTED', should be changed to 'YES' or '1' in the employee table.

How i can do that...??
I've writen the code in 'After Report' as
Update empolyee
set printed=1
where serialno=:emp_id;

But It doesn't change the Printed Field to 1?
NOthing happens?

Regards
qadeer Ahmed
icon5.gif  Re: After Printing ? [message #187119 is a reply to message #186973] Thu, 10 August 2006 23:23 Go to previous messageGo to next message
qadeerahmed
Messages: 63
Registered: July 2006
Location: Pakistan
Member
Hi,
Can AnyOne Help Out in this regard ??

Regards,
Qadeer Ahmed
Re: After Printing ? [message #187150 is a reply to message #187119] Fri, 11 August 2006 02:21 Go to previous messageGo to next message
Littlefoot
Messages: 20888
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Did you COMMIT the update?
Re: After Printing ? [message #187157 is a reply to message #187150] Fri, 11 August 2006 02:42 Go to previous messageGo to next message
qadeerahmed
Messages: 63
Registered: July 2006
Location: Pakistan
Member
Thanks For Reply !!
Yes I did commit;

But Null Value is Inserted in the column.
I checked with this query.
SELECT COUNT(NVL(printed,0)) from employee.


It counts to 3, If NVL function is not used, then it counts to 0 ?

Regards
Qadee Ahmed
Re: After Printing ? [message #187180 is a reply to message #187157] Fri, 11 August 2006 04:12 Go to previous message
qadeerahmed
Messages: 63
Registered: July 2006
Location: Pakistan
Member
Thanks You All,

My Problem is Solved
By Using SRW Package
SRW.DO_SQL('UPDATE BU_EMP_CARD   SET PRINTED=1  WHERE EMPID='||:emp_id);
SRW.DO_SQL('COMMIT'); 


Regards
Qadeer Ahmed
Previous Topic: passing parameter list to report 9i
Next Topic: Problem in creating template for XML report
Goto Forum:
  


Current Time: Sat Dec 03 10:11:57 CST 2016

Total time taken to generate the page: 0.07326 seconds