Home » RDBMS Server » Server Administration » My logs are switching every 5 mins, why?
My logs are switching every 5 mins, why? [message #184397] Wed, 26 July 2006 07:26 Go to next message
aidi-h
Messages: 44
Registered: November 2005
Member
My DB was writing to my redo log files too fast and causing errors. As this was the case, I increased my redo logs from 5 * 50M to 5 * 100M files. Although checkpoints are all being reached now, the logs are switching every 5 mins regardless of the amount of people on the system. Is there some setting anywhere that is forcing the logs to be switched every 5 mins regardless of whether the log is filled up or not. Could my log buffer be too small and is this causing the problems?
Re: My logs are switching every 5 mins, why? [message #184415 is a reply to message #184397] Wed, 26 July 2006 08:36 Go to previous messageGo to next message
JRowbottom
Messages: 5933
Registered: June 2006
Location: Sunny North Yorkshire, ho...
Senior Member
Something, somewhere is doing a sack full of work.

Either Enterprise Manager or statspack should be able to show you what's going on.
Re: My logs are switching every 5 mins, why? [message #184456 is a reply to message #184397] Wed, 26 July 2006 10:45 Go to previous messageGo to next message
aidi-h
Messages: 44
Registered: November 2005
Member
it looks like my logs are switching every 5mins down to the second. Could Dataguard be doing this and if so, how do I stop this?
Re: My logs are switching every 5 mins, why? [message #184593 is a reply to message #184456] Thu, 27 July 2006 03:11 Go to previous messageGo to next message
JRowbottom
Messages: 5933
Registered: June 2006
Location: Sunny North Yorkshire, ho...
Senior Member
So it's not just down to the amount of data? The logs aren't full?


The parameter Archive_Lag_Target sets how long (in seconds) the Db will go before forcing a log switch.

But, I'd say if you're not having a problem with the amount of data in the redo logs, just leave it.


Re: My logs are switching every 5 mins, why? [message #184711 is a reply to message #184397] Thu, 27 July 2006 09:11 Go to previous message
aidi-h
Messages: 44
Registered: November 2005
Member
many thanks for that. the Archive_Lag_Target variable was set to 300 (secs). Thats sorted.
Previous Topic: Constraints
Next Topic: Data modelling
Goto Forum:
  


Current Time: Wed Dec 07 02:57:38 CST 2016

Total time taken to generate the page: 0.10054 seconds