Home » Developer & Programmer » Forms » open_form
open_form [message #184358] Wed, 26 July 2006 05:58 Go to next message
rorehoci
Messages: 1
Registered: July 2006
Junior Member
Hi,
simple thing but huge problem for me.
Two forms 6i (6.0.8.22.1)
Started form FORM_A connect as USER_A on database DATABASE.
From When-Button-Pressed in FORM_A I execute this code:

logout
logon ('USER_B/.....') --> different user but same database
OPEN_FORM('FORM_B') --> also try with ACTIVATE, SESSION

After that I am able to work on FORM_B but when I leave (don't close it but navigate back to FORM_A) I lost connection from that form (FORM_B) as user USER_B.

As I arrived back to FORM_A I am still successfully connected as USER_A and I can work on it but Form_B is no more connected.

Can someone tell me what is reason and how to solve problem ?
Re: open_form [message #184789 is a reply to message #184358] Fri, 28 July 2006 01:19 Go to previous message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Put the connect in the When-New-Form-Instance trigger. That way you will sign on twice - once in each form, but still be connected when you return to the other form.

David

[Updated on: Fri, 28 July 2006 01:20]

Report message to a moderator

Previous Topic: forms 2.1 and forms 6.i installation
Next Topic: SYSTEM.RECORD_STATUS
Goto Forum:
  


Current Time: Sat Dec 10 20:22:02 CST 2016

Total time taken to generate the page: 0.07315 seconds