Home » Applications » Oracle Fusion Apps & E-Business Suite » OE_Order_Pub.Process_Order API
OE_Order_Pub.Process_Order API [message #184167] Tue, 25 July 2006 10:26 Go to next message
reddis
Messages: 12
Registered: January 2006
Location: US
Junior Member
Hi,
I am trying to create a simple order with one item, I am not sure what I am missing but its throwing me an error and the return status is 'U'
below is the error messages

===================================
process ORDER ret status IS: U
process ORDER msg data IS:
process ORDER msg COUNT IS: 2
header.order_number IS: 9.990000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000E+125
header.return_status IS:
header.booked_flag IS:
header.header_id IS: 9.990000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000E+125
header.order_source_id IS: 9.990000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000E+125
header.flow_status_code IS: ENTERED
message is: ORA-20001: User in Package OE_Header_Util Procedure Get_Order_Number
message index is: 1
message is: User-Defined Exception in Package OE_Header_Util Procedure Pre_Write_Process
message index is: 2
oe_msg_pub.count_msg = 2
==================================================

Please let me know if anyone has a solution

Thanks
Re: OE_Order_Pub.Process_Order API [message #184272 is a reply to message #184167] Wed, 26 July 2006 00:10 Go to previous messageGo to next message
B.T.S.Ananth
Messages: 216
Registered: June 2006
Location: chennai / Hyderabad
Senior Member

Hi

I saw ur Query please answer my below questions it should be either one u have missed!

1. what is the order type ur using

2. if the order type is Return create a seperate sequence number for the order

3. if the order type is both(Order & Return) then assign the return in setup > transaction type

the above error is because of the sequence number only
check and let me know

Regards,
B.T.S.Ananth
Re: OE_Order_Pub.Process_Order API [message #184406 is a reply to message #184272] Wed, 26 July 2006 07:47 Go to previous message
reddis
Messages: 12
Registered: January 2006
Location: US
Junior Member
Hello Ananth,

Thanks for the reply.
I was able to figure out the problem.
Actually there was a line level defaulting rule which was defined and the condition yielding for this order type was causing the problems.

Thanks,
Srikanth
Previous Topic: Upload Value sets Values in GL for Independent Type
Next Topic: SOS - facing problems with concurrent manager
Goto Forum:
  


Current Time: Thu Dec 08 22:23:26 CST 2016

Total time taken to generate the page: 0.11924 seconds