Home » RDBMS Server » Server Administration » Errors upgrading from 10.1.0.2 to 10.1.0.3
Errors upgrading from 10.1.0.2 to 10.1.0.3 [message #183623] Fri, 21 July 2006 10:31 Go to next message
cbooker
Messages: 8
Registered: July 2006
Junior Member
Surprisingly, I could not find anything about this with a search.

We have Oracle 10.1.0.2 installed on a Windows Server 2003. With the new critical update, I thought I'd better start learning how to upgrade (I was kind of thrown into administering).

I followed the instructions in Note: 276548.1 on Metalink, however the upgrade to 10.1.0.3 obviously did not go as smoothly as I had hoped. Here is the state of the server components after running catpatch.sql:

COMP_NAME                           STATUS      VERSION
----------------------------------- ----------- ----------
Oracle Workspace Manager            VALID       10.1.0.2.0
Oracle Data Mining                  OPTION OFF  10.1.0.2.0
OLAP Analytic Workspace             OPTION OFF  10.1.0.2.0
Oracle OLAP API                     OPTION OFF  10.1.0.2.0
OLAP Catalog                        OPTION OFF  10.1.0.2.0
Spatial                             OPTION OFF  10.1.0.2.0
Oracle Database Catalog Views       VALID       10.1.0.3.0
Oracle Database Packages and Types  VALID       10.1.0.3.0
JServer JAVA Virtual Machine        VALID       10.1.0.3.0
Oracle XDK                          VALID       10.1.0.3.0
Oracle Database Java Packages       VALID       10.1.0.3.0
Oracle XML Database                 VALID       10.1.0.3.0
Oracle interMedia                   INVALID     10.1.0.3.0
Oracle Text                         INVALID     10.1.0.3.0
Oracle Ultra Search                 VALID       10.1.0.3.0
Oracle Expression Filter            VALID       10.1.0.3.0
Oracle Enterprise Manager           VALID       10.1.0.3.0


Three obvious questions...
1. Do I care that Workspace Manager did not upgrade?
2. What does it mean that interMedia and Text are invalid?
3. How do I fix it? Presumably simply running catpatch again will yield the same results.

And a less obvious 4th question.
(***Edit: 4th question removed. I answered it myself.)

Thanks in advance for any help or insight!

Cory

[Updated on: Fri, 21 July 2006 11:47]

Report message to a moderator

Re: Errors upgrading from 10.1.0.2 to 10.1.0.3 [message #183667 is a reply to message #183623] Fri, 21 July 2006 18:06 Go to previous messageGo to next message
nmacdannald
Messages: 460
Registered: July 2005
Location: Stockton, California - US...
Senior Member
There is a .sql file that recompiles all packages and procedures. In $ORACLE_HOME/rdbms/admin/ directory. I will post its name shortly, I don't remember it right now.
Re: Errors upgrading from 10.1.0.2 to 10.1.0.3 [message #183668 is a reply to message #183623] Fri, 21 July 2006 18:17 Go to previous messageGo to next message
BlackSwan
Messages: 25046
Registered: January 2009
Location: SoCal
Senior Member
SQL> @?/rdbms/admin/utlrp.sql
Re: Errors upgrading from 10.1.0.2 to 10.1.0.3 [message #183966 is a reply to message #183623] Mon, 24 July 2006 09:26 Go to previous message
cbooker
Messages: 8
Registered: July 2006
Junior Member
I'll give that a whirl.Thanks!
Previous Topic: Two questions
Next Topic: partition date wise
Goto Forum:
  


Current Time: Thu Dec 08 16:11:14 CST 2016

Total time taken to generate the page: 0.09048 seconds