Home » Developer & Programmer » Forms » Template Paths and FRM-18108
Template Paths and FRM-18108 [message #183190] Wed, 19 July 2006 19:45 Go to next message
whatfur
Messages: 29
Registered: July 2006
Junior Member
Hello,

I had converted some forms to pick up libraries and templates
from the file system. I have discovered that some of my forms expect the template files to be found in one place while others
require the same files to exist in another place and will fail compiles with FRM-18108 when they don't exist where expected.

The problem is I want them all to look for these templates in one place but cannot seem to find where this path is set.

Any help?
Re: Template Paths and FRM-18108 [message #183205 is a reply to message #183190] Wed, 19 July 2006 23:01 Go to previous messageGo to next message
bhupinderbs
Messages: 67
Registered: July 2006
Location: Bangalore
Member
Hi
Go to registry(REGEDIT) and add another path in FORMs60PATH(For Forms 6i) or FORMS_PATH(For Forms 10g) separated by comma [;].
Open Form Builder and open your form.
It will not give error for path.

Bhupinder Singh

[Updated on: Wed, 19 July 2006 23:02]

Report message to a moderator

icon5.gif  Re: Template Paths and FRM-18108 [message #183337 is a reply to message #183205] Thu, 20 July 2006 07:46 Go to previous messageGo to next message
whatfur
Messages: 29
Registered: July 2006
Junior Member

Thank you, but NO, that is not the answer.

The desired path already exists in the FORMS60_PATH.

The problem is some of my forms are looking
in another path for template info...so I can
only assume a path is stored within the form itself.

I don't want to add this additional path to the env
variable. I want to change the form to look for
the templates in the path already defined by FORMS60_PATH.



icon5.gif  Re: Template Paths and FRM-18108 [message #183435 is a reply to message #183337] Thu, 20 July 2006 22:22 Go to previous messageGo to next message
whatfur
Messages: 29
Registered: July 2006
Junior Member
One last attempt...

First I have read every entry here and on Google concerning
FRM-18108...yet my issue does not seemed to be addressed.

Here with a bit more detail is the breakdown.

I have a bunch of forms in directory:

.../ImFm/AA

I have a couple libraries and a couple form templates
utilized by the forms above stored in directory:

.../ImFm

When I compile the templates and libraries the resultant
executables are put into the directory:

.../forp


I then compile the forms for directory AA above and
most compile cleanly and leave their executables also in

.../forp

Now if all form compiles are successful all these executables
are moved to copied also to directory

.../form
However, because a couple forms do not compile; this copy
to the .../form directory does not happen. Those that do not compile give me the 18108 error because they are looking for
the templates in the .../form directory and they do not exist their yet...where those that do compile look in the .../forp
directory and thus do find them. I know this because if I copy the compiled template to the .../form directory; I can get the
failing forms to compile.

.../forp already exists in my FORMS path...adding .../form to it is not the solution as the templates still would not be found there as they wouldn't exist there yet.

Something is telling these specific forms to look in the .../form directory for the templates while I want them to
specifically look in the .../forp directory for the templates like all the other forms do.

I want to to know what that Something is.

I'm rambling..tired...and frustrated...whatever happened to Informix? ;o)

Any help appreciated.

[Updated on: Thu, 20 July 2006 22:25]

Report message to a moderator

Re: Template Paths and FRM-18108 [message #184556 is a reply to message #183435] Thu, 27 July 2006 01:04 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Once you got all the forms to compile did this solve your problem?

David
Re: Template Paths and FRM-18108 [message #186569 is a reply to message #184556] Tue, 08 August 2006 09:16 Go to previous messageGo to next message
whatfur
Messages: 29
Registered: July 2006
Junior Member
No.

The problem of the compilation of those couple forms still
looking in the wrong directory for their templates still
exists. I am just living with having to make sure I have the
templates, once compiled, moved to both places so those looking in either place can find them.

This is a workaround but not the fix I was looking for.

D
Re: Template Paths and FRM-18108 [message #186693 is a reply to message #186569] Wed, 09 August 2006 02:06 Go to previous message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
I suggest that you make a copy of one of these problem forms. Then you open it in the form builder and at the form level have a look at the Subclass Information. I believe that this is pointing to a directory and file name combination. Change it to just the file name and see if that fixes your problem.

Basically, when the form was created, it was done against a reference form and the 'path' was NOT removed.

It is possible that this referencing has been done at the block or item level.

Alternative: convert your form to XML, use a good 'flat' editor to find the paths and delete them. Then convert the XML back to a form.

David
Previous Topic: unhandled exception ora-306500
Next Topic: truncate partition-index unusable state
Goto Forum:
  


Current Time: Sun Dec 04 10:25:17 CST 2016

Total time taken to generate the page: 0.13680 seconds