Home » Infrastructure » Linux » Running SQLDEVELOPER
Running SQLDEVELOPER [message #180893] Wed, 05 July 2006 14:17 Go to next message
limbe
Messages: 20
Registered: July 2006
Location: Limbe, Cameroon
Junior Member
Hello,

I have installed sqlDeveloper for linux when i start i have the following error,

[root@CITEC sqldeveloper]# sh sqldeveloper

Oracle SQL Developer 1.0
Copyright (c) 2005 Oracle Corporation. All Rights Reserved.

Working directory is /sqldeveloper/jdev/bin
Exception in thread "main" java.lang.NullPointerException
at java.util.Hashtable.get(Hashtable.java:333)
at java.util.logging.LogManager.getLogger(LogManager.java:437)
at java.util.logging.Logger.getLogger(Logger.java:228)
at oracle.ide.performance.PerformanceLogger.<init>(PerformanceLogger.java:64)
at oracle.ide.performance.PerformanceLogger.get(PerformanceLogger.java:94)
at oracle.ideimpl.Main.main(Main.java:21

Any Help !!!!!!!!!
Re: Running SQLDEVELOPER [message #180896 is a reply to message #180893] Wed, 05 July 2006 14:23 Go to previous messageGo to next message
Mahesh Rajendran
Messages: 10672
Registered: March 2002
Location: oracleDocoVille
Senior Member
Account Moderator
Are you sure you are using the latest JDK 1.5.* (whatever)
Re: Running SQLDEVELOPER [message #180898 is a reply to message #180896] Wed, 05 July 2006 14:43 Go to previous messageGo to next message
limbe
Messages: 20
Registered: July 2006
Location: Limbe, Cameroon
Junior Member
Thanks ,

I am using JDK 1.4, MUST IT BE JDK1.5


Hugues
Re: Running SQLDEVELOPER [message #180901 is a reply to message #180898] Wed, 05 July 2006 14:48 Go to previous messageGo to next message
Mahesh Rajendran
Messages: 10672
Registered: March 2002
Location: oracleDocoVille
Senior Member
Account Moderator
Yes.
Re: Running SQLDEVELOPER [message #180910 is a reply to message #180901] Wed, 05 July 2006 15:42 Go to previous messageGo to next message
limbe
Messages: 20
Registered: July 2006
Location: Limbe, Cameroon
Junior Member
Thanks

Going to Downlaod it


Hugues
Install SQLDEVELOPER [message #403418 is a reply to message #180893] Fri, 15 May 2009 08:24 Go to previous messageGo to next message
angav
Messages: 5
Registered: May 2009
Junior Member
I have a problem with the sqldeveloper installation on Ubuntu. I've downloaded sqldeveloper-1.5.4.59.40-1.noarch.rpm.
Then I write:
rpm -Uhv sqldeveloper-1.5.4.59.40-1.noarch.rpm
and I receive the following message:
error: Failed dependencies: /bin/sh is needed by
sqldeveloper-1.5.4.59.40-1.noarch.
What can I do to fix it?

Thanks!
Re: Install SQLDEVELOPER [message #403425 is a reply to message #403418] Fri, 15 May 2009 09:29 Go to previous messageGo to next message
Mahesh Rajendran
Messages: 10672
Registered: March 2002
Location: oracleDocoVille
Senior Member
Account Moderator
Have you installed alien?
Re: Install SQLDEVELOPER [message #403426 is a reply to message #403418] Fri, 15 May 2009 09:33 Go to previous messageGo to next message
Mahesh Rajendran
Messages: 10672
Registered: March 2002
Location: oracleDocoVille
Senior Member
Account Moderator
You need to install alien to convert the RPM.
Install alien and the use it to convert RPM.
Re: Install SQLDEVELOPER [message #403431 is a reply to message #403426] Fri, 15 May 2009 09:58 Go to previous messageGo to next message
angav
Messages: 5
Registered: May 2009
Junior Member
I downloaded and writed alien sqldeveloper-1.5.4.59.40-1.noarch.rpm. What to do next?

Thanks a lot!
Re: Running SQLDEVELOPER [message #403436 is a reply to message #180893] Fri, 15 May 2009 10:32 Go to previous messageGo to next message
BlackSwan
Messages: 25035
Registered: January 2009
Location: SoCal
Senior Member
http://www.lmgtfy.com/?q=ubuntu+alien+convert+rpm
Re: Install SQLDEVELOPER [message #403437 is a reply to message #403431] Fri, 15 May 2009 10:54 Go to previous messageGo to next message
Mahesh Rajendran
Messages: 10672
Registered: March 2002
Location: oracleDocoVille
Senior Member
Account Moderator
#convert using alien . output truncated.
magvivek@kalyani:~/Desktop/downloads$ sudo alien -cv sqldeveloper-1.5.4.59.40-1.noarch.rpm

#check for java versions. install jdk if not found.
magvivek@kalyani:~/Desktop/downloads$ sudo update-alternatives --config java

There are 2 alternatives which provide `java'.

  Selection    Alternative
-----------------------------------------------
*         1    /usr/lib/jvm/java-1.5.0-sun/jre/bin/java
 +        2    /usr/lib/jvm/java-6-sun/jre/bin/java

Press enter to keep the default[*], or type selection number: 


# install sqldeveloper

magvivek@kalyani:~/Desktop/downloads$ sudo dpkg -i sqldeveloper_1.5.4.59.40-2_all.deb
(Reading database ... 177054 files and directories currently installed.)
Preparing to replace sqldeveloper 1.5.4.59.40-2 (using sqldeveloper_1.5.4.59.40-2_all.deb) ...
Unpacking replacement sqldeveloper ...
Setting up sqldeveloper (1.5.4.59.40-2) ...


#create an environment
magvivek@kalyani:~/Desktop/downloads$ touch ~/.sqldeveloper/jdk
magvivek@kalyani:~/Desktop/downloads$ mkdir -p ~/.sqldeveloper
magvivek@kalyani:~/Desktop/downloads$ touch ~/.sqldeveloper/jdk
magvivek@kalyani:~/Desktop/downloads$ echo /usr/lib/jvm/java-6-sun >  ~/.sqldeveloper/jdk

#invoke sqldeveloper. later add permissions for the user (so no sudo is required.)
magvivek@kalyani:~/Desktop/downloads$ sudo sqldeveloper

Oracle SQL Developer
 Copyright (c) 2008, Oracle. All rights reserved. 
Re: Install SQLDEVELOPER [message #403694 is a reply to message #403437] Mon, 18 May 2009 02:33 Go to previous messageGo to next message
angav
Messages: 5
Registered: May 2009
Junior Member
Hi! I did all these you described until the command:
sudo dpkg -i sqldeveloper_1.5.4.59.40-2_all.deb
when I received the following:
(Reading database ... 197337 files and directories currently installed.) Unpacking sqldeveloper (from sqldeveloper_1.5.4.59.40-2_all.deb) ...
dpkg-deb: unexpected end of file in between members in sqldeveloper_1.5.4.59.40-2_all.deb
dpkg: error processing sqldeveloper_1.5.4.59.40-2_all.deb (--install):
subprocess dpkg-deb --fsys-tarfile returned error exit status 2
Errors were encountered while processing:
sqldeveloper_1.5.4.59.40-2_all.deb

Any help?

Re: Install SQLDEVELOPER [message #403728 is a reply to message #403694] Mon, 18 May 2009 06:08 Go to previous messageGo to next message
Mahesh Rajendran
Messages: 10672
Registered: March 2002
Location: oracleDocoVille
Senior Member
Account Moderator
I assumed you have already installed alien and used the correct file. I would startover.
Do this first and try again.
May be, you have not installed tar

sudo apt-get install tar
sudo apt-get install alien


And which Ubuntu version are you using?


Edit:
Added install for tar

[Updated on: Mon, 18 May 2009 06:10]

Report message to a moderator

Re: Install SQLDEVELOPER [message #403732 is a reply to message #403728] Mon, 18 May 2009 06:41 Go to previous messageGo to next message
angav
Messages: 5
Registered: May 2009
Junior Member
I use Ubuntu 8.10.
I wrote those and I have the following:
(Reading database ... 197475 files and directories currently installed.)
Unpacking sqldeveloper (from sqldeveloper_1.5.4.59.40-2_all.deb) ...
dpkg-deb: unexpected end of file in between members in sqldeveloper_1.5.4.59.40-2_all.deb
dpkg: error processing sqldeveloper_1.5.4.59.40-2_all.deb (--install):
subprocess dpkg-deb --fsys-tarfile returned error exit status 2
Errors were encountered while processing:
sqldeveloper_1.5.4.59.40-2_all.deb
Re: Install SQLDEVELOPER [message #403735 is a reply to message #403732] Mon, 18 May 2009 06:52 Go to previous messageGo to next message
Mahesh Rajendran
Messages: 10672
Registered: March 2002
Location: oracleDocoVille
Senior Member
Account Moderator
Seems like a bug with dpkg. I cannot reproduce the case in Ubuntu 810
or
Your rpm file is corrupt.
Clean up the work.
Reboot.
Download rpm again (if you are ftp'ing it, use BIN option).
try again.
Re: Install SQLDEVELOPER [message #403741 is a reply to message #403735] Mon, 18 May 2009 07:16 Go to previous message
angav
Messages: 5
Registered: May 2009
Junior Member
Thanks a lot for the help anyway.
I'll try to do all these again.
Previous Topic: How to install Oracle 9i on RHEL 4.0
Next Topic: Tape Drive
Goto Forum:
  


Current Time: Sat Dec 03 16:28:07 CST 2016

Total time taken to generate the page: 0.08798 seconds