Home » SQL & PL/SQL » Client Tools » SP2-0640: Not connected
SP2-0640: Not connected [message #180180] Fri, 30 June 2006 08:58 Go to next message
pyaranoid
Messages: 5
Registered: June 2006
Junior Member
Hi Gurus,

I have a weird problem all of a sudden. My Oracle DB is working properly till yesterday. When i tried connecting to it today using scott/tiger@orcl its not accepting.

So i entered as system/system..it connected

when i tried to select instance_name from v$instance; it is giving me error

SP2-0640: Not connected

Please find me a solution asap

Thanks

Suresh
Re: SP2-0640: Not connected [message #180181 is a reply to message #180180] Fri, 30 June 2006 09:05 Go to previous messageGo to next message
wpaillan
Messages: 35
Registered: March 2005
Location: Santiago - Chile
Member


hi

SP2-0640 Not connected.
PASSW[ORD] [username]

Cause: The PASSWORD command was issued when there was no connection to the Oracle instance.

Action: Connect to the Oracle database before re-issuing the PASSWORD command.

Re: SP2-0640: Not connected [message #180183 is a reply to message #180181] Fri, 30 June 2006 09:10 Go to previous messageGo to next message
JRowbottom
Messages: 5933
Registered: June 2006
Location: Sunny North Yorkshire, ho...
Senior Member
Well, that was helpful.

It doesn't look like your database is up.

Have a look in the alert log, and see if that reports any recent errors.
Re: SP2-0640: Not connected [message #180274 is a reply to message #180180] Sun, 02 July 2006 12:38 Go to previous messageGo to next message
pyaranoid
Messages: 5
Registered: June 2006
Junior Member
Hi Gurus,

Thank you very much for the replies. My problem is solved now. Actually i have altered my host name for some reasons. Now i have again changed the host name to the previous one and now it is working fine now.

Smile

Suresh
Re: SP2-0640: Not connected [message #180319 is a reply to message #180274] Mon, 03 July 2006 01:54 Go to previous messageGo to next message
Littlefoot
Messages: 19525
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Why didn't you mention this before? Now it looked like "I drove my car yesterday, but can't do that today. Oh, I forgot to say that I, for some reason, removed its engine. When I put it back, it works OK again."
Re: SP2-0640: Not connected [message #454915 is a reply to message #180180] Sat, 08 May 2010 09:07 Go to previous messageGo to next message
keepitsimple07
Messages: 1
Registered: May 2010
Location: india
Junior Member
hi all,

i have installed Oracle10g on Solaris10[x86]
i can open my browser, and can login to
http:/ / localhost:1158 / em fine
using
username; sys
password; --password--
connect as; SYSDBA

however when i try to login to SQLPLUS on the command line, using the command 'connect'
and entering the above username and password, it doesnt let me login saying; invaid username and password.

so, how do i login to SQLPLUS?
please let em know
Re: SP2-0640: Not connected [message #454925 is a reply to message #454915] Sat, 08 May 2010 09:24 Go to previous message
Michel Cadot
Messages: 58938
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
With SQL*Plus you have to follow the whole "connect" syntax to be able to connect as I think your database is not local.

http://download.oracle.com/docs/cd/B19306_01/server.102/b14357/ch3.htm#sthref610

Regards
Michel
Previous Topic: Able to connect Database by using SQL*PLUS, but getting error while trying to connect through TOAD (
Next Topic: spool only time and stats
Goto Forum:
  


Current Time: Fri Aug 29 21:38:50 CDT 2014

Total time taken to generate the page: 0.11562 seconds