Home » RDBMS Server » Server Administration » Error while installing asmlib @vmware
Error while installing asmlib @vmware [message #173226] Sat, 20 May 2006 09:15 Go to next message
mghong
Messages: 27
Registered: February 2006
Location: KL
Junior Member
Hi guys

I trying to experience Automatic Storage Management (ASM) at my vmware 10gr2..

My Cents0s already have 10gr2 installed , i know there is an option on Console to migrate to ASM , but i wanted to test out how the detail part of ASmlib.

So i follow the guide to download those rpm file after i get my kernel version 2.6.9-22.EL

* oracleasm-support-2.0.1-1.i386.rpm
* oracleasmlib-2.0.1-1.i386.rpm
* oracleasm-2.6.9-22.EL-2.0.1-1.i686.rpm

for the first time i do an
Quote:

rpm -Uvh oracleasm-support-2.0.1-1.i386.rpm \
oracleasmlib-2.0.1-1.i386.rpm \
oracleasm-2.6.9-22.EL-2.0.1-1.i686.rpm


everything go smooth , then i do an
# /etc/init.d/oracleasm configure

and this error message come out.
Loading module "oracleasm": Unable to load module "oracleasm"
[FAILED]

I try to copy using the latest oracleasm-2.6.9-34.ELsmp-2.0.1-1.i686.rpm on the oracleasm.ko and overwrite into the current oracleasm

and try again this oracleasm configure , and this new error come out
Quote:


Mounting ASMlib driver filesystem: mount: block device oracleasmfs is write-protected, mounting read-only
mount: cannot mount block device oracleasmfs read-only
Unable to mount ASMlib driver filesystem
[FAILED]



Is there any one experice this error ?
Re: Error while installing asmlib @vmware [message #293900 is a reply to message #173226] Tue, 15 January 2008 10:02 Go to previous messageGo to next message
mccrist
Messages: 3
Registered: January 2008
Location: Hungary
Junior Member

Hi,

Pls try: sh /etc/init.d/oracleasm configure
I assume it will work.

I haven't found out the reason of this bug/error, but I'm on it.

Best regards,
Krisztian
Re: Error while installing asmlib @vmware [message #294417 is a reply to message #173226] Thu, 17 January 2008 09:21 Go to previous messageGo to next message
d.c.b.a
Messages: 44
Registered: March 2005
Location: China
Member

Please try:

service oracleasm configure

Fangxin.Lou, Senior DBA

[Updated on: Thu, 17 January 2008 12:45] by Moderator

Report message to a moderator

Re: Error while installing asmlib @vmware [message #294441 is a reply to message #294417] Thu, 17 January 2008 12:00 Go to previous messageGo to next message
mccrist
Messages: 3
Registered: January 2008
Location: Hungary
Junior Member

[root@dl385db ~]# chkconfig --list|grep asm
oracleasm 0:off 1:off 2:on 3:on 4:on 5:on 6:off
[root@dl385db ~]# service oracleasm configure
Configuring the Oracle ASM library driver.

This will configure the on-boot properties of the Oracle ASM library
driver. The following questions will determine whether the driver is
loaded on boot and what permissions it will have. The current values
will be shown in brackets ('[]'). Hitting <ENTER> without typing an
answer will keep that current value. Ctrl-C will abort.

Default user to own the driver interface [oracle]:
Default group to own the driver interface [dba]:
Start Oracle ASM library driver on boot (y/n) [y]:
Fix permissions of Oracle ASM disks on boot (y/n) [y]:
Writing Oracle ASM library driver configuration: [ OK ]
Mounting ASMlib driver filesystem: mount: block device oracleasmfs is write-protected, mounting read-only
mount: cannot mount block device oracleasmfs read-only
Unable to mount ASMlib driver filesystem
[FAILED]

Probably the error comes from missing env. variables. I will check it soon.
Best regards,
Krisztian
Re: Error while installing asmlib @vmware [message #294712 is a reply to message #294417] Fri, 18 January 2008 09:58 Go to previous messageGo to next message
mccrist
Messages: 3
Registered: January 2008
Location: Hungary
Junior Member

In my case the the error rooted in selinux.


temporary solution:
echo 0 > /selinux/enforce

permanent solution:
vi selinux
#SELINUX=enforcing
SELINUX=disabled

Best regards,
Krisztian
icon7.gif  Re: Error while installing asmlib @vmware [message #311192 is a reply to message #293900] Thu, 03 April 2008 12:17 Go to previous message
Chistophe_L
Messages: 1
Registered: April 2008
Location: Montreal - Canada
Junior Member
mccrist wrote on Tue, 15 January 2008 11:02
Hi,

Pls try: sh /etc/init.d/oracleasm configure
I assume it will work.

I haven't found out the reason of this bug/error, but I'm on it.

Best regards,
Krisztian



Thanks Krisztian... You solved my problem... Smile

Best regards

Christophe

Previous Topic: Move a node to new domain
Next Topic: Revalidating utl_mail package
Goto Forum:
  


Current Time: Sun Dec 11 04:15:27 CST 2016

Total time taken to generate the page: 0.08531 seconds