Home » RDBMS Server » Server Administration » sqlplus
sqlplus [message #170833] Fri, 05 May 2006 07:25 Go to next message
maoro
Messages: 310
Registered: May 2005
Senior Member
hello
i installed oracle9i on AIX 5.2, after the installation was done i was able to run "oemapp console" , rman ,...
but when i try to run sqlplus i got the error :

message file sp1<lang>.msb not found
sp2-0750: you may need to set ORACLE_HOME to your oracle software directory


i guess ORACLE_HOME is set right otherwise i wont be able to run oemapp or rman,
but how to check if the file sp1<lang>.msb is missing or not and how to recover it in case its missing
thanks

so much for your kind help
Re: sqlplus [message #170836 is a reply to message #170833] Fri, 05 May 2006 07:41 Go to previous messageGo to next message
Mahesh Rajendran
Messages: 10672
Registered: March 2002
Location: oracleDocoVille
Senior Member
Account Moderator
it is to do with ORACLE_HOME and PATH.
make you have ORACLE_HOME defined and
PATH=$PATH:$ORACLE_HOME/bin
Re: sqlplus [message #170846 is a reply to message #170833] Fri, 05 May 2006 08:51 Go to previous messageGo to next message
maoro
Messages: 310
Registered: May 2005
Senior Member
sir
if oracle_home and path are not set right how could i run oemapp or rman ?
i guess it has to do with the missing sp1<lang>.msb file
do u know how to restore these file

thanks
Re: sqlplus [message #170848 is a reply to message #170846] Fri, 05 May 2006 08:58 Go to previous messageGo to next message
Mahesh Rajendran
Messages: 10672
Registered: March 2002
Location: oracleDocoVille
Senior Member
Account Moderator
Restore the file?
Interesting. If you had a problem with that 'file' you cannot access anything.
As said before, Problem is your ENVIRONMENT. It has nothing to do with anything else. Set those variables in your profile and try.
http://www.orafaq.com/forum/?SQ=3eb20e62dd0ac9b3a4aa28748ed2d0b9&t=search&srch=message+file+sp1%3Clang%3E.msb+not+found&b tn_submit=Search&field=all&forum_limiter=&search_logic=AND&sort_order=DESC&author=

[Updated on: Fri, 05 May 2006 08:59]

Report message to a moderator

Re: sqlplus [message #240427 is a reply to message #170833] Thu, 24 May 2007 16:26 Go to previous messageGo to next message
dillip777
Messages: 21
Registered: May 2007
Location: USA
Junior Member

Hi,

This problem is solved or not???

If not, contact me. I can solve ur problem
Re: sqlplus [message #240428 is a reply to message #240427] Thu, 24 May 2007 16:45 Go to previous message
DreamzZ
Messages: 1666
Registered: May 2007
Location: Dreamzland
Senior Member
check the directory permissions.
Previous Topic: dba_views
Next Topic: redologfile
Goto Forum:
  


Current Time: Thu Dec 08 14:10:05 CST 2016

Total time taken to generate the page: 0.08627 seconds