Home » Developer & Programmer » Forms » ATT colum
ATT colum [message #166372] Thu, 06 April 2006 01:02 Go to next message
hidayatk
Messages: 25
Registered: November 2005
Junior Member
i have table of three colums

1. Serial#
2. Person Name
3. Attachement (Any file)

i have 2 problems..
A. how would i resolve this 3rd colum using database 10g and forms9i? what should b colum datatype and subsequent form' item type?
B. Is there any way to browse, then select a file so that complete file path insert into running Form' item?

looking for assistance

regards

-Hidayat khattak

[Updated on: Thu, 06 April 2006 01:50]

Report message to a moderator

Re: ATT colum [message #166404 is a reply to message #166372] Thu, 06 April 2006 03:09 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Make column three a 'blob'. Search this forum for 'blob' other people have asked a similar question.

To 'point to a file' then use 'web util' which you can also search for in this forum.

David
Re: ATT colum [message #167569 is a reply to message #166404] Fri, 14 April 2006 00:31 Go to previous messageGo to next message
hidayatk
Messages: 25
Registered: November 2005
Junior Member
Sir,

As i told i m using application Server 10g (9.0.4). to work with 'web util', i downloaded and configured as per insructions in web_util.pdf. i run a demo code supplied in .pdf and found error like,

-> WebUtil Error:oracle.forms.webutil.oleFunctions bean not found. cliend.crate_obj will not work

the code is
DECLARE
 app CLIENT_OLE2.OBJ_TYPE;
 docs CLIENT_OLE2.OBJ_TYPE;
 doc CLIENT_OLE2.OBJ_TYPE;
 selection CLIENT_OLE2.OBJ_TYPE;
 args CLIENT_OLE2.LIST_TYPE;
BEGIN
 -- create a new document
 app := CLIENT_OLE2.CREATE_OBJ('Word.Application');
 CLIENT_OLE2.SET_PROPERTY(app,'Visible',1);
 docs := CLIENT_OLE2.GET_OBJ_PROPERTY(app, 'Documents');
 doc := CLIENT_OLE2.INVOKE_OBJ(docs, 'add');
 selection := CLIENT_OLE2.GET_OBJ_PROPERTY(app, 'Selection');
 -- insert data into new document from long item
 CLIENT_OLE2.SET_PROPERTY(selection, 'Text', 'this is a test message');
 -- save document as example.tmp
 args := CLIENT_OLE2.CREATE_ARGLIST;
 CLIENT_OLE2.ADD_ARG(args, 'c:\example.doc');
 CLIENT_OLE2.INVOKE(doc, 'SaveAs', args);
 CLIENT_OLE2.DESTROY_ARGLIST(args);
 -- close example.tmp
 args := CLIENT_OLE2.CREATE_ARGLIST;
 CLIENT_OLE2.ADD_ARG(args, 0);
 CLIENT_OLE2.INVOKE(doc, 'Close', args);
 CLIENT_OLE2.DESTROY_ARGLIST(args);
 CLIENT_OLE2.RELEASE_OBJ(selection);
 CLIENT_OLE2.RELEASE_OBJ(doc);
 CLIENT_OLE2.RELEASE_OBJ(docs);
 -- exit MSWord
 CLIENT_OLE2.INVOKE(app,'Quit');
END;
looking 4 assistance

-hidayatt khattak

[Updated on: Mon, 17 April 2006 21:43] by Moderator

Report message to a moderator

Re: ATT colum [message #167594 is a reply to message #166372] Fri, 14 April 2006 05:34 Go to previous messageGo to next message
hidayatk
Messages: 25
Registered: November 2005
Junior Member
Sir,

i have installed Developer Suite 10g Forms (10.1.2.0.2).
i did run the code (in my previous post). same error, i m facing.

please help me in solving this error

regard

-hidayat

Re: ATT colum [message #167907 is a reply to message #167569] Mon, 17 April 2006 21:42 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Have you signed the jar files as the documentation specified? Can you get the demonstration form to work?

David

[Updated on: Mon, 17 April 2006 21:42]

Report message to a moderator

Re: ATT colum [message #167936 is a reply to message #167907] Tue, 18 April 2006 00:38 Go to previous messageGo to next message
hidayatk
Messages: 25
Registered: November 2005
Junior Member
Sir,

thank u for being helping. please give ur kind attention to the following 2 issues.

1. i have signed both the jar files (frmwebutil & jacob). i did this through windows command prompt (as per instructions in webutil.pdf) and got message like '...done'. i didn't get any 'demo form'

2. i attached 'webutil.pll' to the form. OLE2 works on Application server .e.g., create word document file, put data the save it. but when i do this from client machine (although i use 'CLIENT_OLE2'), i get two errors in a row,

i -the WEBUTIL object group is not available in this form. WebUtil can not work ( an alert displays 'Plz acknowledge')

ii-WebUtil Error:oracle.forms.webutil.oleFunctions bean not found. cliend.create_obj will not work

Looking 4 ur attention

Regards

Hidayat

[Updated on: Tue, 18 April 2006 00:45]

Report message to a moderator

Re: ATT colum [message #167966 is a reply to message #167936] Tue, 18 April 2006 02:37 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Please reread the instructions for using web_util. You need to 'drag across' the web_util object group from the opened object library to your opened form. Also, the web_util jar has to be available on the aplication server so that the user's browser can pull it down in the same way that the Oracle JInitiator was pulled down the first time they started their first Oracle Forms application.

David
Re: ATT colum [message #362258 is a reply to message #167966] Mon, 01 December 2008 09:10 Go to previous message
simonkimbrell
Messages: 4
Registered: September 2008
Junior Member
Add a bean object to your data block with the implentation class as in your error:
oracle.forms.webutil.olefunction
Previous Topic: Make a data block read only
Next Topic: Very confusing doubt about the data block
Goto Forum:
  


Current Time: Sun Dec 11 04:15:48 CST 2016

Total time taken to generate the page: 0.28593 seconds