Home » Developer & Programmer » Warehouse Builder » OWB runtime audit browser jobs stuck on busy - mappings won't execute.
OWB runtime audit browser jobs stuck on busy - mappings won't execute. [message #165374] Wed, 29 March 2006 13:03 Go to next message
dossantosp
Messages: 2
Registered: March 2006
Junior Member
Hi
Of late, our daily loads in workflow started to get stuck randomly with a busy status. We simply expedited these with failure and restarted our workflows.

In doing so, in owb runtime audit browser, parent level or wrappers completed but some of the the mappings within them stayed with busy status.

According to Doc ID: Note:336674.1 in Metalink, one should :
1) identify busy processes using the script in owborahome\owb\rtp\sql\list_requests.sql
2) if owb 9.2, then exec abort_exec_request.sql for specif <Audit Id> and then
3) execute deactivate_execution.sql script.

Step 3 fails, with
ORA-20003: The object is not in a valid state for the requested operation
ORA-06512: at "OWBRUN.WB_RTI_EXCEPTIONS", line 94
ORA-06512: at "OWBRUN.WB_RTI_EXECUTION", line 694
ORA-06512: at "OWBRUN.WB_RT_EXECUTION", line 77
ORA-06512: at line 4

Has anyone experience a similar problem of deleting busy jobs in owb runtime audit browser?
How have you overcome this?

I believe that values in specific audit browser tables have not been updated, causing jobs to fail. I don't believe it is related to the mappings in question.

Thanks in advance.
Paulo
dossantosp@miu.wits.ac.za



Re: OWB runtime audit browser jobs stuck on busy - mappings won't execute. [message #165522 is a reply to message #165374] Thu, 30 March 2006 15:18 Go to previous messageGo to next message
ottkaresz
Messages: 12
Registered: March 2006
Location: Hungary
Junior Member
Hi

Change the sequence of the scripts:

1) list_requests.sql
2) deactivate_execution.sql
3) abort_exec_request.sql

This is the right sequence!!!

Ott Karesz
http://www.trendo-kft.hu
Re: OWB runtime audit browser jobs stuck on busy - mappings won't execute. [message #165767 is a reply to message #165522] Sat, 01 April 2006 11:07 Go to previous messageGo to next message
dossantosp
Messages: 2
Registered: March 2006
Junior Member
Thanks for your reply but I still get the same error, now in step 2. do you have any further suggestions?

regards
Paulo
dossantosp@miu.wits.ac.za
Re: OWB runtime audit browser jobs stuck on busy - mappings won't execute. [message #166389 is a reply to message #165767] Thu, 06 April 2006 02:09 Go to previous message
ottkaresz
Messages: 12
Registered: March 2006
Location: Hungary
Junior Member
Hi

It works to me, do you use the right ID?

Ott Karesz
http://www.trendo-kft.hu
Previous Topic: Data Generator Operator
Next Topic: Informatica Source File Load Recovery
Goto Forum:
  


Current Time: Sun Sep 21 19:10:29 CDT 2014

Total time taken to generate the page: 0.18387 seconds