Home » Non-English Forums » German » special chars and german "umlaute"
special chars and german "umlaute" [message #163590] Fri, 17 March 2006 06:33
Dr.Schmidt
Messages: 1
Registered: March 2006
Location: Frankfurt/M Germany
Junior Member
Hi,

I'm currently trying to get an new (development-) Webserver working but the oparting system starts getting me crazy. Embarassed

My Webserver is running on Suse Linux 9 with apache 2 and a self compiled php including support for oracle. The Database Server (running oracle) is a second maschine. The connection between these maschines works fine (a thought first...). I could perform all queries I'd like. However as soon as I insert a german special char e. g. or just a normal special char like the system just inserts a questionmark (for both special chars).

If I insert one of this chars using a "normal" sql client it works just fine. I could insert and select all of this chars.

I found several pages which discribes how to fix this issue. Most of them recomended to add the following line to /etc/profile.local or /etc/profile:

export NLS_LANG=AMERICAN_AMERICA.WE8ISO8859P1

However it doesn't work in my environment. (The Database is using this charset as well).

Could anyone help me or give me a hint how to fix this problem?

Thanks & sorry for my bad english!
Previous Topic: German date problem
Next Topic: searching for good DBA training in germany
Goto Forum:
  


Current Time: Tue Sep 02 16:20:52 CDT 2014

Total time taken to generate the page: 0.19314 seconds