Home » Developer & Programmer » Warehouse Builder » how can i fill my deployed schema with data ???
how can i fill my deployed schema with data ??? [message #159044] Wed, 15 February 2006 16:57 Go to next message
s8472
Messages: 15
Registered: February 2006
Junior Member
my problem is that i created a target schema, but the deployment manager only deploys the schema perfectly WITHOUT copying the data from the source database to the target schema.
my sources are a flatfile and 2 oracle databases. i connected the attributes in a mapping with a staging_table and pass the data on to the dimensions and the cube.

plz, can anybody help me quick with that?


greetings
s8472

Re: how can i fill my deployed schema with data ??? [message #159083 is a reply to message #159044] Thu, 16 February 2006 01:04 Go to previous messageGo to next message
Maaher
Messages: 7041
Registered: December 2001
Senior Member
If you look at the scripts the deployment manager generates, you'll see they're just creation scripts.

After installation (deployment), you have to run your mapping(s) or workflow(s). You do that from the deployment manager, as an Oracle job (OEM) or through Oracle Workflow.

What was the result of your run? You can check that out through the Runtime Audit Browser. Any errors in there?

MHE
Re: how can i fill my deployed schema with data ??? [message #159123 is a reply to message #159044] Thu, 16 February 2006 05:18 Go to previous messageGo to next message
jayadesh
Messages: 10
Registered: February 2006
Location: INDIA
Junior Member
HELLO GUYS,
DEPLOY MANAGER IS WHICH WILL HANDLE THE METADATA. THAT IS IT WILL MAKE U READY TO EXECUTE THE MAPPINGS OR WHATEVER IT MAY BE..
ONCE U WANT TO TAKE THE FLAT FILE AS THE SOURCE YOU HAVE TO PLACE THE FLAT FILE SHOULE BE PLACED IN THE SERER SYSTEM OR THERE IS SOME OTHER CONTROL FILE (I AM NOT SURE) THEN DEPLOY AFTER THAT U CAN EXECUTE THE MAPPING.
THANKS
Re: how can i fill my deployed schema with data ??? [message #159144 is a reply to message #159044] Thu, 16 February 2006 06:35 Go to previous messageGo to next message
s8472
Messages: 15
Registered: February 2006
Junior Member
hi MHE,

i tried to deploy a mappings, but constantly i get the following 6 warnings, if i push the "deploy.." button:

ORA-06550: line 13, column 9: PL/SQL: ORA-00942: table or view does not exist
ORA-06550: line 11, column 3: PL/SQL: SQL Statement ignored
ORA-06550: line 23, column 9: PL/SQL: ORA-00942: table or view does not exist
ORA-06550: line 21, column 3: PL/SQL: SQL Statement ignored
ORA-06550: line 94, column 15: PL/SQL: ORA-00942: table or view does not exist
ORA-06550: line 87, column 7: PL/SQL: SQL Statement ignored

i don't understand this. i created some very simple mappings: for example a 1:1 mapping from a small oralce db to a staging_table. deploying the staging_table is no problem. but when it comes to deploy the mapping, it passes the validation and generation, but gives the warning after pressing the "deploy..." button.

THX so much MHE for your answer (btw: my icq-nr is 113348565)

greetings
s8472
Re: how can i fill my deployed schema with data ??? [message #159161 is a reply to message #159044] Thu, 16 February 2006 08:03 Go to previous messageGo to next message
s8472
Messages: 15
Registered: February 2006
Junior Member
...it seems, that the msg "ORA-00942: table or view does not exist" is the key to solve the prob!?

i import the oracle db from schema_A, and target schema_B for the dw. in order to see, if this is the prob, i tried to build a table_A with one coloumn "dates" in the target schema_B and inserted two dates. after creating the target table_B and a mapping (table_A.date -> table_B.date), i deployed the table_B and mapping into schema_B WITHOUT any errors or warnings.
so it worked, but as i pressed the execute button for "copying" the two dates from table_A to table_B, no dates were transfered(0, 0, 0, 0)... cause it stops at the error: "RPE-01013: SQL Loader reported error condition. Nummer 1."

so i have now two questions:

- what else do i have to consider, if i want to execute a mapping? i thought the executing will "copy" the data from one to another table defined by the mapping.

- why can't i import tables from other schemas, use them in the owb and deploy them to my target schema? i thought giving my dw_module in owb-client the db-link to import metadata from a source would give me the possibility to access to another schema than the target schema.


thx so much...

greetings
s8472



[Updated on: Thu, 16 February 2006 10:17]

Report message to a moderator

Re: how can i fill my deployed schema with data ??? [message #159204 is a reply to message #159044] Thu, 16 February 2006 13:39 Go to previous messageGo to next message
s8472
Messages: 15
Registered: February 2006
Junior Member
... it seems that the problem is with the two modules you build in the owb client navigation tree ([project]/database/oracle) and their connection.

i created a source_mod (module-type = source), which imports a table from the owb_user_schema. and i created a datawarehouse_mod (module-type = dw) to create my dw. so if i connect the table from the source_mod to the target table in the datawarehouse_mod inside of one mapping, the 6 warning messages will appear. but if i import the source table to my datawarehouse_mod and deploy that table too, then the warnings are gone.
unfortunately it makes no sense importing data from the target schema, because it is the target schema and not the source.

so can anybody help with setting up the relationship the source module to the datawarehouse module correctly???
Re: how can i fill my deployed schema with data ??? [message #159301 is a reply to message #159044] Fri, 17 February 2006 04:12 Go to previous messageGo to next message
s8472
Messages: 15
Registered: February 2006
Junior Member
i solved this problem, creating the source table in the design schema. now, there are no 6 warnings. maybe you have to grant more system privileges to the schema-users too.

now, the deployment and execution works another problem occurs. owb doesnt transfer the data from the source to the target table. i created a new topic for this prob here:

http://www.orafaq.com/forum/t/59118/82490/

plz help me with this problem!
Re: how can i fill my deployed schema with data ??? [message #159770 is a reply to message #159301] Tue, 21 February 2006 07:17 Go to previous message
s8472
Messages: 15
Registered: February 2006
Junior Member
s8472 wrote on Fri, 17 February 2006 04:12

i solved this problem, creating the source table in the design schema. now, there are no 6 warnings. maybe you have to grant more system privileges to the schema-users too.



the target schema must have "SELECT ANY TABLE" privileges!


greetings
s8472
Previous Topic: how could i easily check my dw
Next Topic: FILE EXISTS Activity (Process Flows)
Goto Forum:
  


Current Time: Tue Jul 29 20:12:16 CDT 2014

Total time taken to generate the page: 0.25729 seconds