Home » Server Options » Data Guard » last archive log applied + archive log lag in standby db
last archive log applied + archive log lag in standby db [message #149833] Mon, 05 December 2005 04:02 Go to next message
xaverianite
Messages: 3
Registered: November 2005
Junior Member
Hi All,
I've created a standby database, how do I see the information about the last archive log which had been applied in the standby database?
I have configured tnsnames.ora and listner.ora for automatic transfer of archive log from primary to standby db and standby db is in managed recovery state. Is it possible that I can set some of time lag in primary db or standby db after which archive log should be transferred to standby db or after which standby db should check for archive log to be applied?

thank you,
Saurabh.

[Updated on: Mon, 05 December 2005 04:04]

Report message to a moderator

Re: last archive log applied + archive log lag in standby db [message #150280 is a reply to message #149833] Wed, 07 December 2005 00:21 Go to previous messageGo to next message
tarundua
Messages: 1080
Registered: June 2005
Location: India
Senior Member
Hi sourabh,

-->how do I see the information about the last archive log which had been applied in the standby database?

Quote:

On the standby database, query the V$ARCHIVED_LOG view to verify the archived redo log was applied.
SQL> SELECT SEQUENCE#,APPLIED FROM V$ARCHIVED_LOG
ORDER BY SEQUENCE#;



I dont think that Oracle provides any facility for time lag but you can see this discussion .

Hope this will help you.

[Updated on: Wed, 07 December 2005 00:23]

Report message to a moderator

Re: last archive log applied + archive log lag in standby db [message #152631 is a reply to message #149833] Sun, 25 December 2005 15:37 Go to previous messageGo to next message
sharan alva
Messages: 57
Registered: November 1999
Member
Hi,
In dataguard you can use the ' delay ' option to delay the application of the logs on the standby, the logs will be shipped immediately to the standby, but the application of this log on the standby will be delayed by the value in minutes provided. Check the datagaurd documentation regarding this parameter.

This is specified in the log_archive_dest_n that is used to ship the logs to the standby

eg log_archive_dest_n = 'service=<servicename> etc .... delay=240'


In the documentation check for Standby with Time-lag

Thanks

SHaran
icon9.gif  Re: last archive log applied + archive log lag in standby db [message #158612 is a reply to message #150280] Mon, 13 February 2006 08:02 Go to previous messageGo to next message
mahmoudmaher
Messages: 1
Registered: February 2006
Location: Bahrain
Junior Member

hi

i tried the mentioned select statment but no data retrive so how can i know what is the last log was applied to my standby database while it not open in mount mode
Re: last archive log applied + archive log lag in standby db [message #159494 is a reply to message #158612] Mon, 20 February 2006 00:59 Go to previous messageGo to next message
sharan alva
Messages: 57
Registered: November 1999
Member
Hi,
For the last log applied check the v$archived_log for the applied column , group by sequence#, Yes indicates that the log has been applied and NO ....

-- Sharan
Re: last archive log applied + archive log lag in standby db [message #389837 is a reply to message #149833] Tue, 03 March 2009 14:24 Go to previous messageGo to next message
suhong
Messages: 8
Registered: May 2007
Location: NJ/NY
Junior Member
sometimes, the applied status did not show correctly for one of the standby databases from primary database by dest_id, although it is applied on physical standby. Anyone who knows or if there is such way to force update applied status on primary database?

Thanks,

- suhong
Re: last archive log applied + archive log lag in standby db [message #389839 is a reply to message #149833] Tue, 03 March 2009 14:33 Go to previous messageGo to next message
BlackSwan
Messages: 25050
Registered: January 2009
Location: SoCal
Senior Member
>the applied status did not show correctly for one of the standby databases from primary database by dest_id, although it is applied on physical standby.

You need to help us by following the Posting Guidelines as stated below.
http://www.orafaq.com/forum/t/88153/0/

The Posting Guidelines clearly state:
"Show us what you did (if you tried it yourself) and how Oracle responded (COPY & PASTE your SQL*Plus session), including errors and/or why the result is not what you want.
Do not describe, explain or report - show us!"

Re: last archive log applied + archive log lag in standby db [message #389844 is a reply to message #389839] Tue, 03 March 2009 14:39 Go to previous message
babuknb
Messages: 1734
Registered: December 2005
Location: NJ
Senior Member

Congratulations...

After two years your started/continuing this topic. As per BlackSwan; Answer all question.

[Updated on: Tue, 03 March 2009 14:41]

Report message to a moderator

Previous Topic: Resource_manager initialization parameter
Next Topic: GET IP Address of client
Goto Forum:
  


Current Time: Fri Dec 09 13:56:48 CST 2016

Total time taken to generate the page: 0.04629 seconds