Home » Developer & Programmer » Forms » frm - 40039 can't attach PL/SQL Library
frm - 40039 can't attach PL/SQL Library [message #142898] Tue, 18 October 2005 05:18 Go to next message
s4sam
Messages: 18
Registered: October 2005
Location: pakistan
Junior Member
hi
i have attached a pl/sql library to my oracle form 10g.
In default.env file set the value of FORMS90_PATH.

After attaching library if i clicks "yes" in "remove path alert" option and run the form , it works fine but next time on opening the same .fmb file, library attachment is lost with FRM-10202 message that can't attach library.
But if i clicks "no" in "remove path alert" and run the form, error occurs that can't attach library(FRM - 40039).


Re: frm - 40039 can't attach PL/SQL Library [message #143052 is a reply to message #142898] Tue, 18 October 2005 23:00 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Default.env defines the Developer Server run time environment. The Forms Builder uses the FORMS90_PATH in the register, as does the DS IF you DON'T have the FORMS90_PATH in the default.env or <servername>.env file.

I suggest that you DO NOT modify the default.env and ONLY place the FORMS90_PATH in the register.

David
Re: frm - 40039 can't attach PL/SQL Library [message #143074 is a reply to message #142898] Wed, 19 October 2005 00:35 Go to previous messageGo to next message
s4sam
Messages: 18
Registered: October 2005
Location: pakistan
Junior Member
yes u r right but i have set the FORMS90_PATH to D:\lib (location of my library) on my machine.
i have also set FORMS90_PATH in default.env file for server runtime environment to D:\Apps\Lib (location of .plx file of library)

when i deploy the form on server and access it from client machine, runtime error message occurs
FRM:40039 : Can't attach library D:\lib\mylib while opening form..

Now i think the problem is 'the path of lib on which the form was designed is different from application server path'
What should i do now.
Re: frm - 40039 can't attach PL/SQL Library [message #143076 is a reply to message #143074] Wed, 19 October 2005 00:41 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
My suggestion is that you have both the source and runtime code in the same directory until you are ready to migrate the application into production at which time ONLY the runtime goes onto the Application Server.

AND remove the FORMS90_PATH from the default.env file.

I VERY STRONGLY suggest that you ONLY have a SINGLE development directory on your PC and it contains ALL the pll and plx files (not just the ones you are changing but a copy of ALL the plls used by your system), ALL the object library files, and the various forms and reports that you are developing.

David
Re: frm - 40039 can't attach PL/SQL Library [message #143077 is a reply to message #143074] Wed, 19 October 2005 00:43 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
You DID select the NON-default option 'Yes', to the 'remove path message', when you attached the PLL to your form, right?

David
Re: frm - 40039 can't attach PL/SQL Library [message #143080 is a reply to message #142898] Wed, 19 October 2005 00:53 Go to previous messageGo to next message
s4sam
Messages: 18
Registered: October 2005
Location: pakistan
Junior Member
when i select "yes" to remove the path then whenever next time i open the .fmb file library attachment is lost.
If i select no runtime error occurs that can't attach library when i deploy application on server.
Re: frm - 40039 can't attach PL/SQL Library [message #143082 is a reply to message #143080] Wed, 19 October 2005 01:04 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Create a short-cut for starting Form Builder and put your development directory in the Start-In of the short-cut.

To what sort of server are you deploying? That is, tell us your whole environment. That is, development is 9i Forms and DS on windows, and deployment is AS on Linux or what?

David
Re: frm - 40039 can't attach PL/SQL Library [message #143083 is a reply to message #142898] Wed, 19 October 2005 01:06 Go to previous messageGo to next message
s4sam
Messages: 18
Registered: October 2005
Location: pakistan
Junior Member
now you mean that at the time of development i attach library and set remove path to "Yes" .
When i deploy the application then i just only place .plx files on server and set default.env (set FORMS90_PATH to the location of library plx file)?????
if your answer is yes then
what should i do when i again open the .fmb file for some changes and have to bear the burden of again setting library path due to lost of library.????
Re: frm - 40039 can't attach PL/SQL Library [message #143084 is a reply to message #142898] Wed, 19 October 2005 01:08 Go to previous messageGo to next message
s4sam
Messages: 18
Registered: October 2005
Location: pakistan
Junior Member
development in 10g forms
Re: frm - 40039 can't attach PL/SQL Library [message #143088 is a reply to message #142898] Wed, 19 October 2005 01:11 Go to previous messageGo to next message
s4sam
Messages: 18
Registered: October 2005
Location: pakistan
Junior Member
development in 10g forms and deployment on 10AS
Re: frm - 40039 can't attach PL/SQL Library [message #143089 is a reply to message #143083] Wed, 19 October 2005 01:12 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
I said
Quote:

I VERY STRONGLY suggest that you ONLY have a SINGLE development directory on your PC and it contains ALL the pll and plx files (not just the ones you are changing but a copy of ALL the plls used by your system), ALL the object library files, and the various forms and reports that you are developing.

please read this again ... it contains the answer to your question.

By the way, deploy is either AS or DS, not Forms. Is this a production system or an assignment to be run on a PC for assessment?

Okay ... we overlapped on answers.

David

[Updated on: Wed, 19 October 2005 01:12]

Report message to a moderator

Re: frm - 40039 can't attach PL/SQL Library [message #143092 is a reply to message #143088] Wed, 19 October 2005 01:13 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
10AS is on Windows or Unix?

David

[Updated on: Wed, 19 October 2005 01:13]

Report message to a moderator

Re: frm - 40039 can't attach PL/SQL Library [message #143093 is a reply to message #143088] Wed, 19 October 2005 01:21 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Please reply with the contents of your Register FORMS90_PATH. You should have multiple paths on this entry. You CAN have both the D:\Apps\Lib and D:\Lib diectories in the setting, but it is hard to get it into the Short-Cut Start-Up.

David
Re: frm - 40039 can't attach PL/SQL Library [message #143103 is a reply to message #142898] Wed, 19 October 2005 01:49 Go to previous messageGo to next message
s4sam
Messages: 18
Registered: October 2005
Location: pakistan
Junior Member
I am using 10g forms and AS on windows plateform for deployment.
Now i have placed all the libraries in a sigle directory on D:\Lib on my machine for development.
Also on application server i have made a directory D:\Lib with all the .plx files of libraries .
Also set default.env's FORM90_PATH to D:\Lib on application server.
now since path for library on my machine & on applicatin server is same thus no problem in library attachment.
All this is done with ur help. Thanks for you valuable time for me. Thans once again
Re: frm - 40039 can't attach PL/SQL Library [message #143105 is a reply to message #143103] Wed, 19 October 2005 01:51 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Did you change the Start-In of your Form Builder short-cut?

David
Re: frm - 40039 can't attach PL/SQL Library [message #143113 is a reply to message #142898] Wed, 19 October 2005 02:25 Go to previous messageGo to next message
s4sam
Messages: 18
Registered: October 2005
Location: pakistan
Junior Member
i have not changed the default start in but set the form90_path in registry for library path.
Re: frm - 40039 can't attach PL/SQL Library [message #143300 is a reply to message #143113] Wed, 19 October 2005 17:34 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
You said that you have a problem (library not found when you open an fmb), I have given you the solution. Whether you use it or not is up to you.

David
Re: frm - 40039 can't attach PL/SQL Library [message #395147 is a reply to message #143052] Tue, 31 March 2009 08:27 Go to previous messageGo to next message
irfankundi786@yahoo.com
Messages: 269
Registered: February 2009
Location: pakistan
Senior Member

What u mean by register?
I can understand your meaning.
please sir me detail steps.
I create .pll and saved it in D:\library.
now where i put this D:\library either in envir variable or where?
I am working in form 10g.
In envire variable there is Forms_path not Forms90_path both are same.
I am waiting form +ve response.
Thanks
Re: frm - 40039 can't attach PL/SQL Library [message #395568 is a reply to message #395147] Wed, 01 April 2009 22:19 Go to previous message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Let's continue this discussion in your other thread http://www.orafaq.com/forum/mv/msg/142929/395169/67467/#msg_395169

David
Previous Topic: Multi Record block with some single record item
Next Topic: Storing images into database using Oracle Forms
Goto Forum:
  


Current Time: Sat Dec 10 01:36:51 CST 2016

Total time taken to generate the page: 0.05372 seconds