Home » Infrastructure » Linux » Install 10g on Debian sarge
icon4.gif  Install 10g on Debian sarge [message #136771] Sat, 10 September 2005 01:22 Go to next message
scislaghi
Messages: 5
Registered: September 2005
Location: Italy, Milan
Junior Member

Hi all,

I'm installing Oracle 10g R2 on debian sarge. I know this is possibile. But I'm only a problem during compilation:

INFO: mv -f /opt/oracle/oracle/product/10.2.0/db_1/bin/dgmgrl /opt/oracle/oracle/product/10.2.0/db_1/bin/dgmgrlO

INFO: mv /opt/oracle/oracle/product/10.2.0/db_1/rdbms/lib/dgmgrl /opt/oracle/oracle/product/10.2.0/db_1/bin/dgmgrl

INFO: chmod 751 /opt/oracle/oracle/product/10.2.0/db_1/bin/dgmgrl

INFO:

INFO: - Linking tg4pwd utility

INFO: rm -f /opt/oracle/oracle/product/10.2.0/db_1/rdbms/lib/tg4pwd

INFO: gcc -o /opt/oracle/oracle/product/10.2.0/db_1/rdbms/lib/tg4pwd -L/opt/oracle/oracle/product/10.2.0/db_1/rdbms/lib/ -L/opt/oracle/oracle/product/10.2.0/db_1/lib/ -L/opt/oracle/oracle/product/10.2.0/db_1/lib/stubs/ -L/usr/lib -lirc /opt/oracle/oracle/product/10.2.0/db_1/rdbms/lib/tg4pwd.o /opt/oracle/oracle/product/10.2.0/db_1/rdbms/lib/defopt.o /opt/oracle/oracle/product/10.2.0/db_1/rdbms/lib/homts.o -lagtsh -lpls10 -lplp10 -lclntsh -lsnls10 -lnls10 -lcore10 -lsnls10 -lnls10 -lcore10 -lsnls10 -lnl
INFO: s10 -lxml10 -lcore10 -lunls10 -lsnls10 -lnls10 -lcore10 -lnls10 /opt/oracle/oracle/product/10.2.0/db_1/lib/libgeneric10.a `cat /opt/oracle/oracle/product/10.2.0/db_1/lib/sysliblist` -Wl,-rpath,/opt/oracle/oracle/product/10.2.0/db_1/lib -lm `cat /opt/oracle/oracle/product/10.2.0/db_1/lib/sysliblist` -ldl -lm -L/opt/oracle/oracle/product/10.2.0/db_1/lib -lvsn10

INFO: /opt/oracle/oracle/product/10.2.0/db_1/lib//libagtsh.so: undefined reference to `nnfyboot'
collect2: ld returned 1 exit status
make: *** [/opt/oracle/oracle/product/10.2.0/db_1/rdbms/lib/tg4pwd] Error 1


I do not know if I miss a library. Who can help me?

Thanks
Stefano

Re: Install 10g on Debian sarge [message #151133 is a reply to message #136771] Tue, 13 December 2005 07:14 Go to previous messageGo to next message
stranger26
Messages: 1
Registered: December 2005
Junior Member
Dear Stefano,

I am not sure where you went wrong as you did not post your complete routine and the erorr you are having does not seem familiar to me.

But if you haven't installed Oracle on Debian yet, try my HowTo.

http://www.gutermann.net/debian-linux/installation-von-oracle-auf-debian-linux-sarge-sid-remote/

It is currently only in German available, but I promise to translate it by the end of this week.
Re: Install 10g on Debian sarge [message #153783 is a reply to message #151133] Wed, 04 January 2006 03:01 Go to previous messageGo to next message
bongout
Messages: 6
Registered: December 2005
Junior Member
Hi Stefano,

maybe you alredy managed to install 10gR1 on Debian. If yes - just add "libaio" and R2 will work fine too...

cheers,

Mat
Re: Install 10g on Debian sarge [message #195847 is a reply to message #136771] Mon, 02 October 2006 15:32 Go to previous message
brech
Messages: 1
Registered: October 2006
Junior Member
The symbol nnfyboot does not occur in libaio -- I checked .a and .so with nm.

I installed package libaio on Ubuntu 6.06.1 LTS before attempting the Oracle install. I still got this error, so probably missing libaio isn't the reason.
Previous Topic: Oracle 9i R2 32 bit
Next Topic: some doubts with the 64 bits architecture
Goto Forum:
  


Current Time: Tue Dec 06 10:35:03 CST 2016

Total time taken to generate the page: 0.11446 seconds