Home » RDBMS Server » Networking and Gateways » Oracle - MS SQL-Server Transparent Gateway not working
Oracle - MS SQL-Server Transparent Gateway not working [message #136310] Wed, 07 September 2005 08:31 Go to next message
brandointheweb
Messages: 25
Registered: August 2005
Location: Germany
Junior Member
Hello from Germany!
I tried to setup Transparent Gateways for MSSQL-Server on my Oracle 9.0.1-machine!
Sincerely it isn't working:
From my point of view I tried everything!
Listener is starting up without any problems and tnsping is working also!

If I try a Select * from TBKUNDE@TESTLINK (database-link) I get the ORA-02068, ORa-28511 and ORA-28509 failure-messages!

I'll give You my configuration-information hoping You can help me!

Transparent gateway installed on Win2003 (Oracle 9.2i with 9.2.0.4-Patch)
MSSQL-Server installed on seperate Win2003-machine (IP: 192.168.48.15)
Database to access: Videothek
MSSQL-User: sa --> password:dd

######### initMARLONTG.ora ############

HS_FDS_CONNECT_INFO="SERVER=192.168.48.15;DATABASE=Videothek"
HS_FDS_FEFAULT_OWNER=sa
#HS_FDS_RECOVERY_ACCOUNT=sa
#HS_FDS_RECOVERY_PWD=dd
HS_FDS_TRACE_LEVEL=DEBUG

######### listener.ora ##############

LISTENER=
(DESCRIPTION_LIST=
(DESCRIPTION=
(ADDRESS_LIST=
(ADDRESS = (PROTOCOL = TCP)
(HOST = 127.0.0.1)
(PORT = 1521)
)
)
)
(DESCRIPTION=
(ADDRESS_LIST=
(ADDRESS = (PROTOCOL = TCP)
(HOST = 127.0.0.1)
(PORT = 1434)
)
)
)
)

SID_LIST_LISTENER =
(SID_LIST =
(SID_DESC =
(GLOBAL_DBNAME = BNS)
(ORACLE_HOME = D:\Programme\DB\Oracle\Ora92)
(SID_NAME = BNS)
)
(SID_DESC =
(SID_NAME = MARLONTG)
(ORACLE_HOME = D:\Programme\DB\Oracle\Ora92)
(PROGRAM = tg4msql)
)
)

########### tnsnames.ora #############
BNS =
(DESCRIPTION =
(ADDRESS_LIST =
(ADDRESS = (PROTOCOL = TCP)(HOST = 127.0.0.1)(PORT = 1521))
)
(CONNECT_DATA =
(SERVICE_NAME = BNS)
(SERVER = DEDICATED)
)
)

TG4MSSQL =
(DESCRIPTION=
(ADDRESS=(PROTOCOL=TCP)(HOST=127.0.0.1)(PORT=1434))
(CONNECT_DATA=(SID=MARLONTG))
(HS=OK)
)

########## SQLNET.ora #########
SQLNET.AUTHENTICATION_SERVICES = (NTS)

########## Created database-link #######
create database link TESTLINK
connect to SA identified by DD
using 'TG4MSSQL';

If I look the trace-files it appears as I'm able to connect to MSSQL but somewhere is an unknown error:
######### trace-file ######


Oracle Corporation --- MITTWOCH SEP 07 2005 14:17:06.853


Heterogeneous Agent Release
9.2.0.4.0


(0) hoagprd (2): ; Entered.
(0) (0): ; [Transparent gateway for MSSQL] version: 3.3.00.00.0030
(0) (0): ; Class version: 117
(0) hoagprd (2): ; Exited with retcode = 0.
(0) hoainit (3): ; Entered.
(0) (0): ; connect string is: defTdpName=MARLONTG;SYNTAX=(ORACLE8_HOA,
(0) BASED_ON=ORACLE8, IDENTIFIER_QUOTE_CHAR="",
(0) CASE_SENSITIVE=CASE_SENSITIVE_QUOTE);BINDING=<navobj>
<binding>
<datasources>
(0) <datasource name='MARLONTG' type='MSSQLODBC'
(0) connect='SERVER=192.168.48.15;DATABASE=Videothek'>
(0) <driverProperties/></datasource></datasources><environment>
<misc
(0) year2000Policy='-1' consumerApi='1' sessionBehavior='4'/><queryProcessor
(0) parserDepth='2000' noInsertParameterization='true'
(0) noThreadedReadAhead='true'/><debug
(0) generalTrace='true'/></environment></binding></navobj>
(0) ORACLE SQL SERVER GATEWAY Log File Started at 07-Sep-05 14:17:06
(0) hoainit (3): ; Exited with retcode = 0.
(0) hoalgon (7): ; Entered. name = SA.
(0) Created new MSSQLODBC connection (15668040)
(0) MESSAGE.C (1): ; Unexpected error opening message catalog
(0) D:\Programme\DB\Oracle\Ora92\tg4msql\nls\eng\msg_base.msg
(0) MESSAGE.C (190): ;
(0) MESSAGE.C (11): ; Cannot open message file
(0) D:\Programme\DB\Oracle\Ora92\tg4msql\nls\eng\msg_base.msg
(0) DATABASE.C (475): ;
(0) hoalgon (7): ; Exited with retcode = 0.
(0) hoaulcp (4): ; Entered.
(0) hoaulcp (4): ; Exited with retcode = 0.
(0) hoauldt (5): ; Entered.
(0) hoauldt (5): ; Exited with retcode = 0.
(0) hoabegn (9): ; Entered. formatID = 306206, hoagttln = 24, hoagttid =
(0) BUILD.06bf057.2.19.40973, hoagtbln = 10, hoagtbid = , tflag = 0, initial = 1
(0) hoabegn (9): ; Exited with retcode = 0.
(0) hoadtab (26): ; Entered. count = 1
(0) hoadtab (26): ; schema_name = , table_name = TBKUNDE

It would be very kind of You to give me any hint!
Thanks for Your patience!
Best regards from Germany!
Marlon
Re: Oracle - MS SQL-Server Transparent Gateway not working [message #300239 is a reply to message #136310] Thu, 14 February 2008 12:15 Go to previous message
heideem74795
Messages: 1
Registered: February 2008
Location: Charleroi
Junior Member
I got the same error message, to solve that issue I had to apply patch 9.2.0.8.
Previous Topic: listener listening on 2 different ports
Next Topic: Newbie: register instance with the listener?
Goto Forum:
  


Current Time: Fri Oct 24 07:26:39 CDT 2014

Total time taken to generate the page: 0.12052 seconds