Home » RDBMS Server » Backup & Recovery » rman error - RMAN-03009
rman error - RMAN-03009 [message #129101] Fri, 22 July 2005 00:29 Go to next message
vimal_vpsk
Messages: 18
Registered: March 2005
Junior Member
hi,

i have problem with rman. When i run the script, it's throwing below error.

RMAN-00571: ===========================================================
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
RMAN-00571: ===========================================================
RMAN-03009: failure of allocate command on t1 channel at 07/21/2005 13:49:06
ORA-19554: error allocating device, device type: SBT_TAPE, device name:
ORA-27211: Failed to load Media Management Library
Additional information: 25



can anyone give solution for this error.

regards
vimal
Re: rman error - RMAN-03009 [message #129153 is a reply to message #129101] Fri, 22 July 2005 03:44 Go to previous messageGo to next message
Mahesh Rajendran
Messages: 10672
Registered: March 2002
Location: oracleDocoVille
Senior Member
Account Moderator
running what?
backup commands or maintainence commands?
whatever it is, RMAN is looking for MML API to talk to the tapes.
Do you have API installed?
Re: rman error - RMAN-03009 [message #129156 is a reply to message #129101] Fri, 22 July 2005 04:12 Go to previous messageGo to next message
vimal_vpsk
Messages: 18
Registered: March 2005
Junior Member
hi,

I am executing below rman script for backup.
run
{

allocate channel t1 type 'SBT_TAPE';
allocate channel t2 type 'SBT_TAPE';
backup
skip offline
skip inaccessible
filesperset 3
format 'LDV01A_FULL_%s_%t_%u'
database;
sql 'alter system archive log current';
backup
format 'al_LDV01A_%s_%p_%t'
filesperset 20
archivelog all
delete input;
backup
format 'cf_LDV01A_%s_%p_%t'
current controlfile ;
}

it's throwing above mentioned error.plz help me

regards

vimal
Re: rman error - RMAN-03009 [message #129191 is a reply to message #129156] Fri, 22 July 2005 07:18 Go to previous messageGo to next message
Mahesh Rajendran
Messages: 10672
Registered: March 2002
Location: oracleDocoVille
Senior Member
Account Moderator
You are trying to backup directly to tape using RMAN.
You need MML API for that.
Is that installed? What kind of vendor are you using? veritas/tivoli/legato or what?
Re: rman error - RMAN-03009 [message #129610 is a reply to message #129101] Mon, 25 July 2005 23:38 Go to previous messageGo to next message
vimal_vpsk
Messages: 18
Registered: March 2005
Junior Member
hi,

Due to server crash rman script is not working fine.Previously that script was working fine.

We are using veritas netbackup datacenter 4.5 setup.

Can you please tell me how to check MML API is present or not? How to install if it is not there? Where can i get this one?

help me.


regards
vimal
Re: rman error - RMAN-03009 [message #129721 is a reply to message #129610] Tue, 26 July 2005 07:14 Go to previous messageGo to next message
Mahesh Rajendran
Messages: 10672
Registered: March 2002
Location: oracleDocoVille
Senior Member
Account Moderator
>> Can you please tell me how to check MML API is present or not? How to install if it is not there? Where can i get this one?

MML api is additional piece of software you need to buy ( if you want RMAN to backup directly to tapes).
Talk to your Unix/Veritas guy.
http://www.oracle.com/technology/deploy/availability/htdocs/bsp.htm
Re: rman error - RMAN-03009 [message #130057 is a reply to message #129101] Wed, 27 July 2005 23:25 Go to previous messageGo to next message
vimal_vpsk
Messages: 18
Registered: March 2005
Junior Member
hi,

I discussed with unix admin about this problem.Now the problem is solved.The rman script is working fine.

THANKS A LOT.Thanks for your replies.

Thanks & Regards
Vimal
Re: rman error - RMAN-03009 [message #149044 is a reply to message #130057] Tue, 29 November 2005 18:05 Go to previous messageGo to next message
ogutierd
Messages: 1
Registered: November 2005
Location: Bogota
Junior Member

Hi, I got the same problem but i am using IBM Tivoli Storage Mannager.

This is the error.

using target database controlfile instead of recovery catalog

RMAN-00571: ===========================================================

RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============

RMAN-00571: ===========================================================

RMAN-03009: failure of allocate command on HOT_SMI channel at 11/29/2005 16:42:56

ORA-19554: error allocating device, device type: SBT_TAPE, device name:

ORA-27211: Failed to load Media Management Library



Thanks for your help
Re: rman error - RMAN-03009 [message #149154 is a reply to message #149044] Wed, 30 November 2005 06:42 Go to previous messageGo to next message
Mahesh Rajendran
Messages: 10672
Registered: March 2002
Location: oracleDocoVille
Senior Member
Account Moderator
Did you read any of the above discussions?.
Is nothing applicable to you?
Re: rman error - RMAN-03009 [message #213616 is a reply to message #130057] Thu, 11 January 2007 08:34 Go to previous message
armin_noor
Messages: 5
Registered: January 2007
Junior Member
hi,
I have exactly the same problem. Would you tell me what did you do (after talking with your unix admin) to solve the prob. ?

regards
Previous Topic: RMAN recovery question
Next Topic: RMAN cannot find datafiles during duplicate
Goto Forum:
  


Current Time: Sat Dec 10 15:07:58 CST 2016

Total time taken to generate the page: 0.10448 seconds