Home » Infrastructure » Linux » Oracle10g (10.2.0.1) ASM database installation on RHEL AS 4(3)
Oracle10g (10.2.0.1) ASM database installation on RHEL AS 4(3) [message #127859] Wed, 13 July 2005 13:32 Go to next message
dba477
Messages: 10
Registered: July 2005
Junior Member
According to:-

http://download-uk.oracle.com/docs/cd/B19306_01/install.102/b15661/toc.htm

The system must be running the following (or later) kernel version:
Red Hat Enterprise Linux 3.0 and Asianux 1.0
2.4.21-27.EL
Red Hat Enterprise Linux 4.0 and Asianux 2.0
2.6.9-5.0.5.EL
Install Oracleasm Library and create volumes.
Reboot Linux and login as oracle.
During the first DBCA run , creating ASM database,
the prompt to run as root following command:-
# $ORACLE_HOME/bin/localconfig add
will come up to start the first time CSS daemons.
Scripts dbshut and dbstart now work perfectly :-
properly starting and stopping +ASM instance (compare with [2]).

References.
1.http://www.puschitz.com/InstallingOracle10g.shtml
2.http://www.linuxgazette.com/node/9572

[Updated on: Wed, 13 July 2005 13:39]

Report message to a moderator

Re: Oracle10g (10.2.0.1) ASM database installation on RHEL AS 4(3) [message #132595 is a reply to message #127859] Mon, 15 August 2005 01:40 Go to previous messageGo to next message
alexzeng
Messages: 133
Registered: August 2005
Location: alexzeng.wordpress.com
Senior Member
When I run the installation on Linux ES3, the program of Oracle10g(10.2.0.1) tell me it need glibc-2.3.2-95.27.rpm.

Can you tell me where can I find the package and dependent packages?

Thanks

Alexander
Re: Oracle10g (10.2.0.1) ASM database installation on RHEL AS 4(3) [message #132632 is a reply to message #132595] Mon, 15 August 2005 07:12 Go to previous messageGo to next message
dba477
Messages: 10
Registered: July 2005
Junior Member
Check carefully :-
http://www.puschitz.com/InstallingOracle10g.shtml
The reference is perfect.First of all Update 5 for RHEL 3 had been used for 10.2.0.1 installation.
However,for glibc issues to be resolved
# rpm -qa|grep glibc
To pick up all dependent packages
Launch browser to:-
http://ftp.belnet.be/linux/whiteboxlinux/3.0/en/obsolete-updates/
Web Page content:-
glibc-2.3.2-95.27.i386.rpm 17-Sep-2004 05:14 3.3M
glibc-2.3.2-95.27.i586.rpm 18-Sep-2004 00:19 4.1M
glibc-2.3.2-95.27.i686.rpm 17-Sep-2004 16:28 4.9M
glibc-2.3.2-95.27.src.rpm 17-Sep-2004 20:39 13.4M
glibc-2.3.2-95.27.x86_64.rpm 17-Sep-2004 17:48 4.8M
glibc-2.3.2-95.6.i386.rpm 02-Dec-2003 08:07 3.3M
glibc-2.3.2-95.6.i586.rpm 03-Dec-2003 19:47 4.1M
glibc-2.3.2-95.6.i686.rpm 02-Dec-2003 10:21 4.9M
glibc-2.3.2-95.6.src.rpm 12-Nov-2003 00:40 12.8M
glibc-common-2.3.2-95.20.i386.rpm 20-May-2004 03:15 12.1M
glibc-common-2.3.2-95.20.x86_64.rpm 09-Sep-2004 22:38 12.1M
glibc-common-2.3.2-95.27.i386.rpm 17-Sep-2004 05:20 12.1M
glibc-common-2.3.2-95.27.x86_64.rpm 17-Sep-2004 17:53 12.1M
glibc-common-2.3.2-95.6.i386.rpm 02-Dec-2003 08:08 12.0M
glibc-debug-2.3.2-95.20.i386.rpm 20-May-2004 03:15 5.3M
glibc-debug-2.3.2-95.20.x86_64.rpm 09-Sep-2004 22:38 1.5M
glibc-debug-2.3.2-95.27.i386.rpm 17-Sep-2004 05:22 5.3M
glibc-debug-2.3.2-95.27.x86_64.rpm 17-Sep-2004 17:54 1.5M
glibc-debug-2.3.2-95.6.i386.rpm 02-Dec-2003 08:08 5.3M
glibc-devel-2.3.2-95.20.i386.rpm 20-May-2004 03:15 1.8M
glibc-devel-2.3.2-95.20.x86_64.rpm 09-Sep-2004 22:40 2.3M
glibc-devel-2.3.2-95.27.i386.rpm 17-Sep-2004 05:23 1.8M
glibc-devel-2.3.2-95.27.x86_64.rpm 17-Sep-2004 17:55 2.3M
glibc-devel-2.3.2-95.6.i386.rpm 02-Dec-2003 08:07 1.8M
glibc-headers-2.3.2-95.20.i386.rpm 20-May-2004 03:15 509k
glibc-headers-2.3.2-95.20.x86_64.rpm 09-Sep-2004 22:40 504k
glibc-headers-2.3.2-95.27.i386.rpm 17-Sep-2004 05:23 513k
glibc-headers-2.3.2-95.27.x86_64.rpm 17-Sep-2004 17:55 512k
glibc-headers-2.3.2-95.6.i386.rpm 02-Dec-2003 08:07 505k
glibc-profile-2.3.2-95.20.i386.rpm 20-May-2004 03:15 1.0M
glibc-profile-2.3.2-95.20.x86_64.rpm 09-Sep-2004 22:40 1.5M
glibc-profile-2.3.2-95.27.i386.rpm 17-Sep-2004 05:24 1.0M
glibc-profile-2.3.2-95.27.x86_64.rpm 17-Sep-2004 17:56 1.5M
glibc-profile-2.3.2-95.6.i386.rpm 02-Dec-2003 08:07 1.0M
glibc-utils-2.3.2-95.20.i386.rpm 20-May-2004 03:15 71k
glibc-utils-2.3.2-95.20.x86_64.rpm 09-Sep-2004 22:41 72k
glibc-utils-2.3.2-95.27.i386.rpm 17-Sep-2004 05:24 74k
glibc-utils-2.3.2-95.27.x86_64.rpm 17-Sep-2004 17:56 75k
glibc-utils-2.3.2-95.6.i386.rpm 02-Dec-2003 08:08 67k
Looks like you need RHEL 3 Update 3 at least to avoid trouble

[Updated on: Mon, 15 August 2005 07:51]

Report message to a moderator

Re: Oracle10g (10.2.0.1) ASM database installation on RHEL AS 4(3) [message #132729 is a reply to message #132632] Mon, 15 August 2005 20:58 Go to previous messageGo to next message
alexzeng
Messages: 133
Registered: August 2005
Location: alexzeng.wordpress.com
Senior Member
Thank you very much!

I have download all the packages. When I install I meet a mistake.

Detail :

[root@rhes21 glibc]# cat /etc/redhat-release 
Red Hat Enterprise Linux ES release 3 (Taroon)
[root@rhes21 glibc]# ls -l
total 26476
-rw-r--r--    1 root     root      5161270 Sep 17  2004 glibc-2.3.2-95.27.i686.rpm
-rw-r--r--    1 root     root     12658344 Sep 16  2004 glibc-common-2.3.2-95.27.i386.rpm
-rw-r--r--    1 root     root      5592786 Sep 16  2004 glibc-debug-2.3.2-95.27.i386.rpm
-rw-r--r--    1 root     root      1937434 Sep 16  2004 glibc-devel-2.3.2-95.27.i386.rpm
-rw-r--r--    1 root     root       525229 Sep 16  2004 glibc-headers-2.3.2-95.27.i386.rpm
-rw-r--r--    1 root     root      1078475 Sep 16  2004 glibc-profile-2.3.2-95.27.i386.rpm
-rw-r--r--    1 root     root        75647 Sep 16  2004 glibc-utils-2.3.2-95.27.i386.rpm
root@rhes21 glibc]# rpm -U --force glibc-*
warning: glibc-2.3.2-95.27.i686.rpm: V3 DSA signature: NOKEY, key ID 73307de6
error: Failed dependencies:
        shadow-utils < 2:4.0.3-20 conflicts with glibc-2.3.2-95.27
        glibc-devel = 2.3.2-95.3 is needed by (installed) nptl-devel-2.3.2-95.3
Re: Oracle10g (10.2.0.1) ASM database installation on RHEL AS 4(3) [message #132802 is a reply to message #132729] Tue, 16 August 2005 05:04 Go to previous messageGo to next message
dba477
Messages: 10
Registered: July 2005
Junior Member
Well,as far as to my knowledge:-
kernel 2.4.21-27.EL,mentioned at OTN, means RHEL 3 Update 4.
Just go to U4 and stop fighting failed dependencies.
It might take a while to clean all this stuff out.
What's actually gonna happen:-
You download right versions of shadow-utils and nptl-devel RPMs
try to install them and get some other failed dependencies and
so on .. and so on ..

[Updated on: Tue, 16 August 2005 09:04]

Report message to a moderator

icon14.gif  Re: Oracle10g (10.2.0.1) ASM database installation on RHEL AS 4(3) [message #132987 is a reply to message #127859] Wed, 17 August 2005 03:24 Go to previous messageGo to next message
alexzeng
Messages: 133
Registered: August 2005
Location: alexzeng.wordpress.com
Senior Member
Thank you so much!

I updated the system to Linux ES3 U5 and installed Oracle10.2.0.1 smoothly.

Laughing
Re: Oracle10g (10.2.0.1) ASM database installation on RHEL AS 4(3) [message #314497 is a reply to message #132987] Wed, 16 April 2008 23:13 Go to previous messageGo to next message
biswas_tt
Messages: 6
Registered: April 2008
Junior Member
I am facing same issue as described by 'alexzeng' so i need to upgrade my OS from Redhat EnterPrise Liux AS 3 to RedHat Enterprise Linux AS 3 U5.

Could u pls suggest me what are the packages or rpm i need to install on existing AS 3?

Regards,

Tarun
Re: Oracle10g (10.2.0.1) ASM database installation on RHEL AS 4(3) [message #315495 is a reply to message #127859] Mon, 21 April 2008 13:22 Go to previous message
BlackSwan
Messages: 25046
Registered: January 2009
Location: SoCal
Senior Member
Are you unwilling or incapable or reading the Installation Guide as found at
http://www.oracle.com/pls/db102/homepage?remark=tahiti
?

Why do you expect people to type onto this forum what is documented by Oracle previously?
Previous Topic: How to Uninstall oracle in Linux OS
Next Topic: Oracle User and LDAP
Goto Forum:
  


Current Time: Wed Dec 07 10:55:51 CST 2016

Total time taken to generate the page: 0.13396 seconds