Home » Developer & Programmer » Forms » FRM-10142: The HTTP Listener is not running on <computernam> at port 8888.  () 1 Vote
icon7.gif  FRM-10142: The HTTP Listener is not running on <computernam> at port 8888. [message #126725] Wed, 06 July 2005 06:50 Go to next message
syedashfaq2
Messages: 12
Registered: July 2005
Location: India
Junior Member

Hi ALL,

I am still facing the following error even though i have started the OC4j instance,

"FRM-10142: The HTTP Listener is not running on <computernam> at port 8888.
Please start the listener or check your runtime preferences."

Please reply wht cud be the possible solution to rectify this.

Re: FRM-10142: The HTTP Listener is not running on <computernam> at port 8888. [message #126728 is a reply to message #126725] Wed, 06 July 2005 07:17 Go to previous messageGo to next message
priyravi
Messages: 41
Registered: July 2005
Member
Hi,

Go to forms builder...Edit Menu-->Preferences-->Runtime.
Give application server URL <ur machine ip>:8888/forms90/f90servlet [check this]
& web server location will be your browser window exe.


Start OC4J instance before u start running your form.

Hope it would work.

Regards,
Priya
Re: FRM-10142: The HTTP Listener is not running on <computernam> at port 8888. [message #126733 is a reply to message #126728] Wed, 06 July 2005 07:24 Go to previous messageGo to next message
syedashfaq2
Messages: 12
Registered: July 2005
Location: India
Junior Member

Hi Priya,

I tried the steps u suggested and started OC4J instance but it looks to me that there is some problem with my OC4J instance, it just closes down after some few seconds showing some command line parameters.

Pls guide me if u r aware of this problem.

Re: FRM-10142: The HTTP Listener is not running on <computernam> at port 8888. [message #126735 is a reply to message #126725] Wed, 06 July 2005 07:33 Go to previous messageGo to next message
priyravi
Messages: 41
Registered: July 2005
Member
Hi,

One of my friend faced the same issue...The reason we found that she was not having admin rights. Mean to say, login user rights is restricted. Where are u running ur application from home or office? From office means, check your rights and try...
Pl let me know your pbm if still exists.

Regards,
Priya
Re: FRM-10142: The HTTP Listener is not running on <computernam> at port 8888. [message #126841 is a reply to message #126735] Wed, 06 July 2005 22:34 Go to previous messageGo to next message
syedashfaq2
Messages: 12
Registered: July 2005
Location: India
Junior Member

Priya,

I am trying to run this from my office and i have got admin rights to my login id.
I feel there is something to do with the java setup, all the environment variables as listed below looks fine to me, if u c somthing missing then just point it out.

1.CLASSPATH=> D:\oracle9ids\jlib\bigraphbean.jar;D:\oracle9ids\jlib\LW_PfjBean.jar;D:\oracle9ids\jlib\bigraphbean-nls.zip;C:\JDBCDemo;D:\oracle9ids \j2ee\home\jdbc.jar;D:\oracle9ids\jdk\jre\lib\ext;D:\oracle9ids\jdbc\lib;D:\oracle9ids\jdk\jre\lib\ext\ojdbc14.jar;D:\oracle9ids\lib; D:\oracle9ids\jdbc\lib\ojdbc14.jar;.

2.JAVA_HOME=>D:\oracle9ids\jdk
3.PATH=> D:\oracle9ids\bin;D:\oracle9ids\jdk\jre\bin;D:\oracle9ids\jdk\jre\bin\classic;D:\oracle9ids\jdk\jre\bin\classic;D:\oracle9ids\jlib;D: \oracle9ids\bin;C:\Program Files\Oracle\jre\1.3.1\bin;D:\oracle9ic\bin;C:\Program Files\Oracle\jre\1.1.8\bin;D:\oracle\Oracle6i\bin;D:\PROGRA~1\RATIONAL\RATION~1\NUTCROOT\bin;D:\PROGRA~1\RATIONAL\RATION~1\NUTCROOT\b in\x11;D:\PROGRA~1\RATIONAL\RATION~1\NUTCROOT\mksnt;%SystemRoot%\system32;%SystemRoot%;d:\Program Files\Rational\common;d:\Program Files\Rational\Rose\TopLink\;d:\Program Files\Rational\Rational Test;d:\Program Files\Rational\ClearQuest;<RBUJBUILDERINSTALLDIR>\bin;d:\Program Files\Rational\Coverage;d:\Program Files\Rational\Coverage\cache;d:\ClearCase_Storage\bin;D:\oracle9ids\jdk\bin;D:\oracle9ids\lib;D:\oracle9ids\jdbc\lib;%JAVA_HOME%\bin ;%J2EE_HOME%\bin;%ANT_HOME%\bin;.

My Platform is Win NT service pack 6
Oracle9iAS Release 2

Rgds,
Syed Ashfaq Ahmed

Re: FRM-10142: The HTTP Listener is not running on <computernam> at port 8888. [message #126850 is a reply to message #126725] Wed, 06 July 2005 23:34 Go to previous messageGo to next message
priyravi
Messages: 41
Registered: July 2005
Member
Hi,

I doubt in ur rights only.
U find and run startinst.bat file and check the rights of that particular file or the folder which have this file. Check whether it has read/write permissions. pl let me know the status

Priya
Re: FRM-10142: The HTTP Listener is not running on <computernam> at port 8888. [message #126859 is a reply to message #126850] Thu, 07 July 2005 00:14 Go to previous messageGo to next message
syedashfaq2
Messages: 12
Registered: July 2005
Location: India
Junior Member

Priya,

I have Full Access on the file startinst.bat.
But when i ran this in command line it gave the following error,

D:\oracle9ids\j2ee\Oracle9iDS>D:\oracle9ids\jdk\bin\java -Dorg.omg.CORBA.ORBClas
s=com.inprise.vbroker.orb.ORB -Dorg.omg.CORBA.ORBSingletonClass=com.inprise.vbro
ker.orb.ORB -Doracle.security.jazn.config=D:\oracle9ids\j2ee\Oracle9iDS\config\j
azn.xml -Doracle.home=D:\oracle9ids -DORACLE_HOME=D:\oracle9ids -jar D:\oracle9i
ds\j2ee\home\oc4j.jar -userThreads -config D:\oracle9ids\j2ee\Oracle9iDS\config\
server.xml
java.lang.NoClassDefFoundError: javax/sql/DataSource
at java.lang.ClassLoader.defineClass0(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:493)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:11
1)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:248)
at java.net.URLClassLoader.access$100(URLClassLoader.java:56)
at java.net.URLClassLoader$1.run(URLClassLoader.java:195)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
at java.lang.ClassLoader.loadClass(ClassLoader.java:299)
at java.lang.ClassLoader.loadClass(ClassLoader.java:255)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:315)
at java.lang.ClassLoader.defineClass0(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:493)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:11
1)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:248)
at java.net.URLClassLoader.access$100(URLClassLoader.java:56)
at java.net.URLClassLoader$1.run(URLClassLoader.java:195)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
at java.lang.ClassLoader.loadClass(ClassLoader.java:299)
at java.lang.ClassLoader.loadClass(ClassLoader.java:292)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:286)
at java.lang.ClassLoader.loadClass(ClassLoader.java:255)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:315)
at com.evermind.server.XMLServerConfig.postInit(XMLServerConfig.java:245
)
at com.evermind.server.deployment.EnterpriseArchive.postInit(EnterpriseA
rchive.java:881)
at com.evermind.xml.XMLConfig.init(XMLConfig.java:177)
at com.evermind.xml.XMLConfig.init(XMLConfig.java:88)
at com.evermind.server.deployment.EnterpriseArchive.init(EnterpriseArchi
ve.java:1433)
at com.evermind.server.ServerComponent.init(ServerComponent.java:173)
at com.evermind.server.XMLApplicationServerConfig.parseApplicationConfig
(XMLApplicationServerConfig.java:1059)
at com.evermind.server.XMLApplicationServerConfig.postInit(XMLApplicatio
nServerConfig.java:209)
at com.evermind.xml.XMLConfig.init(XMLConfig.java:177)
at com.evermind.xml.XMLConfig.init(XMLConfig.java:88)
at com.evermind.server.XMLApplicationServerConfig.init(XMLApplicationSer
verConfig.java:1338)
at com.evermind.server.ApplicationServerLauncher.run(ApplicationServerLa
uncher.java:47)
at java.lang.Thread.run(Thread.java:484)
at com.evermind.util.ThreadPoolThread.run(ThreadPoolThread.java:49)
D:\oracle9ids\j2ee\Oracle9iDS>


I think there is a problem with my java setup as i pointed out earlier.

Rgds,
Syed Ashfaq
Re: FRM-10142: The HTTP Listener is not running on <computernam> at port 8888. [message #282894 is a reply to message #126725] Sat, 24 November 2007 14:56 Go to previous messageGo to next message
oraebs11i
Messages: 4
Registered: October 2007
Junior Member
Thanks to all. I have just installed Developer suite 10g and I had the same problem.

This post helped me to resolve my issue.

Thanks,
Rahul
Re: FRM-10142: The HTTP Listener is not running on <computernam> at port 8888. [message #401963 is a reply to message #126725] Thu, 07 May 2009 02:53 Go to previous messageGo to next message
supriya_546
Messages: 56
Registered: October 2005
Location: hyderabad
Member
Hi,

I also have the same issue...

installation details..

oracle database - 10201
D2K - 101202

following are the values given at
edit->preferences->runtime option

1)application server url : /10.212.98.67:8889/forms90/f90servlet

2)web browser location :
C:\Program Files\Internet Explorer\IEXPLORE.EXE

am i giving anything wrongly?
i checked the services also...
oc4j instance is running...
i have admin rights also...in my machine

Please suggest me what is missing?

Thanks,
Supriya

Re: FRM-10142: The HTTP Listener is not running on <computernam> at port 8888. [message #402150 is a reply to message #401963] Thu, 07 May 2009 20:56 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
IS this from running the form from within Forms Builder or from the OracleAS Forms Services panel via the menu?

David
Re: FRM-10142: The HTTP Listener is not running on <computernam> at port 8888. [message #432162 is a reply to message #402150] Sun, 22 November 2009 08:59 Go to previous messageGo to next message
cdpothen
Messages: 1
Registered: November 2009
Location: Kuwait
Junior Member
I am getting a similar error and to answer DJMartins question - I am getting this after running the form application within FormBuilder. I have started oc4j but still get the error. Not sure if something to do with the ports is teh issue

[Updated on: Sun, 22 November 2009 09:00]

Report message to a moderator

Re: FRM-10142: The HTTP Listener is not running on <computernam> at port 8888. [message #432192 is a reply to message #126725] Sun, 22 November 2009 22:50 Go to previous messageGo to next message
sreejith.s
Messages: 26
Registered: November 2009
Junior Member

I had the same problem. Its due to wrong installation of oracle on the PC....
Re: FRM-10142: The HTTP Listener is not running on <computernam> at port 8888. [message #432736 is a reply to message #432162] Thu, 26 November 2009 00:10 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Vinoo,

Have you solved your problem?

David
Re: FRM-10142: The HTTP Listener is not running on <computernam> at port 8888. [message #438417 is a reply to message #402150] Fri, 08 January 2010 16:07 Go to previous messageGo to next message
gonzpard
Messages: 10
Registered: January 2010
Location: Lima
Junior Member
I have the same problem when I try to run it from the "Form Builder". And, when I start the OC4J, the command window doesn´t close. Is that rigth? It only say: "initialized".

Thanks in advanced

Augusto Gonzales

[Updated on: Fri, 08 January 2010 16:08]

Report message to a moderator

Re: FRM-10142: The HTTP Listener is not running on <computernam> at port 8888. [message #438461 is a reply to message #438417] Sat, 09 January 2010 05:09 Go to previous messageGo to next message
Littlefoot
Messages: 19536
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Yes, it is OK; OC4J window should stay open (until you Shut down OC4J instance).
Re: FRM-10142: The HTTP Listener is not running on <computernam> at port 8888. [message #438665 is a reply to message #438461] Mon, 11 January 2010 09:02 Go to previous messageGo to next message
gonzpard
Messages: 10
Registered: January 2010
Location: Lima
Junior Member
Thanks for answer me. I resolve the error problem, but now when the form builder runs, it opens the browser but only shows the characters "ORACLE FORMS". Do i need to install something else?

I am using Windows server 2003 SP1 with Explorer 6.

Thanks in advance

Augusto Gonzales
Re: FRM-10142: The HTTP Listener is not running on <computernam> at port 8888. [message #438673 is a reply to message #438665] Mon, 11 January 2010 12:43 Go to previous messageGo to next message
Littlefoot
Messages: 19536
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Did you correctly set Forms preferences (Edit menu - Preferences - Runtime tab)? Try to reset Application Server's URL to default.

In Internet Explorer, go to Tools - Internet options - Advanced tab and (under the Security node) check the "allow active content to run in files on My Computer" checkbox.

Disable firewall (if you use it).
Re: FRM-10142: The HTTP Listener is not running on <computernam> at port 8888. [message #438678 is a reply to message #438673] Mon, 11 January 2010 13:53 Go to previous messageGo to next message
gonzpard
Messages: 10
Registered: January 2010
Location: Lima
Junior Member
Thanks for the answer and concern, but i already did that and it´s still showing the same characters.

When I use firefox 3.5 it´s breaks and close the browser. When I use Netscape 9 it´s tell me that i need a plugin, I installed the jdk 6 with the jre 6 and add the .dll to the plugin but nothing.

Maybe, there is a problem with the versions I am using; also the database is in a server computer using oracle database 10g, and I have the application server and the developer 10g in this computer.

Do I have to use Windows server 2003 with SP2?

Thanks in advanced

Augusto Gonzales

[Updated on: Mon, 11 January 2010 13:54]

Report message to a moderator

Re: FRM-10142: The HTTP Listener is not running on <computernam> at port 8888. [message #438735 is a reply to message #438678] Tue, 12 January 2010 00:16 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Look at http://www.orafaq.com/forum/m/264585/67467/?srch=tools+internet+options+lan+settings+advanced#msg_264585

David
Re: FRM-10142: The HTTP Listener is not running on <computernam> at port 8888. [message #438835 is a reply to message #438735] Tue, 12 January 2010 09:00 Go to previous messageGo to next message
gonzpard
Messages: 10
Registered: January 2010
Location: Lima
Junior Member
Thanks for your answer. I did what you said about the prefix, then i run it and told me that i have to activate activex. I activated it; and now when i try to run it, it´s open and then close the window immediately and never see nothing.

Do i need some extra instalation of activex? I just installed the Jinitiator 1.3.1.28, jdk6 and jre6.

I hope to solve this soon. Thanks you in advance for the answers and concern.

Augusto Gonzales
Re: FRM-10142: The HTTP Listener is not running on <computernam> at port 8888. [message #438895 is a reply to message #438835] Tue, 12 January 2010 21:50 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Is this your first form? Can you get the 'test' form running?

David
Re: FRM-10142: The HTTP Listener is not running on <computernam> at port 8888. [message #438991 is a reply to message #438895] Wed, 13 January 2010 08:23 Go to previous messageGo to next message
gonzpard
Messages: 10
Registered: January 2010
Location: Lima
Junior Member
This are my first forms in 10g, and the test never runs, it close immediately. I had always worked in Forms 6i, now I need to migrate 500 forms and 1000 reports to 10g.

My solution by now was to install Jinitiator 1.3.1.22, with JDK 1.4.2_06 and Netscape 7.1 and it works. But I need it to work in explorer 6, for production.

I thing that the problem could be with my windows server 2003, because when i run the jinitiator from the control panel, it crash and close, I looked for and intall many Jinitiator .22, but is not the problem.

Maybe someone can help me with this problem in IE6. Thanks in advance. I really appreciate your help.

Augusto Gonzales

Re: FRM-10142: The HTTP Listener is not running on <computernam> at port 8888. [message #444607 is a reply to message #438991] Mon, 22 February 2010 23:56 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Sorry that I have been so long in replying. Have you solved your problem?

David
Re: FRM-10142: The HTTP Listener is not running on <computernam> at port 8888. [message #471780 is a reply to message #126725] Tue, 17 August 2010 05:29 Go to previous messageGo to next message
shailesh23
Messages: 1
Registered: August 2010
Location: NEW DELHI
Junior Member
i m getting the same problem,when i compiling the form it compiled bt when run on browser it stucks and shows only 'ORACLE FORMS'.plz help me.i have started the OC4J instance.
Re: FRM-10142: The HTTP Listener is not running on <computernam> at port 8888. [message #471847 is a reply to message #471780] Tue, 17 August 2010 10:37 Go to previous messageGo to next message
gonzpard
Messages: 10
Registered: January 2010
Location: Lima
Junior Member
At the end I only make it works with IE6 in Windows XP and never in server, vista or windows 7. if you want it to work use one of this convinations:

Windows 2000 SP3 or XP
Internet Explorer 6.0
Java Plug-in 1.4.2_(06+)
Oracle JInitiator 1.3.1.22 (It will ask for it automatically the first time like a ActiveX plug-in)

OR

Windows 2000 SP3, XP or server
Netscape Navigator 7.1
Java Plug-in 1.4.2_(06+)
Oracle JInitiator 1.3.1.22

Also check that the firewall is not blocking the "Oracle Run Forms"

In case you are using IE6 verify that you can run ActiveX components. You can see that in Internet Options > Segurity > Personalise Level > Controls and Complements of ActiveX
Finaly you have to enable IE6 for running contents in: Internet Options > Segurity > Allow contents to run in PC File. (Many these are not the correct names of the menues but you can understand them)

Re: FRM-10142: The HTTP Listener is not running on <computernam> at port 8888. [message #611201 is a reply to message #432736] Sat, 29 March 2014 15:23 Go to previous message
milikiel
Messages: 82
Registered: May 2009
Member
Hi Martin

I faced the same problem but i resolved by starting OCJ..

The problem is when I run the form it asks me for 'plug in'.

I'm using window xp service paCK 3, Oracle 10G Developer .Please assist.
Thank you.
Previous Topic: How to Generate Report in Excel from Oracle 10g forms on client machin
Next Topic: read excel cell value
Goto Forum:
  


Current Time: Mon Sep 01 15:05:47 CDT 2014

Total time taken to generate the page: 0.09476 seconds