Home » Developer & Programmer » Forms » report status using report_object_status in form builder
icon14.gif  report status using report_object_status in form builder [message #125984] Thu, 30 June 2005 06:25 Go to next message
rgg_ksf
Messages: 1
Registered: June 2005
Junior Member
operating system : windows XP
oracle developers form 6i

I want to run report within form builder for that i am using
following code.
declare
repid REPORT_OBJECT;
v_rep VARCHAR2(100) ;
repnm varchar(50);
fname varchar2(50);
rep_status varchar2(20);
--varchar2(20):= 'rgg';
begin
repid := find_report_object('report24');
v_rep := RUN_REPORT_OBJECT(repid);
rep_status := report_object_status(v_rep);
end;
while running code i am not getting varchar2 value for
run_report_object(repid). which in turns giving error
FRM-40738 . How should i process?

rgg
Embarassed
Re: report status using report_object_status in form builder [message #126084 is a reply to message #125984] Thu, 30 June 2005 19:26 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
The following is the code from the 6i forms documentation.

DECLARE
   repid        REPORT_OBJECT;
   v_rep        VARCHAR2 (100);
   rep_status   varchar2 (20);
BEGIN
   repid := find_report_object ('report4');
   v_rep := RUN_REPORT_OBJECT (repid);
   rep_status := report_object_status (v_rep);

   if rep_status = 'FINISHED' then
      message ('Report Completed');
      copy_report_object_output (v_rep, 'd:\temp\local.pdf');
      host ('netscape d:\temp\local.pdf');
   else
      message ('Error when running report.');
   end if;
END;


Are you getting anything for rep_status?

David
Re: report status using report_object_status in form builder [message #266184 is a reply to message #126084] Mon, 10 September 2007 02:11 Go to previous messageGo to next message
james_aron
Messages: 32
Registered: July 2007
Location: chennai
Member
hi david,

I am facing problem with the forms documentation code. Is this is forms 6i documentation error or something else please let me know.......?


regards,
jame
Re: report status using report_object_status in form builder [message #266912 is a reply to message #266184] Wed, 12 September 2007 00:08 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Is this a new topic? If it is, DON'T associate it with an existing thread, post it as a new topic.

What is the error message code and the error message text?

David
Re: report status using report_object_status in form builder [message #268034 is a reply to message #266912] Mon, 17 September 2007 04:55 Go to previous messageGo to next message
james_aron
Messages: 32
Registered: July 2007
Location: chennai
Member
Error Code :
" FRM-40738:Argument 1 to builtin REPORT_OBJECT_STATUS cannot be null.".

Storing null values in v_rep...?
Re: report status using report_object_status in form builder [message #416144 is a reply to message #125984] Thu, 30 July 2009 16:50 Go to previous message
christianmlong
Messages: 3
Registered: July 2009
Junior Member
From the Forms 6i documentation for the RUN_REPORT_OBJECT built-in
Quote:

If you invoke Run_Report_Object with a blank Report Server property, the return value will be NULL. In that case, you cannot then use the built-ins Report_Object_Status and Copy_Report_Object_Output, because they require an actual ID value.

Previous Topic: Problem in running report from forms 6i.......Please help...!
Next Topic: Internet Explorer Problem in running oracle Forms 10g
Goto Forum:
  


Current Time: Sun Dec 11 00:03:38 CST 2016

Total time taken to generate the page: 0.05559 seconds