Home » Other » General » Error accessing package dbms_application_info
Error accessing package dbms_application_info [message #113364] Fri, 01 April 2005 11:38 Go to next message
poaudain
Messages: 5
Registered: March 2005
Junior Member
Hello!

While accessing to my database using sql*plus or others utility, I find this message "Error accessing package DBMS_APPLICATION_INFO", "Package Standard not accessible". When I go on DBA Studio I find that the package is invalid and I can compile it. Could anyone help me please?

PS. The Oracle version is 8.1.7 and the operating system is Win 2000 server.
Re: Error accessing package dbms_application_info [message #113514 is a reply to message #113364] Mon, 04 April 2005 06:03 Go to previous messageGo to next message
Maaher
Messages: 7062
Registered: December 2001
Senior Member
I'd say: reinstall the package:

Connect as SYS and run the standard.sql file.

HTH,
MHE
Re: Error accessing package dbms_application_info [message #226506 is a reply to message #113364] Sat, 24 March 2007 06:16 Go to previous messageGo to next message
tndeepakbharadwaj
Messages: 3
Registered: March 2007
Location: Chennai, India
Junior Member

The same can be rectified by executing catalog.sql and catproc.sql from $ORACLE_HOME/rdbms/admin dir which will re-create the data dictionary
Re: Error accessing package dbms_application_info [message #226523 is a reply to message #113364] Sat, 24 March 2007 09:38 Go to previous messageGo to next message
BlackSwan
Messages: 25033
Registered: January 2009
Location: SoCal
Senior Member
tndeepakbharadwaj,
I suspect that you really are/were trying to be helpful, but
responding to a post that is almost TWO years old might be considered less than 100% useful.
Re: Error accessing package dbms_application_info [message #323121 is a reply to message #113364] Tue, 27 May 2008 06:23 Go to previous messageGo to next message
debajyoti
Messages: 5
Registered: April 2007
Junior Member
Hi,

I am facing the same problem but while trying to run catalog and catproc the m/c is bahaving in a hanged state.
Please suggest.


Regards
Dev
Re: Error accessing package dbms_application_info [message #323238 is a reply to message #323121] Tue, 27 May 2008 20:06 Go to previous messageGo to next message
tndeepakbharadwaj
Messages: 3
Registered: March 2007
Location: Chennai, India
Junior Member

Hi Dev,

I too faced a similar problem and the reason was the dump file which i was trying to import was of 64 Bit and my database was of 32 bit so i had to do oracle bit migration. If you can check and conclude that the problem in because of bit variation then follow the steps as shown below,

1) Shutdown the database and startup as startup migrate
2) Then execute catalog,catproc and utlirp scripts. Utlirp.sql will change the bit from 32 to 64 and vice versa
3) Then execute catpatch.sql
4) Then execute utlrp.sql which will recompile the invalid objects of SYS.
5) Then shutdown the database and startup

Regards,
Deepak Bharadwaj TN
Re: Error accessing package dbms_application_info [message #323239 is a reply to message #113364] Tue, 27 May 2008 20:20 Go to previous messageGo to next message
BlackSwan
Messages: 25033
Registered: January 2009
Location: SoCal
Senior Member
tndeepakbharadwaj,
>the reason was the dump file which i was trying to import was of 64 Bit and my database was of 32

Import will work with any dump file made by export at the same version or lower version; regardless of OS, endian, or 32vs64-bit similarities or differences.
Re: Error accessing package dbms_application_info [message #323273 is a reply to message #323238] Wed, 28 May 2008 00:43 Go to previous messageGo to next message
debajyoti
Messages: 5
Registered: April 2007
Junior Member
hi,

I tried to follow the steps sugeggested by you.

1. The catalog.sql is run properly.
2. When I am runnning catproc.sql after sometime I am getting the message ora:03114: not connected to oracle

enter the value for wpi_file_var :

enter the value for owa_file_var:

please suggest

Regards
Dev
Re: Error accessing package dbms_application_info [message #323281 is a reply to message #113364] Wed, 28 May 2008 01:15 Go to previous messageGo to next message
BlackSwan
Messages: 25033
Registered: January 2009
Location: SoCal
Senior Member
>I tried to follow the steps sugeggested by you.
who is "you"?
Re: Error accessing package dbms_application_info [message #323313 is a reply to message #323281] Wed, 28 May 2008 03:06 Go to previous messageGo to next message
debajyoti
Messages: 5
Registered: April 2007
Junior Member
you is Deepak Bharadwaj

thanks
Dev
Re: Error accessing package dbms_application_info [message #323567 is a reply to message #323239] Wed, 28 May 2008 20:21 Go to previous messageGo to next message
tndeepakbharadwaj
Messages: 3
Registered: March 2007
Location: Chennai, India
Junior Member

Hi anacedent,

In my case import happened fine but I got the similar error what Dev is getting while trying to compile any PL/SQL stub. So I had to do Oracle bit migration after which it was fine.

Hi Dev,

Error ora:03114 generally occurs when the session is being terminated or disconnection of communication channel to database. But this case is bit strange that while running catproc.sql, database is getting terminated. I will check on this and will get back to you.

Regards
Deepak Bharadwaj TN

Re: Error accessing package dbms_application_info [message #507359 is a reply to message #113514] Sat, 14 May 2011 05:37 Go to previous messageGo to next message
ibanpaf
Messages: 11
Registered: September 2008
Location: peshawar pakistan
Junior Member

i run the standard.sql but it gives me error
SP2-0023: String not found.
Re: Error accessing package dbms_application_info [message #507363 is a reply to message #507359] Sat, 14 May 2011 08:48 Go to previous messageGo to next message
BlackSwan
Messages: 25033
Registered: January 2009
Location: SoCal
Senior Member
It would be helpful if you followed Posting Guidelines - http://www.orafaq.com/forum/t/88153/0/
Re: Error accessing package dbms_application_info [message #507371 is a reply to message #507359] Sat, 14 May 2011 10:19 Go to previous message
Michel Cadot
Messages: 64102
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
ibanpaf wrote on Sat, 14 May 2011 12:37
i run the standard.sql but it gives me error
SP2-0023: String not found.


Copy and paste what you did and I got.
Before, Please read OraFAQ Forum Guide and How to use [code] tags and make your code easier to read.
Make sure that lines of code do not exceed 80 characters when you format.
Indent the code, use code tags and align the columns in result.
Use the "Preview Message" button to verify.
Also always post your Oracle version, with 4 decimals.

Regards
Michel

Previous Topic: SYSAUX Tablespace
Next Topic: base tables....In oracle Version 6 or 7
Goto Forum:
  


Current Time: Fri Dec 02 16:53:01 CST 2016

Total time taken to generate the page: 0.25683 seconds