Home » Developer & Programmer » JDeveloper, Java & XML » JDeveloper 10g JSP include directive problem
JDeveloper 10g JSP include directive problem [message #104090] Tue, 27 July 2004 05:42 Go to next message
Messages: 22
Registered: July 2000
Junior Member

When developing a JSP page with an [<]%@ include %[>] directive, the editor highlights various lines _not_ associated with the current file in the editor, but lines that correspond to the included file.

For instance, say good.jsp has a [<]%@ include file="bad.jsp" %[>], and bad.jsp has an error, say using an undefined variable.  While editting good.jsp, it will be highlighted on the offending line number from bad.jsp.

Also, something simliar happens while debugging JSPs with an [<]%@ include %[>] - JDeveloper does not switch files to show the correct code, and the hightlighted line bounces around the current main JSP page with no regard to the displayed code/file.

I am using JDeveloper 10g (Version (Build 1618)) on Windows 2000 Pro, with an underlying Sun J2EE 1.4.2.


Re: JDeveloper 10g JSP include directive problem [message #104188 is a reply to message #104090] Fri, 13 August 2004 07:38 Go to previous messageGo to next message
Messages: 73
Registered: September 1999
I have a similar problem, but not identical. Errors in included JSPs are highlighted correectly (JDeveloper DOES switch documents for me), however it also reports errors which should not exist.

For instance, I have a variable (String class) defined in good.jsp and then include sub.jsp which tries to access this variable:

<% String tester = "This is a test string."; %>
<%@ include file="sub.jsp" %>

where sub.jsp has something that looks like:


According to everything I have read, since sub.jsp is simply being included in good.jsp at translation time, it should be able to see that variable tester and to access it as well. But when I try to run good.jsp, I get the error:

Error(65,54): variable tester not found in class __sub

My environment is:
JDeveloper 10g ( build 1618)
Windows 2000 SP2
JDK 1.4.2
Re: JDeveloper 10g JSP include directive problem [message #104316 is a reply to message #104188] Wed, 15 September 2004 11:16 Go to previous messageGo to next message
Sean Lawrence
Messages: 1
Registered: September 2004
Junior Member

I was told to delete all the compiled class files in the project, and when I did this, my problems here disappeared, and I have not a problem since.

Re: JDeveloper 10g JSP include directive problem [message #207807 is a reply to message #104090] Thu, 07 December 2006 01:53 Go to previous message
Messages: 1
Registered: December 2006
Junior Member

unfortunately that does not work for me!

I'm using latest JDev ( and struts 1.2.9) but JDev claims that it must use JSP version 1.1 with struts 1.2.9 (which is nonsense since the same project with the same sources works fine within Tomcat and within Eclipse - but I have to use JDev!).

So the problem is that JDev does not know the following things:

1. Variables (bean define) that are introduced in JSPs which are inkluding other JSPs. Within the included JSPs these variables are not known.

2. Overwritten beans using bean:define and nested:define more than one time on the same bean variable (this is due to the used JSP 1.1 version which I don't know how to change for the project in JDev).

Can please anybody help here!?

Many thanks in advance
Best regards
Previous Topic: upload document to DB
Next Topic: How to intrigate Oracle 10g Database with Oracle 10g Form in RHEL 4
Goto Forum:

Current Time: Sat Oct 22 15:11:07 CDT 2016

Total time taken to generate the page: 0.11613 seconds