Home » Infrastructure » Windows » problems with oracle 8i on my windows xp system
problems with oracle 8i on my windows xp system [message #99896] Sun, 12 May 2002 09:26 Go to next message
Prasad
Messages: 104
Registered: October 2000
Senior Member
i have installed oracle 8i on my windows xp system. it has not given me any problems during installation. i could log on to oracle and work on it without any problems. but when i restarted my system, my system has failed to start the oracle service, and i could no longer logon to sql * plus. i've got messages 'oracle not available'. i've even tried to start the service from adminstrative tools-services, but of no use. then i created a new database and log on to sql* plus. but when i rebooted my system, the problem continued. i need help.
Re: problems with oracle 8i on my windows xp system [message #99899 is a reply to message #99896] Sun, 12 May 2002 23:01 Go to previous messageGo to next message
S JESSE
Messages: 1
Registered: May 2002
Junior Member
Prasad:

Unfortunately, I will tell you that Oracle does not have plans at this time to certify the 8i version of the database for Windows XP. Oracle9i Release 1 is the first version to be offically tested and supported on XP, and this is on Windows XP Professional (the home edition is not certified).

Oracle will likely anounce certification of the 8i CLIENT software ONLY, starting in June. This means that the 8i version of the database is not tested on XP at all, and you may encounter problems.

Having said that, the symptoms you describe do sound similar to a known bug with Oracle 8.1.6 on Windows 2000. BUG#1266248 results in the Service for the instance being stuck in a 'Starting' status after a reboot. You do not mention the version of database that you are running. This bug only affects 8.1.6. If you are running this version, you should obtain and apply the 8.1.6.3.0 patchset, followed by the 8.1.6.3.8 patchset (You must apply these patches in that order, as 8.1.6.3.8 has the fix, but it can only be applied over the top of 8.1.6.3.0). These patches are available from Metalink as Path#1650087 and Patch#2102378, respectively.

Ultimately, if this is just for personal use, you may want to consider dowloading Oracle9i and using that release, since it is certified for XP Professional Edition.

Hope that helps..
Scott
Re: problems with oracle 8i on my windows xp system [message #99907 is a reply to message #99896] Wed, 15 May 2002 22:09 Go to previous messageGo to next message
Jonathan Liew
Messages: 4
Registered: May 2002
Junior Member
You should use Oracle 8.1.5 on Windows XP Professional and everything works for me.
Re: problems with oracle 8i on my windows xp system [message #100075 is a reply to message #99896] Tue, 09 July 2002 16:16 Go to previous messageGo to next message
John Joy
Messages: 1
Registered: July 2002
Junior Member
Hi Prasad,

I have recently installed Oracle 8i on my xp system and ran into the same trouble. Since Im a new user to Oracle itself, the solution that im giving here may not be the right one. But it works for me.

Here are the things to do.

After the system reboot, most of the Oracle servers willbe running bcos of the "Automatic" setting in the system services startup. Change the start-up options to "Manual" for all the 5 services (OracleOraHome81TNSListener, OracleOraHome81DataGatherer,OracleOraHome81ClientCache,OracleOraHome81Agent and OracleWebAssistant0). Also change the (Assume your instance name is Prasad) OracleServicePRASAD service to Manual.

Then once the system restarts, start the services one by one in the above listed order (I got some problems when I changed the order. But Im not sure abt that). Then start your OracleServicePRASAD. It will come out with a dialouge box saying that "Unable to start" and the status will be "Starting".

Go to the Task Manager, Kill the one and only ORACLE process running. Come back again and restart the OracleServicePRASAD service. Eventhough the status shown will be 'Starting' you will be able to start the service.

If you find any problem with this sequence, mail me back. Or of you got any easy steps for the same, just update me.

thanks,
John.
Re: problems with oracle 8i on my windows xp system [message #100082 is a reply to message #99896] Fri, 12 July 2002 08:36 Go to previous messageGo to next message
laurence
Messages: 1
Registered: July 2002
Junior Member
Hey, I found that Oracle 9i release 2 has the same problem on Win XP as Oracle8.1.6. on Win 2000.
After I created the database before reboot, it works well. However, it doesn't start up again after I reboot the PC. And I tried to start the DB from the 'Administration Assistant for Win NT'. It gave me the error message "failed to start service. error 0x80070420". Now, what should I do? Please reply. Thank you.
Re: Directions [message #100165 is a reply to message #100075] Thu, 15 August 2002 11:20 Go to previous messageGo to next message
Joycelyn Mensah
Messages: 2
Registered: August 2002
Junior Member
can you give me directions on how to install Oracle8i on my XP system? Because it gave an error the first time. It says that it needs to be stalled on Windows NT or it won't do it.
Re: problems with oracle 8i on my windows xp system [message #100192 is a reply to message #100075] Sun, 01 September 2002 13:10 Go to previous messageGo to next message
Handojo
Messages: 1
Registered: September 2002
Junior Member
I had the same problem for several days.
I install Oracle 8.1.6 in Windows 2000 Server ( Service Pack 3 ).
The oracle installation is fine, until it begin creating database using DBASSIST.

I had an error : ORA-01034 : Oracle not available, at the moment it tries to "Creating database files"

I've had installed the oracle before on the same machine, but this time it is not successfull.

After several days, I figured out that If I changed the JRE path from "C:Program filesOraclejre1.1.7bin" to "%JAVA_HOME%jrebin", the database creation worked just fine.
The Java version I installed in %JAVA_HOME% is 1.4.0
Re: problems with oracle 8i on my windows xp system [message #100231 is a reply to message #100075] Sun, 15 September 2002 20:10 Go to previous messageGo to next message
bill
Messages: 75
Registered: November 1999
Member
John,
Your suggestion got me looking at the Task Manager and process list. On my XP system, I had oradim.exe running along with an oracle.exe (the Oracle service) process. I killed oradim.exe and the service process *finally* started. Just another thing to keep in mind when getting Oracle 8i started on XP. Thanks for the previous tip...got me through the startup issues.

--Bill
Re: problems with oracle 8i on my windows xp system [message #100323 is a reply to message #99896] Mon, 14 October 2002 23:13 Go to previous messageGo to next message
Leonard Wolters
Messages: 3
Registered: October 2002
Junior Member
Hi,

I have exactly the same problem. I'n running Oracle 8.1.5 on Windows XP. Before rebooting, everything works fine. After rebooting, database shows the same error message, i.e. 0x80070420

Please please please help me. On windows 2000 there doesn't seem to be a problem...
Re: problems with oracle 8i on my windows xp system [message #100495 is a reply to message #99896] Wed, 22 January 2003 23:02 Go to previous messageGo to next message
Kishor reddy
Messages: 1
Registered: January 2003
Junior Member
My system is windows xp profisnal. Loading the oracle 8i in my system fist of all the oracle load surver creat. Then restart the system open oracle "oracle not availble" message come.
Re: problems with oracle 8i on my windows xp system [message #100553 is a reply to message #99896] Fri, 14 February 2003 02:43 Go to previous messageGo to next message
Jill
Messages: 6
Registered: August 1999
Junior Member
Well, there is a way for you to log on to SQL-Plus under Windows XP Pro, 1st; type in 'Oracle' inside the user's name, and then 'Internal' for password; wait for that execution, you'll then be able to log on to SQL-Plus ^_^
Re: problems with oracle 8i on my windows xp system [message #100736 is a reply to message #100082] Sun, 13 July 2003 14:32 Go to previous messageGo to next message
Mihai Cristofor
Messages: 8
Registered: July 2003
Junior Member
I had the same problem with 8.1.5 on windows xp. I have installed 9i release 2 and the problem still there. Only if i kill oradim process and restart the service it works. But i have to do this every time i restart the computer. Any patch for this???
Re: problems with oracle 8i on my windows xp system [message #100766 is a reply to message #100323] Tue, 19 August 2003 10:11 Go to previous messageGo to next message
Sanjiv Gupta
Messages: 1
Registered: August 2003
Junior Member
Is anyone with the solution????

I am also having the same problem with Oracle on Windows XP.

Your immediate help will be appreciated!!!

--Sanjiv
Re: problems with oracle 8i on my windows xp system [message #100896 is a reply to message #100736] Tue, 10 February 2004 06:45 Go to previous messageGo to next message
pat
Messages: 27
Registered: September 2000
Junior Member
seems like I have to also end all oracle.exe processes..
problems with oracle 8i on my windows xp system [message #101056 is a reply to message #100553] Thu, 08 April 2004 08:56 Go to previous messageGo to next message
Krupali
Messages: 2
Registered: April 2004
Junior Member
I installed Oracle8.1.5.0 on Win XP and could use SQL with oracle and everything worked fine but only till i hadn't rebooted my system And I also tried to start the DB from the 'Administration Assistant for Win NT'. It gave me the error message "failed to start service. error 0x80070420".
It gives me an error saying Oracle Not available and also No listener.
Have also copied the tnsnames.ora file from \networkadmin but it doesnt seem to work.
With a different name and password it says connected to idle instance.
I am a new to oracle. If the problem is very simple sorry abaout that.
Your help will be appreciated.
Thanks
Regards,
Krupali
Now, what should I do? Please reply. Thank you.
Re: problems with oracle 8i on my windows xp system [message #101057 is a reply to message #100075] Thu, 08 April 2004 11:30 Go to previous messageGo to next message
Krupali
Messages: 2
Registered: April 2004
Junior Member
Hey John,

Your solution has been of great help.

Thanks,
Regards,
Krupali
Re: problems with oracle 8i on my windows xp system [message #101067 is a reply to message #100075] Tue, 13 April 2004 06:35 Go to previous messageGo to next message
Al-Khwarizmi
Messages: 1
Registered: April 2004
Junior Member
Thanks for your advice, it has been very useful to me too.

By the way, I think it's not neccesary to change services to manual, at least in my computer.
Re: problems with oracle 8i on my windows xp system [message #101143 is a reply to message #100896] Tue, 25 May 2004 20:18 Go to previous messageGo to next message
Dev
Messages: 28
Registered: May 2001
Junior Member
have u installed service packs in XP ? and remember XP doesn't comes with java.
Re: problems with oracle 8i on my windows xp system [message #101198 is a reply to message #100553] Wed, 16 June 2004 20:38 Go to previous messageGo to next message
ranjan kohli
Messages: 4
Registered: June 2004
Junior Member
Respected Sir/Mam,
I have faceing a problem in windows xp at the time of installation of oracle 8i server. Install oracle 8i server 02 services has been started :
1)Listner
2)Instant
but after re-boot the system,windows-xp has been on,
but only one service has started Listner service and another service(Instant service) not started only message showing "STARTING" but services not started.

But I have one another trial for INSTANT SERVICE started, I have goen through dos command : 1) Svrmgrl
2) connect oracle
3) start service
service has started showing in oracle status but after the re-boot the system or shutdown the system after the re-start the system service(Instant Service) has been again stop. why Instant Service not automatically started.
Please reply as soon as possible in my yahoo email address.
Thanking you

Ranjan
Problem in running Oracle8i on WinXP [message #101268 is a reply to message #100896] Wed, 14 July 2004 04:12 Go to previous messageGo to next message
Rahul
Messages: 94
Registered: December 1998
Member
Sir, i have installed oracle8i successfully on my computer but when i reboot my computer & try to run SQL
by using username:- system & password:- manager or scott/tiger i get message "Oracle not available".
sir please mail me the solution to this problem.
vist,glad to see you! [message #101338 is a reply to message #99896] Sat, 14 August 2004 20:08 Go to previous messageGo to next message
kingkun
Messages: 2
Registered: August 2004
Junior Member
I am a newbie,pls help me to study oracle. If you give me some advice,I am very glad to hear you!
Re: problems with oracle 8i on my windows xp system [message #101339 is a reply to message #101056] Sat, 14 August 2004 20:13 Go to previous messageGo to next message
kingkun
Messages: 2
Registered: August 2004
Junior Member
You may add a patch about oracle 8i,this is a bug of the oracle8i. Good luck to you!
Re: problems with oracle 8i on my windows xp system [message #101414 is a reply to message #100082] Sat, 18 September 2004 10:26 Go to previous messageGo to next message
raj ganjoo
Messages: 1
Registered: September 2004
Junior Member
Yeh this problem exists with win xp. However I tried to get the remedy from net and landed here to know that this problem is being faced by others and their seems to be no solution. However after trying everything, I have just today created one more database alongwith the existing database through start>Programs>Oracle-oraHome8i>database administration> database configuration assistant. And to my pleasure and happiness I found the second database running quite effeciently and I have since then turned off and on my system at least five times and database is now starting efficiently without any errors such as ORA-01034 and error (0x80070420)

Hope this will help you, if not previously set right.

Raj B Ganjoo
Jammu
Re: problems with oracle 8i on my windows xp system [message #101550 is a reply to message #99899] Fri, 03 December 2004 00:37 Go to previous messageGo to next message
Marcel
Messages: 7
Registered: August 2001
Junior Member
Thank you Scott!

i have found your tip last night when my both 8.1.6 Servers crashed. After installing the 2 patches they work again.

regards
Marcel
Re: problems with oracle 8i on my windows xp system [message #126460 is a reply to message #100231] Mon, 04 July 2005 16:16 Go to previous messageGo to next message
Samantha
Messages: 1
Registered: July 2005
Junior Member
hi Bill,

I have been running Oracle 8i on my Windows XP machine *exactly* as you describe, i.e., killing oradim.exe which is actually the bone of contempt and gets stuck, and then restarting both OracleDefault_POTNSListener and OracleServiceSam services; for nearly a month !

But today a wonderful thing happened ! As i sat to work and tried to start Oracle, it did not start by this method ! Even this method has seized to work ! One of my projects has gone half way and things are stuck Razz



Regards,
Sam.
xxxxxxxxx
Re: Problem in running Oracle8i on WinXP [message #144244 is a reply to message #101268] Tue, 25 October 2005 13:05 Go to previous messageGo to next message
mukeshmohd
Messages: 1
Registered: October 2005
Junior Member
Hi,
Am new to Oracle.
I found a solution for Oracle 8i with XP. Please try it.

Open SQL Plus from start/all programs/Oracle-Ora81/Application Development/SQL Plus. It will prompt for username and password. Just press OK without typing anything. Now in SQL Plus, it will ask for 'Enter Username:'. Type CONNECT INTERNAL/ORACLE and press enter.
It will connect to idle instance. Then in SQL Prompt, type STARTUP OPEN and press enter. It will start the database showing the below
'Total System Global Area
Fixed Size
Variable Size
Database Buffers
Redo Buffers
Database mounted.
Database opened.'

Then in sql Prompt, type CONNECT SCOTT/TIGER (or CONNECT SCOTT/TIGER@databasename (where databasename is the name of your database you have given while installing oracle 8i)

It will be connected.

Try it and give me a reply

Re: problems with oracle 8i on my windows xp system [message #190314 is a reply to message #99896] Wed, 30 August 2006 03:15 Go to previous messageGo to next message
akdwivedi
Messages: 2
Registered: August 2006
Junior Member
Yo can try runnin the batch file which I have attached. There will never be a startup problem again
Re: problems with oracle 8i on my windows xp system [message #211023 is a reply to message #99896] Mon, 25 December 2006 05:41 Go to previous messageGo to next message
dnantepara
Messages: 1
Registered: December 2006
Junior Member
How to Install oracle 6i 8i on windows xp
I was getting error ora-01034 and could not connect to database on computer restart
Found oracle 8i not certified by oracle to run on windows xp
The problem is the oracle service database_home was hanging is the startup state

Solution
1. install developer 6i to default_home (dir orant)
2. install oracle personnel edition database to default_home2 (dir oracle_data)
3. reboot
4. create a new database (start, oracle-default_home2, database admin, oracle admin)
5. reboot
6. rename orant\net80\admin\tnsnames.ora *.oldora
7. copy oracle_data\network\admin\tnsnames.ora to orant\net80\admin\*
8. edit orant\net80\admin\sqlnet.ora and change the line names.default_domain = world to # line names.default_domain = world
9. change service startup for both oracleservices to manual (start, settings, control panel, administrative tools, services )
10. reboot
11. start service for the second database you created when it has started start the original database service
12. now you can connect to database from developer

Re: problems with oracle 8i on my windows xp system [message #386531 is a reply to message #99899] Mon, 16 February 2009 00:25 Go to previous messageGo to next message
harisantha07
Messages: 1
Registered: February 2009
Junior Member
hi.......... iam harikrishna
iam doing the project using oracle
when iam inserting the data into the oracle sometimes oracle can't insert the data
but sometimes it is inserting
that time it is giving error like ora-01031 error
every time i started the oracle
using

internal
oracle
startup
conn
scott
tiger


sir can u plz..send me the solution
thnku
Re: problems with oracle 8i on my windows xp system [message #386533 is a reply to message #386531] Mon, 16 February 2009 00:38 Go to previous messageGo to next message
Michel Cadot
Messages: 64108
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
ORA-01031: insufficient privileges
 *Cause: An attempt was made to change the current username or password
         without the appropriate privilege. This error also occurs if
         attempting to install a database without the necessary operating
         system privileges.
         When Trusted Oracle is configure in DBMS MAC, this error may occur
         if the user was granted the necessary privilege at a higher label
         than the current login.
 *Action: Ask the database administrator to perform the operation or grant
          the required privileges.
          For Trusted Oracle users getting this error although granted the
          the appropriate privilege at a higher label, ask the database
          administrator to regrant the privilege at the appropriate label.

For more: read OraFAQ Forum Guide, use SQL*Plus and copy and paste your session.

Regards
Michel

[Updated on: Mon, 16 February 2009 00:39]

Report message to a moderator

Re: problems with oracle 8i on my windows xp system [message #386558 is a reply to message #99896] Mon, 16 February 2009 02:31 Go to previous messageGo to next message
m_golam_hossain
Messages: 89
Registered: August 2008
Location: Uttara, Dhaka, Bangladesh
Member

Mr. Prasad,

Perhaps your oracle services have not been started.

Try the following steps:

1. Click Windows START
2. Click RUN
3. Type SERVICES.MSC /L and press enter

from the service name list double click the OracleServicesXXXXXXX names and press START button.



Mohd. Golam Hossain
Uttara, Dhaka, Bangladesh.
Re: problems with oracle 8i on my windows xp system [message #386564 is a reply to message #386558] Mon, 16 February 2009 02:41 Go to previous messageGo to next message
Michel Cadot
Messages: 64108
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
What make you think that a non started service leads to a 1031 error?

Regards
Michel
Re: problems with oracle 8i on my windows xp system [message #386575 is a reply to message #386564] Mon, 16 February 2009 03:03 Go to previous messageGo to next message
m_golam_hossain
Messages: 89
Registered: August 2008
Location: Uttara, Dhaka, Bangladesh
Member

Dear Michel,

Thank you for your interest.

Mr. Prasad's problem was not an authority/privileges related one. Whereas, Ora-01031 is an error message related to lack of privilege/authority.

Thank you again.

M. Golam Hossain
Re: problems with oracle 8i on my windows xp system [message #475224 is a reply to message #99896] Mon, 13 September 2010 15:21 Go to previous message
Apoorva
Messages: 1
Registered: September 2010
Junior Member
Dear Prasad Ji,
Try the following steps
Go to start menu-----Run-----type CMD press enter
MSDOS command prompt will open
Type SVRMGRL press enter
Type CONNECT INTERNAL/ORACLE press enter
Type STARTUP press enter
This will start the oracle.
Now close the MSDOS window.
On windows XP oracle does not start automatically on system startup. It can be started manually as above on every system startup. Trying to start Oracle from the services option does not work.
Hope this solves your problem.
Regards
Apoorva
Previous Topic: Install oracle in windows XP
Next Topic: can't find the session of a Thread ID
Goto Forum:
  


Current Time: Mon Dec 05 05:06:22 CST 2016

Total time taken to generate the page: 0.19749 seconds