Home » Developer & Programmer » Precompilers, OCI & OCCI » Pro*c Executable - Error Debug Assertion failed
Pro*c Executable - Error Debug Assertion failed [message #94312] Sun, 18 July 2004 20:13 Go to next message
Satish Bharadwaj
Messages: 8
Registered: December 2003
Junior Member
Hi to all oracle Gurus,

This is Satish.

I need one Help from You.

Scenario 1:
-----------
 I had, P3 Machine,


 Installed components:
  oracle 8i, with pro*C Components
  Visual Basic was installed in system.
 Aplication:
  There was a file written in Pro*C, it takes a
  Big ascii file as input, and process it, parse it,
  Insert records in to some of the tables in database.
 Status :
  Working Fine.


Scenario 2:
-----------
I had, P4 Machine,



 Installed components:
  oracle 8i, with pro*C Components
  Visual Studio, VB, VC++ was installed in system.
 Aplication:
  The same application mentioned above.
 Status :
  Not working
 Error :
-------------------------------------------------------------------------
        Microsoft VC++ Debug Library.    
  Debug Assertion failed.     
  Program : D:maindatamain1.exe    
  File : fgets.c      
  Line:60       
       
  Exception: str!=NULL     
       
  For information on how your program can cause assertion failure,
  see visual c++ documentation on asserts   
       
  [[Abort]] [[Retry]] [[Ignore]]    
-------------------------------------------------------------------------
  
  Error message Attached.

Pease help me what could be wrong with new system.

 1. Is Environment Variables causing problem, If yes, then please inform me
  what are the basic environment settings for Proc*C

 2. How to Test Pro*C is working properly or not?
Re: Pro*c Executable - Error Debug Assertion failed [message #94503 is a reply to message #94312] Fri, 24 December 2004 01:30 Go to previous messageGo to next message
Kaustubh Deshpande
Messages: 32
Registered: March 2004
Member
Hi Satish,

Have you linked Oracle Libraries from VC++ to ur proc program.

Regards,
Kaustubh
Re: Pro*c Executable - Error Debug Assertion failed [message #94514 is a reply to message #94503] Wed, 29 December 2004 19:18 Go to previous message
raajaindra
Messages: 1
Registered: December 2004
Junior Member
Please check the path where you are trying to write
Previous Topic: why and when we have to use nullset in pro*c
Next Topic: INTERNAL ERROR: Failed Assertion [Code=40701]
Goto Forum:
  


Current Time: Tue Apr 24 09:38:22 CDT 2018

Total time taken to generate the page: 0.01368 seconds