Home » Developer & Programmer » Warehouse Builder » INS0029 Error OWB10g Runtime Repository Install Failed
INS0029 Error OWB10g Runtime Repository Install Failed [message #93413] Tue, 14 December 2004 09:14 Go to next message
eilison
Messages: 22
Registered: August 2003
Junior Member
Hi,

I have trouble in installing Runtime Repository. I've done a log of search in the OTN forum and internet on my problem, but none answered my question. I'm running out of my patience, time and coffee :-(

OS: Windows XP home
DB: Oracle 10g 10.1.0.2
OWB: 10g 10.1.0.2 (Both of these are from OTN, latest version)

Installation Sequence:
=======================
Oracle DB (succeed)
OWB (succeed)
Design Repository (succeed)
Runtime Repository (Failed)

I was following the installing guide PDF from OTN documentation. I've been working on oracle products for about four years, I'm sure I did not make any stupid mistakes. My OS is not an english version, but I already set the locale to English(USA).

I searched the forum and learned that some folks ran across problems due to NLS_LANG(converting issues) and AQ(object locking issues), but according to my log file, the root to this problem seems to be those roles which are absent, for example: JAVADEBUGPRIV

Part of my log:
=====================================================
oracle.wh.util.DebugUtility: the tbspace for data is USERS
Sun Dec 12 19:58:41 CST 2004
oracle.wh.util.DebugUtility: the tbspace for indexes is USERS
Sun Dec 12 19:58:41 CST 2004
oracle.wh.util.DebugUtility: the tbspace for snapshot is USERS
Sun Dec 12 19:58:41 CST 2004
oracle.wh.util.DebugUtility: [[processSQLDBAToken]]: Script Name is ../../rtasst/platform_system_rights.sql
Sun Dec 12 19:58:41 CST 2004
oracle.wh.util.DebugUtility: java.sql.SQLException: ORA-01919: role 'JAVAIDPRIV' does not exist
Sun Dec 12 19:58:41 CST 2004
oracle.wh.util.DebugUtility: [[ at runSqlScript(RuntimeInstaller.java ) ]].
Sun Dec 12 19:58:41 CST 2004
oracle.wh.util.DebugUtility: this is SQL error: continue =false
Sun Dec 12 19:58:41 CST 2004
oracle.wh.util.DebugUtility: java.sql.SQLException: ORA-01919: role 'JAVAIDPRIV' does not exist
Sun Dec 12 19:58:41 CST 2004
oracle.wh.util.DebugUtility: java.sql.SQLException: ORA-01919: role 'JAVAIDPRIV' does not exist
Sun Dec 12 19:58:41 CST 2004
oracle.wh.util.DebugUtility:

Sun Dec 12 19:58:41 CST 2004
oracle.wh.util.DebugUtility: at oracle.jdbc.driver.DatabaseError.throwSqlException(DatabaseError.java:125)

Sun Dec 12 19:58:41 CST 2004
oracle.wh.util.DebugUtility: at oracle.jdbc.driver.T2CConnection.checkError(T2CConnection.java:630)

Sun Dec 12 19:58:41 CST 2004
oracle.wh.util.DebugUtility: at oracle.jdbc.driver.T2CStatement.execute_for_describe(T2CStatement.java:841)

Sun Dec 12 19:58:41 CST 2004
oracle.wh.util.DebugUtility: at oracle.jdbc.driver.T2CStatement.execute_for_rows(T2CStatement.java:1002)

Sun Dec 12 19:58:41 CST 2004
oracle.wh.util.DebugUtility: at oracle.jdbc.driver.OracleStatement.doExecuteWithTimeout(OracleStatement.java:1028)

Sun Dec 12 19:58:41 CST 2004
oracle.wh.util.DebugUtility: at oracle.jdbc.driver.OracleStatement.executeUpdate(OracleStatement.java:1451)

Sun Dec 12 19:58:41 CST 2004
oracle.wh.util.DebugUtility: at oracle.wh.ui.install.reposinst.RuntimeInstaller.parseAndRunSqlScript(RuntimeInstaller.java:539)

Sun Dec 12 19:58:41 CST 2004
oracle.wh.util.DebugUtility: at oracle.wh.ui.install.reposinst.ReposInstMain.processSQLDBAToken(ReposInstMain.java:2918)

Sun Dec 12 19:58:41 CST 2004
oracle.wh.util.DebugUtility: at oracle.wh.ui.install.reposinst.ReposInstMain.processDriverFile(ReposInstMain.java:2331)

Sun Dec 12 19:58:41 CST 2004
oracle.wh.util.DebugUtility: at oracle.wh.ui.install.reposinst.ReposInstMain$2.runTask(ReposInstMain.java:1824)

Sun Dec 12 19:58:41 CST 2004
oracle.wh.util.DebugUtility: at oracle.ewt.thread.TaskScheduler.runTask(Unknown Source)

Sun Dec 12 19:58:41 CST 2004
oracle.wh.util.DebugUtility: at oracle.ewt.thread.TaskScheduler.processTask(Unknown Source)

Sun Dec 12 19:58:41 CST 2004
oracle.wh.util.DebugUtility: at oracle.ewt.thread.TaskScheduler$TaskQueue.run(Unknown Source)

Sun Dec 12 19:58:41 CST 2004
oracle.wh.util.DebugUtility: at oracle.ewt.timer.Timer.doRun(Unknown Source)

Sun Dec 12 19:58:41 CST 2004
oracle.wh.util.DebugUtility: at oracle.ewt.timer.Timer.run(Unknown Source)

Sun Dec 12 19:58:41 CST 2004
oracle.wh.util.DebugUtility: at java.lang.Thread.run(Thread.java:534)

Sun Dec 12 19:58:41 CST 2004
oracle.wh.util.DebugUtility: Assistant operation is unsuccessful ...

=====================================================

Please point me in the right direction!
Thanks!
eilison
eilisonl@yahoo.com
Re: INS0029 Error OWB10g Runtime Repository Install Failed [message #138536 is a reply to message #93413] Thu, 22 September 2005 07:13 Go to previous messageGo to next message
abojan
Messages: 4
Registered: September 2005
Junior Member
I had the same problem INS0029, installing owb Runtime Repository on db 10.2.0.1.0.

The problem was that instalation failed on creating views because runtime repository owner does not have privilege to create views.

So I created user first and I granted him the system privilege 'CREATE ANY VIEW'. Then, I started OWB Runtime Assistent and I used option 'Install into an existing schema'.

Ragards
Re: INS0029 Error OWB10g Runtime Repository Install Failed [message #143661 is a reply to message #93413] Fri, 21 October 2005 06:50 Go to previous messageGo to next message
jinpark75
Messages: 11
Registered: October 2005
Junior Member
I'm getting the same problem. I granted create view and still receiving the same error.
Re: INS0029 Error OWB10g Runtime Repository Install Failed [message #143690 is a reply to message #143661] Fri, 21 October 2005 08:29 Go to previous messageGo to next message
abojan
Messages: 4
Registered: September 2005
Junior Member
It is the same error but another reason ... Anyway it will continue with errors and there is no the way out because OWB10g is not certified for database 10g Release 2, but only for 10g Release 1.

You cane see more on
http://forums.oracle.com/forums/message.jspa?messageID=1058416

Best regards
Re: INS0029 Error OWB10g Runtime Repository Install Failed [message #143691 is a reply to message #93413] Fri, 21 October 2005 08:32 Go to previous messageGo to next message
jinpark75
Messages: 11
Registered: October 2005
Junior Member
Actually, I'm running this on 9i database.
Re: INS0029 Error OWB10g Runtime Repository Install Failed [message #143697 is a reply to message #143691] Fri, 21 October 2005 09:00 Go to previous messageGo to next message
abojan
Messages: 4
Registered: September 2005
Junior Member
I did not have this problem with 9i and the only known reason could be that your user doesn't have the necessary access rights

http://www.techsupport.businessobjects.com/DocData/5.0/En/Errors50en.pdf
Re: INS0029 Error OWB10g Runtime Repository Install Failed [message #143699 is a reply to message #93413] Fri, 21 October 2005 09:09 Go to previous messageGo to next message
jinpark75
Messages: 11
Registered: October 2005
Junior Member
What other rights does he need other than create any view
Re: INS0029 Error OWB10g Runtime Repository Install Failed [message #143705 is a reply to message #143699] Fri, 21 October 2005 10:04 Go to previous messageGo to next message
abojan
Messages: 4
Registered: September 2005
Junior Member
The reason could also be a conflicts with another user or role name caused by previous failed attempts or an older version of OWB that was previously installed using the same schema names.

If You go to see a log file in the OWB_HOME\OWB\rtasst directory it shows additional errors which caused the error INS0029

For example:

oracle.wh.util.DebugUtility: java.sql.SQLException:
ORA-00955: name is already used by an existing object

oracle.wh.util.DebugUtility: java.sql.SQLException:
ORA-01920: user name 'Your_Runtime_Repository_User_Name' conflicts with another
user or role name

oracle.wh.util.DebugUtility: java.sql.SQLException:
ORA-01921: role name 'WB_D_Your_Runtime_Repository_User_Name' conflicts with
another user or role name

The best thing to do is to drop users and roles created and to restart the OWB Runtime Repository Assistant.

There are 4 roles that should be droped:
WB_D_Runtime_Repository_Username
WB_A_Runtime_Repository_Username
WB_R_Runtime_Repository_Username
WB_U_Runtime_Repository_Username

I suggest You to go to oracle metalink and submit a search for INS0029. I'm sore You will find solution for Your problem.

Regards
Re: INS0029 Error OWB10g Runtime Repository Install Failed [message #143727 is a reply to message #93413] Fri, 21 October 2005 12:31 Go to previous messageGo to next message
jinpark75
Messages: 11
Registered: October 2005
Junior Member
thanks for your help
Re: INS0029 Error OWB10g Runtime Repository Install Failed [message #143981 is a reply to message #93413] Mon, 24 October 2005 09:17 Go to previous messageGo to next message
jinpark75
Messages: 11
Registered: October 2005
Junior Member
When I look at the log file it generated, I get an Oracle error ORA-03113. Can someone help me?

Re: INS0029 Error OWB10g Runtime Repository Install Failed [message #197601 is a reply to message #93413] Wed, 11 October 2006 23:32 Go to previous messageGo to next message
senthil29
Messages: 4
Registered: October 2006
Junior Member
i too receive the same folloing error

../../rtasst/platform_system_rights.sql
oracle.wh.util.DebugUtility: java.sql.SQLException: ORA-01919: role 'JAVAIDPRIV' does not exist.

i am using oracle10g R2.i have installed Jserver.
can someone help on his?
Re: INS0029 Error OWB10g Runtime Repository Install Failed [message #198620 is a reply to message #197601] Wed, 18 October 2006 00:40 Go to previous messageGo to next message
senthil29
Messages: 4
Registered: October 2006
Junior Member
i got my java errors get corrected by providing the necessary privs.But i receive other kind of error messages like

"ORA-06512-WB_RTI_TARGET_SCHEMA_PRIVS ".
I GET THIS ERROR WHILE CREATING THE REGISTRY USERS.

can any one give me what sort of privs a database user should have while accessing the repository as a repository user.simillarly what privs a repository owner should have......


Regards,
Senthil.
Re: INS0029 Error OWB10g Runtime Repository Install Failed [message #220034 is a reply to message #197601] Sat, 17 February 2007 23:10 Go to previous messageGo to next message
gmustafaabbasi
Messages: 1
Registered: February 2007
Location: bristol
Junior Member
did you find any clue, how to resolve the issue "ORA-01919: role 'JAVAIDPRIV' does not exist"?

I have tried more than my capacity on my win xp pc but unresolve. I dont know why oracle introduced repository culture in all products while it doestn't work properly.

Plz Help
Ghulam
Re: INS0029 Error OWB10g Runtime Repository Install Failed [message #251267 is a reply to message #220034] Thu, 12 July 2007 14:53 Go to previous messageGo to next message
emix
Messages: 3
Registered: July 2007
Junior Member

install JServer option.


Re: INS0029 Error OWB10g Runtime Repository Install Failed [message #289309 is a reply to message #93413] Thu, 20 December 2007 11:31 Go to previous message
acur8dba
Messages: 1
Registered: December 2007
Location: Charlotte
Junior Member
You are running a script from a 3rd party vendor which is trying to grant
roles to users. The grants fail with:

ORA-01919, Role '%s' does not exist

on the following roles:

javadebugpriv
javauserpriv
javaidpriv
javasyspriv


Solution Description
--------------------

Run the INITJVM.SQL script as user SYS or Internal.

The script is located in the ORACLE_HOME\JAVAVM\INSTALL directory.


Explanation
-----------
These roles have not been created because the INITJVM.SQL script to setup the
Java Virtual Machine (JVM) has not been run.

Note that when you run this script, you may see these errors again (i.e.
ORA-1919 - Role JAVADEBUGPRIV does not exist
This is normal, as the script does a drop role prior to creating it, and of
course the role does not exist the first time the script is run.


Previous Topic: Need urgent help with DATE Format issue with Oracle OWB 10gR2
Next Topic: to import view
Goto Forum:
  


Current Time: Mon Dec 22 05:07:04 CST 2014

Total time taken to generate the page: 0.09286 seconds