Home » Developer & Programmer » Forms » troubles with attached library - Forms6i
troubles with attached library - Forms6i [message #87603] Thu, 20 January 2005 05:50 Go to next message
Antonio
Messages: 12
Registered: October 2001
Junior Member
I'm working with Forms6i (6.0.8.8.0).
I have some troubles with attached libraries.
I have to modify an old forms project. All server elements are on the original
server computer (database, sources, libraries , ect..). Now I installed
on a new client Pc forms6i and I tried to open forms modules.
When I open modules I don't see attached library (pll and olb).
I reattached the object library and the pl/sql library but when
I close and open forms6i I can see in module structure only
object library. No pl/sql library . I reattached pl/sql library too
but i get errors like "identifier xyz must be declared" about functions and
procedures defined in my pl/sql library .
First I try to add in registry the pll library path in FORMS60_PATH
then I try following suggestion :
" just put all of your forms (*.fmx), menu (*.mmx) and PLL libraries (*.PLL or *.PLX) files into the same directory, then change your shortcut (icon) that you start the Oracle Forms runtime environment from so it's "Start in" (working directory) is set to the directory where your forms, menus and libraries are. "
I get same errors.
Could you help me ?
Thanks in advance.

Antonio
Re: troubles with attached library - Forms6i [message #87688 is a reply to message #87603] Tue, 01 February 2005 03:28 Go to previous messageGo to next message
Anzar Baig
Messages: 3
Registered: January 2005
Junior Member
hi every one
i have same problem.can any body give solution that how can i fix it .

if i run from short cut its run with an error message library .pll not attached

if i run from form builder its shown the samwe error
tanks
Re: troubles with attached library - Forms6i [message #87689 is a reply to message #87603] Tue, 01 February 2005 03:30 Go to previous messageGo to next message
Anzar Baig
Messages: 3
Registered: January 2005
Junior Member
hi every one
"""I'm working with Forms6i (6.0.8.8.0).
I have some troubles with attached libraries.
I have to modify an old forms project. All server elements are on the original
server computer (database, sources, libraries , ect..). Now I installed
on a new client Pc forms6i and I tried to open forms modules.
When I open modules I don't see attached library (pll and olb).
I reattached the object library and the pl/sql library but when
I close and open forms6i I can see in module structure only
object library. No pl/sql library . I reattached pl/sql library too
but i get errors like "identifier xyz must be declared" about functions and
procedures defined in my pl/sql library .
First I try to add in registry the pll library path in FORMS60_PATH
then I try following suggestion :
" just put all of your forms (*.fmx), menu (*.mmx) and PLL libraries (*.PLL or *.PLX) files into the same directory, then change your shortcut (icon) that you start the Oracle Forms runtime environment from so it's "Start in" (working directory) is set to the directory where your forms, menus and libraries are. "
I get same errors.
Could you help me ?
Thanks in advance.
""""
if i run from short cut its run with an error message library .pll not attached

if i run from form builder its shown the samwe error
tanks
Re: troubles with attached library - Forms6i [message #112045 is a reply to message #87689] Tue, 22 March 2005 11:26 Go to previous message
Matloob
Messages: 39
Registered: December 2004
Member
hi there
u have to recompile ur library
just open the form builder then open ur library and compile it and save it through new version of developer which ur using
then it will work allright
bye
Previous Topic: CAN I MAKE APPLICATION FRONT HAND DEVELOPER2000 AND BACK HAND ACCESS 2000
Next Topic: How to: Attach libraries using environment variable
Goto Forum:
  


Current Time: Thu Aug 28 06:30:25 CDT 2014

Total time taken to generate the page: 0.14044 seconds