Home » Server Options » Text & interMedia » INSO filter problems
INSO filter problems [message #76061] Mon, 21 July 2003 05:49
Juan Salvador
Messages: 4
Registered: July 2003
Junior Member
Hi,
I am using Intermedia to index a table containing about 80000 entries. The index is an URL_DATASTORE type index. I am using the INSO_FILTER, but this filter does not work properly when there is a text document as an input. To solve this, I have written an script that detects when the filter fails, and, in that case, pass the input as the output as is. That is the script:

Set args = WScript.Arguments
Set fso = CreateObject ("Scripting.FileSystemObject")
if (fso.FileExists(args(1))) then
fso.DeleteFile args(1), true
end if
Set shell = CreateObject("WScript.Shell")
Set oExec = shell.Exec ("ctxhx "&args(0)&" "&args(1))
while oExec.Status = 0
wend
if (not fso.FileExists(args(1))) then
fso.CopyFile args(0), args(1)
end if
Set oExec = Nothing

I have used this combination successfully with lighter tables. But in that case, when the table is bigger, the filter hangs after some time. The data base activity stops, but the computer keeps at 100% of activity because of cthhx. So, I suppose the filter is hanging. but what is the reason? May the filter hangs for some type of documents? Are any type known as problematic?

I do not know what is happening. Any ideas/comments/suggestions would be appreciated.

Thank you in advance

Juan Salvador
Previous Topic: what is wrong?About full text index,i can not optimize but i can sync it.
Next Topic: Ghost index
Goto Forum:
  


Current Time: Wed Jul 30 16:48:11 CDT 2014

Total time taken to generate the page: 0.05398 seconds