Home » Server Options » Text & interMedia » InterMedia vs. TNS Listener
InterMedia vs. TNS Listener [message #76055] Wed, 25 June 2003 04:56 Go to next message
Michael R. Brett
Messages: 2
Registered: June 2003
Junior Member
Hi,

I'm running Oracle 8.1.6.3.0 with the 8.1.6.3.5 patch on W2K/SP3.

My problem is that I'm loosing connection to the PLSExtProc via TNS name EXTPROC_CONNECTION_DATA, although anything in tnsnames.ora and listener.ora seems to be configured correctly.

The symptoms are as follows:

- start TNSListener Service
- start SQL*PLUS
- login to my DB as user ctxsys
- do a 'exec ctx_output.start_log('alfactx_basketfile.log');'
=> succeeds
- do a 'exec ctx_output.end_log;'
=> succeeds too

(that's why I expect my NETWORK config to be correct)

- quit SQL*PLUS
- start SQL*PLUS again
- login to my DB as user ctxsys
- do a 'exec ctx_output.start_log('alfactx_basketfile.log');'
=> *
=> ERROR in line 1:
=> ORA-20000: interMedia Text error:
=> DRG-50704: Net8 listener is not running or cannot start external procedures
=> ORA-28575: unable to open RPC connection to external procedure agent
=> ORA-12154: TNS:could not resolve service name .
=> ORA-06512: at "CTXSYS.DRUE", line 126
=> ORA-06512: at "CTXSYS.CTX_OUTPUT", line 39
=> ORA-06512: at Zeile 1

(sometimes this happens not after the second start of SQL*PLUS but after the 3rd...)

After a restart of TNSListener service 'ctx_output.start_log' will again succeed on the first try...

BTW even when SQL*PLUS shows this problem, 'tnsping extproc_connection_data 5' still works fine.

Any idea, what went wrong??

Many thanks in advance

Michael
Re: InterMedia vs. TNS Listener [message #76056 is a reply to message #76055] Mon, 30 June 2003 09:27 Go to previous message
Michael R. Brett
Messages: 2
Registered: June 2003
Junior Member
Well, seems to be a communication/tns problem instead of an intermedia text issue. Should move this thread to oracle.server... :-)

As soon as I switch the communication protocol for the PLSExtProc from IPC to TCP/IP, everything works fine!

So somewhat breaks my IPC. But what? Ans suggestions?

BTW a second W2K/SP3 PC doesn't show this kind of problem at all... weird
Previous Topic: very urgent - want to download pachset 9
Next Topic: Problem in querying using Contains Operator
Goto Forum:
  


Current Time: Mon Oct 20 17:55:12 CDT 2014

Total time taken to generate the page: 0.12003 seconds