Home » Developer & Programmer » Precompilers, OCI & OCCI » sqlcxt error
sqlcxt error [message #75909] Mon, 18 February 2002 00:33 Go to next message
E. Jayasankar
Messages: 1
Registered: February 2002
Junior Member
While linking the Pro*C obj file, I am getting error unresolved symbol, sqlcxt(). How to fix this. I have included orasql8.lib and other necessary files. I have tried linking from the command line also. Still it is not working. I have edited the make.bat file also. I couldn't rectify the problem.

If anybody knows the answer please help me???
Re: sqlcxt error [message #75919 is a reply to message #75909] Sun, 10 March 2002 21:35 Go to previous messageGo to next message
Hari
Messages: 59
Registered: August 2000
Member
Please change the function
extern void sqlcxt (....);

created after the precompilation

as
extern "C" void sqlcxt (...);

The error does not occur. It worked for me. This is in case you are using a C++ file.

Thanks.

Regards.
H.
Re: sqlcxt error [message #75942 is a reply to message #75909] Fri, 26 April 2002 16:00 Go to previous messageGo to next message
Jean_pierre Nziga
Messages: 1
Registered: April 2002
Junior Member
I am trying to compile a program (Pro*C) and I am having the following error message:

Undefined first referenced
symbol in file
sqlcxt /var/tmp/ccdTbkhq.o
ld:fatal:symbol referencing errors. No output written to a.out
collect2:ld returned 1 exit status.

Any help?
Thanks,
Jean_pierre.
Re: sqlcxt error [message #75949 is a reply to message #75909] Mon, 13 May 2002 05:28 Go to previous messageGo to next message
sanjay tripathy
Messages: 1
Registered: May 2002
Junior Member
when i precompile my .pc file it generates .c file successfully with this line
extern sqlcxt (/*_ void **, unsigned long *,
struct sqlexd *, struct sqlcxp * _*/);

and while linking it could not recognise sqlcxt and references is as undefined symbol.
what flags should i use to get link the corresponding oracle library
Re: sqlcxt error [message #75964 is a reply to message #75909] Fri, 12 July 2002 06:02 Go to previous messageGo to next message
D.
Messages: 5
Registered: November 2001
Junior Member
In the pre compiler settings set Code to 'CPP' rather than 'ANSI_C'.
It will then automagicaly wrap the function prototypes with extern "C when the code is generated.
Re: sqlcxt error [message #76007 is a reply to message #75909] Tue, 17 December 2002 07:56 Go to previous messageGo to next message
akhil
Messages: 2
Registered: December 2002
Junior Member
Hi,

I am working on an application which is in HPUnix 10.2(C-Front compiler) with PRO*C
We are mihratingf to HP 11.x (aCC Compiler) with Pro*C.

While compiling Pro*C code, i am getting following error:
"Expected 0 argument(s) for "int sqlcxt()"; had 4 instead"

Anybody can help!!!
Akhil
Re: sqlcxt error How to set the pre compiler settings [message #76083 is a reply to message #75964] Fri, 20 February 2004 01:56 Go to previous messageGo to next message
sathish
Messages: 16
Registered: February 2002
Junior Member
How to set the pre compiler setting Code to 'CPP' rather than 'ANSI-C'.
Re: sqlcxt error [message #76085 is a reply to message #75949] Wed, 10 March 2004 05:57 Go to previous messageGo to next message
Veronica Rincon
Messages: 1
Registered: March 2004
Junior Member
Hi, I have the same problem. Who resolve it?
Thanks
Vero
Re: sqlcxt error [message #76086 is a reply to message #76085] Fri, 19 March 2004 20:35 Go to previous messageGo to next message
AJ
Messages: 11
Registered: April 2002
Junior Member
Hi ,

use -L option as:
-L$ORACLE_HOME/lib

this should tell cc where to find libraries

then use -lclntsh

This would link libclntsh in the application and
sattisfy the sqlcxt code dependency.

Regards
J
Re: sqlcxt error How to set the pre compiler settings [message #76103 is a reply to message #76083] Fri, 16 July 2004 10:00 Go to previous messageGo to next message
Anon
Messages: 6
Registered: October 1999
Junior Member
>>How to set the pre compiler setting Code to 'CPP'
>>rather than 'ANSI-C'.

proc myfile.pc CODE=CPP

"RTFM"
Re: sqlcxt error How to set the pre compiler settings [message #76106 is a reply to message #76103] Thu, 12 August 2004 05:47 Go to previous messageGo to next message
anto jerlin
Messages: 1
Registered: August 2004
Junior Member
it says semantic error its not able to connect to database how to set the path
Re: sqlcxt error -to many call arguments [message #76184 is a reply to message #76083] Mon, 07 February 2005 22:15 Go to previous messageGo to next message
Ganesh
Messages: 31
Registered: November 2000
Member
Hi ,
I also facing the problem with the sqlcxt. when i am compiling the file it gives the error as
"To many call arguments to sqlcx()" . I have the Pre compiler setting as CPP only.

Can any one help meeeeeeeeeeee....

Thanks in Advance
Ganesh
Re: sqlcxt error How to set the pre compiler settings [message #193758 is a reply to message #76103] Tue, 19 September 2006 05:35 Go to previous messageGo to next message
shekar_tr
Messages: 1
Registered: September 2006
Junior Member
Hi,

As you mentioned in prev. msgs i compiled my proc as
proc myproc.pc CODE=CPP
after that
when i tried to compile it with xlc (VC++ compile on AIX). giiving me the "syntax error" in the line extern "C" Void
Re: sqlcxt error How to set the pre compiler settings [message #382776 is a reply to message #193758] Sat, 24 January 2009 10:10 Go to previous message
amit.singhal
Messages: 2
Registered: January 2009
Junior Member
if you are using xlc then it will only compile your C code and not CPP code. "extern" in compiled pro*C file is because you created cpp file from your proC file. If you have just xlc then create C file with proc using option code=ANSI_C

Hope it helps you.
Previous Topic: Advice needed for performance improvement in OCI program
Next Topic: libirc.a is empty (merged)
Goto Forum:
  


Current Time: Sun Dec 04 04:19:32 CST 2016

Total time taken to generate the page: 0.07243 seconds