Home » Server Options » Streams & AQ » ORA-00942 in apply process
ORA-00942 in apply process [message #75764] Fri, 21 January 2005 04:54 Go to next message
Messages: 3
Registered: December 2002
Junior Member
Hi all,
I've configured a streams test evironment using 2 database, according to the oramag article (http://www.oracle.com/technology/oramag/oracle/04-nov/o64streams.html).

From various diagnostic queries I've run, I think both capture and propagation processes are running ok. Interesting stuff shows up when querying DBA_APPLY_ERROR:

ORA-00942: table or view does not exist

I have no clue which table it is that the error applies to. The destination table exists and the streams user has enough privileges on it.

Running DBMS_APPLY_ADM.EXECUTE_ALL_ERRORS also gives me an ORA-00942:
ERROR at line 1:
ORA-00942: table or view does not exist
ORA-06512: at "SYS.DBMS_APPLY_ERROR", line 65
ORA-06512: at "SYS.DBMS_APPLY_ERROR", line 208
ORA-06512: at "SYS.DBMS_APPLY_ADM", line 439
ORA-06512: at line 1

I have no clue about where to go to find out which table it is that causes the error, hope someone over here can give me a hint.

Re: ORA-00942 in apply process [message #75765 is a reply to message #75764] Mon, 24 January 2005 03:38 Go to previous message
Messages: 3
Registered: December 2002
Junior Member
the problem is solved, found it by creating a logon trigger that enables sql_trace for my strmadmin user.

I was indeed the replicated table that was unaccessible by strmadmin. As I found out the hard way, role privileges are not valid inside stored procedures ..

Previous Topic: New to Warehousing
Next Topic: How to find which two databases are configured for streams
Goto Forum:

Current Time: Sun Nov 29 22:48:34 CST 2015

Total time taken to generate the page: 0.07721 seconds