Home » RDBMS Server » Enterprise Manager » Authentication adapter initialization failed
Authentication adapter initialization failed [message #68435] Tue, 16 September 2003 08:19 Go to next message
teched
Messages: 5
Registered: September 2003
Junior Member
Hi everyone,

I have installed a Oracle EE 8.1.7.0 database in windows 2000 server. I also run an Oracle EE 8.1.5 database. One of the main reasons for install 8.1.7 on a new server was to try and get rid of this VNI-2015 error that has been the bain of my existence.

Anyway in my oms.log I have found the following error:

OEMCTRL for Windows NT: Version 2.2.0.0.0
Copyright (c) 1998, 2000, Oracle Corporation. All rights reserved.
Starting the Oracle Management Server... [[main]][[2003-9-12:15:19:48:782]] VdbSession.processError: errorCode >12640<
[[main]][[2003-9-12:15:19:48:782]] VdbSession.processError: errorMsg >ORA-12640: Authentication adapter initialization failed
<
[[main]][[2003-9-12:15:19:48:782]] VdbSession.processError: database connection error

VXA-2018 :
Unable to connect to OMS registry serviceoracle.sysman.vxn.VxnBootstrapException:
at oracle.sysman.vxa.VxaAppServer.startServices(VxaAppServer.java:1353)
at oracle.sysman.vxa.VxaAppServer.main(VxaAppServer.java:2547)

Error starting Oracle Management Server. OEMCTRL for Windows NT: Version 2.2.0.0.0
Copyright (c) 1998, 2000, Oracle Corporation. All rights reserved.
Starting the Oracle Management Server... [[main]][[2003-9-15:10:47:48:140]] VdbSession.processError: errorCode >12640<
[[main]][[2003-9-15:10:47:48:156]] VdbSession.processError: errorMsg >ORA-12640: Authentication adapter initialization failed
<
[[main]][[2003-9-15:10:47:48:156]] VdbSession.processError: database connection error

VXA-2018 :
Unable to connect to OMS registry serviceoracle.sysman.vxn.VxnBootstrapException:
at oracle.sysman.vxa.VxaAppServer.startServices(VxaAppServer.java:1353)
at oracle.sysman.vxa.VxaAppServer.main(VxaAppServer.java:2547)

Could someone tell me if this is the reason for me not being able to resolve the VNI-2015 error I have been getting.

Or is this just the error message that I am getting when I try a import/export in OEM 2.2.

Many thanks

Eddy
Re: Authentication adapter initialization failed [message #68436 is a reply to message #68435] Tue, 16 September 2003 14:08 Go to previous messageGo to next message
Mahesh Rajendran
Messages: 10671
Registered: March 2002
Location: oracleDocoVille
Senior Member
Account Moderator
vni-2015 is related to your privileges and rights.
You have to login as an OS administrative in order to be able to run batch jobs in OEM.

and now you are not having a VNI-2015.

this time you get VAX-2018 which means your OMS is not properly configured.
first you need to configure OMS, create repository.
discover nodes and databases and then, schedule the batch jobs.

VAX-2015 is occuring becuase , OEMCTRL is tryint to talk to the OMS databases and errors out with ORA-12640.
My best guess is , you must be having the following 
entry in your sqlnet.ora

SQLNET.AUTHENTICATION_SERVICES = (NTS) 

remove or comment of the above entry in ur Database sqlnet.ora and oms sqlnet.ora and anywhere.
try to restart OMS.

Re: Authentication adapter initialization failed [message #68437 is a reply to message #68435] Tue, 16 September 2003 14:14 Go to previous messageGo to next message
Mahesh Rajendran
Messages: 10671
Registered: March 2002
Location: oracleDocoVille
Senior Member
Account Moderator
if your OS is windows 2000 and you are receiving the vni-2015 error, please have a look in our old posting
Re: Authentication adapter initialization failed [message #68439 is a reply to message #68435] Thu, 18 September 2003 07:50 Go to previous messageGo to next message
teched
Messages: 5
Registered: September 2003
Junior Member
Ok found out that there was a bug with OEM 2.2, that was the reason i kept getting this error "ORA-12640: Authentication adapter initialization failed", one bug of many aparently.

The work around for this is to set the SQLNET.AUTHENTICATION_SERVICES= (NONE) in the sqlnet.ora file

Managed to get access to metalink and found at least 38 separate pacthes for 8.1.7. The one I downloaded was 115mb.

Also found out the reason why I kept getting the VNI-2015 error with OEM 2.0.4 was not because the credentials were wrong but because it has a bug that does not allow exporting or importing.

Managed to get past the VNI-2015 in OEM 2.2 by Instead of creating an OS user logon for the domain I created one for just the server and then granted "log on as a batch job".

Hope this is some help to any poor sole that gets stuck on the same problem.

Eddy
Re: Authentication adapter initialization failed [message #432577 is a reply to message #68439] Wed, 25 November 2009 00:42 Go to previous message
mayurebg
Messages: 1
Registered: November 2009
Location: mumbai
Junior Member
Yes i was having the same issue and i have done following and it has solved my problem

solution is this line
The work around for this is to set the SQLNET.AUTHENTICATION_SERVICES= (NONE) in the sqlnet.ora file

Other steps that needs to be done
1> IIS 32-bit change
2> in command prompt - run >> type following
C:\Windows\syswow64\rundll32.exe "C:\Program Files (x86)\Common Files\System\Ole DB\oledb32.dll",OpenDSLFile C:\test.udl
This will give you to create the .udl connection file for oracle OLE DB driver

The problem was the server is 64bit oracle server.
64bit iis needs to be converted to 32bit
Previous Topic: OEM for the first time
Next Topic: Problems after recreate emca
Goto Forum:
  


Current Time: Tue Sep 27 05:57:22 CDT 2016

Total time taken to generate the page: 0.14208 seconds