Home » RDBMS Server » Networking and Gateways » Ora-27101 : shared memory realm does not exist
Ora-27101 : shared memory realm does not exist [message #67607] Mon, 15 November 2004 03:17 Go to next message
karen
Messages: 19
Registered: January 2002
Junior Member
Hi,

I'm getting the following errors when I try to connect :

ORA-01034 : <A class=iAs style="COLOR: darkgreen; BORDER-BOTTOM: darkgreen 1px solid; BACKGROUND-COLOR: transparent; TEXT-DECORATION: underline" href="http://www.tek-tips.com/viewthread.cfm?qid=951653&page=1#" target=_blank>ORACLE[/url] not available
Ora-27101 : shared memory realm does not exist

When I start my <A class=iAs style="COLOR: darkgreen; BORDER-BOTTOM: darkgreen 1px solid; BACKGROUND-COLOR: transparent; TEXT-DECORATION: underline" href="http://www.tek-tips.com/viewthread.cfm?qid=951653&page=1#" target=_blank>pc[/url] oracle does not start up by itself so I go to run -> cmd and type in :

set oracle_sid = grms
sqlplus /nolog
conn system/manager as sysdba
startup

The <A class=iAs style="COLOR: darkgreen; BORDER-BOTTOM: darkgreen 1px solid; BACKGROUND-COLOR: transparent; TEXT-DECORATION: underline" href="http://www.tek-tips.com/viewthread.cfm?qid=951653&page=1#" target=_blank>database[/url] then starts up.

Problem is I still get the error if I try to connect through Toad or <A class=iAs style="COLOR: darkgreen; BORDER-BOTTOM: darkgreen 1px solid; BACKGROUND-COLOR: transparent; TEXT-DECORATION: underline" href="http://www.tek-tips.com/viewthread.cfm?qid=951653&page=1#" target=_blank>sql[/url]*plus.

My tnsnames is correct. I checked it a few times.

The funny thing is that if I plug my network cable out, and restart my pc, my oracle starts up by itself and I don't have any problems.

So that let me think that maybe it is some sort of network problem or security setting. I know an outside contractor came to our company and changed some of the security settings on our network. Closed some of the ports etc. Don't know exactly what. My user belongs to the ORA_DBA group on my pc. Can't find ORA_DBA on the domain. So if I have to add it to the domain - how ?

My listener is started.

Do you think this can be the problem? Or am I totally looking at the wrong place? I don't have a lot of network/security knowledge. Does anybody have some suggestions what I must look for. I can contact the guy who changed our security setting, but at this stage I don't even know what to ask him.

Thanks
Karen
Re: Ora-27101 : shared memory realm does not exist [message #67632 is a reply to message #67607] Fri, 26 November 2004 07:52 Go to previous messageGo to next message
Emy
Messages: 1
Registered: November 2004
Junior Member
Sorry for my english.
I don't know the reason, but try to put a comment in sqlnet.ora in the following line:

#SQLNET.AUTHENTICATION_SERVICES= (NTS)

May be this is not the correct solution, but worked for me :)
Re: Ora-27101 : shared memory realm does not exist [message #67709 is a reply to message #67632] Sun, 23 January 2005 19:43 Go to previous messageGo to next message
Manoj Dudhe
Messages: 1
Registered: January 2005
Junior Member
Hi All,

#SQLNET.AUTHENTICATION_SERVICES= (NTS) This worked for me also. Thanks EMY.
Re: Ora-27101 : shared memory realm does not exist [message #67720 is a reply to message #67607] Wed, 26 January 2005 21:32 Go to previous messageGo to next message
krishna
Messages: 141
Registered: October 1998
Senior Member
Hi,

Just restart the server and login are root and follow the instructions.

> su - root
root> sqlplus sqlplus /nolog
root> connect sys as sysdba
root> enter password
>root startup force

and start the listener.

This will work.

Thanks,
Krishna Nimishakavi
Re: Ora-27101 : shared memory realm does not exist [message #67726 is a reply to message #67709] Thu, 03 February 2005 06:36 Go to previous messageGo to next message
hal1961
Messages: 1
Registered: February 2005
Junior Member
Thank's a lot, I just fixed this trouble now by
adding the # in the sqlnet.ora :-)
Re: Ora-27101 : shared memory realm does not exist [message #67727 is a reply to message #67632] Thu, 03 February 2005 10:24 Go to previous messageGo to next message
JUAN
Messages: 23
Registered: November 2000
Junior Member
work for me too
thanks
Re: Ora-27101 : shared memory realm does not exist [message #67728 is a reply to message #67632] Fri, 04 February 2005 06:04 Go to previous messageGo to next message
Windows
Messages: 1
Registered: February 2005
Junior Member
Thanks's
Funciono!
Re: Ora-27101 : shared memory realm does not exist [message #67731 is a reply to message #67632] Tue, 08 February 2005 09:57 Go to previous messageGo to next message
Steve
Messages: 190
Registered: September 1999
Senior Member
Thanks, putting the comment below also worked for me in Oracle 8.17

#SQLNET.AUTHENTICATION_SERVICES= (NTS)
Re: Ora-27101 : shared memory realm does not exist [message #67732 is a reply to message #67720] Wed, 09 February 2005 01:15 Go to previous messageGo to next message
Nick
Messages: 64
Registered: February 2000
Member
Sorry also for my english. :-)

I did this: #SQLNET.AUTHENTICATION_SERVICES= (NTS)
After that, i opened the Database again in DBA Stundio and after that, it worked well.
But if I restart the Server or the service, the Database is down again, i will get the Error 2701 again and i have to restart it again.

Any Ideas what i can do?

Thank for your help.
icon14.gif  Re: Ora-27101 : shared memory realm does not exist [message #206403 is a reply to message #67607] Wed, 29 November 2006 22:52 Go to previous messageGo to next message
deva82
Messages: 1
Registered: November 2006
Location: Mumbai
Junior Member
I put # before SQLNET.AUTHENTICATION_SERVICES= (NTS) line
in SQLNET.ORA file and it also works for oracle 9i

#SQLNET.AUTHENTICATION_SERVICES= (NTS)

Thanks EMY.
Re: Ora-27101 : shared memory realm does not exist [message #213920 is a reply to message #67607] Fri, 12 January 2007 14:31 Go to previous messageGo to next message
business1
Messages: 5
Registered: December 2006
Junior Member
Will I hop this work out I will look for that.




[Updated on: Fri, 12 January 2007 14:34] by Moderator

Report message to a moderator

Re: Ora-27101 : shared memory realm does not exist [message #213921 is a reply to message #213920] Fri, 12 January 2007 14:34 Go to previous messageGo to next message
Mahesh Rajendran
Messages: 10672
Registered: March 2002
Location: oracleDocoVille
Senior Member
Account Moderator
@business1
Stop spamming. Or you will get banned.
Re: Ora-27101 : shared memory realm does not exist [message #354861 is a reply to message #67607] Tue, 21 October 2008 12:34 Go to previous messageGo to next message
KbCb
Messages: 2
Registered: October 2008
Junior Member
I have been getting the "Shared Memory Realm Does Not Exist" error on my oracle instance as well... When I do the following, it works again:

sqlplus /nolog
connect sys as sysdba
startup force

It then loads the database and things are working again. Even if I restart the oracle services it continues to work (for a while). But, after a while it stops working. For example, I ran with the database for about 24 hours, and then it stopped working again, and I started receiving the "Shared memory realm does not exist" error again.

Anyone have any ideas why this is occurring?
Re: Ora-27101 : shared memory realm does not exist [message #354867 is a reply to message #354861] Tue, 21 October 2008 13:14 Go to previous messageGo to next message
Michel Cadot
Messages: 64153
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Why what is occuring? It still works or it then does not work?

Regards
Michel
Re: Ora-27101 : shared memory realm does not exist [message #354890 is a reply to message #354867] Tue, 21 October 2008 18:13 Go to previous message
KbCb
Messages: 2
Registered: October 2008
Junior Member
It works for a while, then quits working giving the "Shared realm not available" error again (after about 24 hours).
Previous Topic: tns problem
Next Topic: Cannot start listener
Goto Forum:
  


Current Time: Sun Dec 11 02:28:04 CST 2016

Total time taken to generate the page: 0.09845 seconds