Home » Developer & Programmer » Forms » How to view code for attached library? (Forms 11g )
How to view code for attached library? [message #681194] Wed, 24 June 2020 10:13 Go to next message
Pameta
Messages: 6
Registered: June 2020
Junior Member
I have procedure called to run the report and seems like server name is coded there. And procedure is in attached library. I like to view the code of the procedure and edit if necessary. How do I do it? I can not see in "Form Builder". Also where can I find it? and how to open it? Thanks.
Re: How to view code for attached library? [message #681202 is a reply to message #681194] Thu, 25 June 2020 05:50 Go to previous messageGo to next message
jury68000
Messages: 15
Registered: October 2019
Junior Member
I'm quite new to Forms, so if I write silly things I hope someone more experienced will correct me.
There is a variable called FORMS_PATH and it exists in %ORACLE_HOME%/forms/server/default.env file, Windows Registry (assuming you are on Windows, if not I do not remember where its on Linux/Unix) and Environment Variables in Windows. If I remember correctly path for compiled runtime libraries (*.plx) is in that default.env file and path for source code for the libraries (*.pll) is in one of the other locations, do not remember which one of those 2, so just check it out by yourself.
And if you want to change it, just open it in Forms Builder just as a 'normal' *.fmb module than change what you want, compile it and place it where plx binaries are (of course its possible that pll's and plx files are in the same location)

[Updated on: Thu, 25 June 2020 05:51]

Report message to a moderator

Re: How to view code for attached library? [message #681203 is a reply to message #681202] Thu, 25 June 2020 08:27 Go to previous messageGo to next message
Pameta
Messages: 6
Registered: June 2020
Junior Member
How do I compile and generate *.plx file?
Re: How to view code for attached library? [message #681204 is a reply to message #681203] Thu, 25 June 2020 09:17 Go to previous messageGo to next message
jury68000
Messages: 15
Registered: October 2019
Junior Member
Exactly the same as you compile fmb module.
I'm not at work right now and I do not have Forms Builder at home Wink but if I remember correctly first press Ctrl-T and then Ctrl-Shift-K (but I could be wrong with this, will verify it tomorrow)
Re: How to view code for attached library? [message #681205 is a reply to message #681204] Thu, 25 June 2020 09:26 Go to previous messageGo to next message
Pameta
Messages: 6
Registered: June 2020
Junior Member
Thank you. So if I compile in Form builder server and then take .plx and put it in path on migrated server? will it attach to all the forms where library is called?
Re: How to view code for attached library? [message #681206 is a reply to message #681205] Thu, 25 June 2020 12:27 Go to previous messageGo to next message
jury68000
Messages: 15
Registered: October 2019
Junior Member
I do not understand what your "migrated server" is. Just put the new plx in the location where FORMS_PATH points to (backing up the current plx just in case Wink ) and then each Forms module which is run, will load up the new plx library.

[Updated on: Thu, 25 June 2020 12:27]

Report message to a moderator

Re: How to view code for attached library? [message #681214 is a reply to message #681194] Fri, 26 June 2020 15:24 Go to previous messageGo to next message
Pameta
Messages: 6
Registered: June 2020
Junior Member
Thank you. Basically we have created new development server and now having all configuration issues that we are trying to figure out.
So now we are passed that error but we changed WEB.SHOW_DOCUMENT('http://servername_new:8888/webreports/' || vcFile,'_blank'); we only changed servername to new one and kept port number same and getting error http 404 error. Trying to understand what else do we need to change to make report display. Tried port "7777" but did not work. Where should I look now? Thanks
Re: How to view code for attached library? [message #681243 is a reply to message #681214] Mon, 29 June 2020 13:03 Go to previous message
Pameta
Messages: 6
Registered: June 2020
Junior Member
Documenting in case anyone wants to know this.

We were able to figure out. There was Alias set in forms.conf file under OHS. Changed that pointing to new server and restarted OHS. and it's working now
Previous Topic: 2 multiple items data in single item??
Next Topic: Send SMS using Oracle Forms 6i
Goto Forum:
  


Current Time: Mon Aug 10 20:45:24 CDT 2020