Home » Infrastructure » Unix » [REQ] Oracle Database 7i for sparc
[REQ] Oracle Database 7i for sparc [message #680748] Sat, 06 June 2020 08:52 Go to next message
Simon180
Messages: 3
Registered: June 2020
Junior Member
I dont no if this is allowed am sorry if its not but am looking for a copy of the legacy oracle database 7i for sparc platform am wondering if anyone has a copy some were hidden away I searched the internet and even ebay with no luck.

I require this for a small project to restore some legacy software.

if this is not allowed please remove and am sorry just dont no were else to ask.

thanks alot

Yours
Simon
Re: [REQ] Oracle Database 7i for sparc [message #680750 is a reply to message #680748] Sat, 06 June 2020 10:48 Go to previous messageGo to next message
Michel Cadot
Messages: 67227
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator

There was never 7i, "i" starts at 8i for 8.1.* versions, and you have to specify the OS.
Anyway, it is not legal to get any Oracle materials on Internet.
You have to contact Oracle itself.

Re: [REQ] Oracle Database 7i for sparc [message #680751 is a reply to message #680750] Sat, 06 June 2020 11:49 Go to previous messageGo to next message
Simon180
Messages: 3
Registered: June 2020
Junior Member
thanks it would be oracle 7.3.4 database for sparc Solrais 7/8, I did contact the oracle sales team and was told that oracle no longer support nor offer older database downloads as such its class's as abandonware so can be shared legally. I have copy of oracle 8i but the files that I use require 7.3.4 to compile.

[Updated on: Sat, 06 June 2020 11:59]

Report message to a moderator

Re: [REQ] Oracle Database 7i for sparc [message #680752 is a reply to message #680751] Sat, 06 June 2020 13:26 Go to previous messageGo to next message
Michel Cadot
Messages: 67227
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator

OK.
Files? what kind of files?

Re: [REQ] Oracle Database 7i for sparc [message #680753 is a reply to message #680752] Sat, 06 June 2020 16:02 Go to previous messageGo to next message
Simon180
Messages: 3
Registered: June 2020
Junior Member
just a backend to some legacy code I have that I need to get compiled the database backend for it uses oracle 7 proc and libs
Re: [REQ] Oracle Database 7i for sparc [message #681014 is a reply to message #680753] Sun, 07 June 2020 00:50 Go to previous message
Michel Cadot
Messages: 67227
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator

Can't you modify it to compile with a higher version?
I fail to understand how this couldn't work.
I have Pro*C code I have written for version 7 and made it work for every version up to 11gR2.
Maybe you could post this question about your code in our Pro*C forum, we may help you to make it work.

Previous Topic: How to start if sqlloader fails inside shell script
Goto Forum:
  


Current Time: Sat Jul 04 01:56:41 CDT 2020