Home » Developer & Programmer » Forms » Language (Oracle Developer 6i, Win 7)
Language [message #678768] Wed, 08 January 2020 12:38 Go to next message
hissam78
Messages: 113
Registered: August 2011
Location: PAKISTAN
Senior Member
Dear Respectful Experts,
I have installed my Native Language URDU in windows 7 and also setup NLS_LANG in REGEDIT = AMERICAN_AMERICA.AR8MSWIN1256
but in oracle DB value is saved and display in developer Forms like ????????

jpg file attached for your kind reference.

somebody can help me to solve this problem.
  • Attachment: Language.jpg
    (Size: 20.84KB, Downloaded 259 times)
Re: Language [message #678770 is a reply to message #678768] Wed, 08 January 2020 13:56 Go to previous messageGo to next message
Michel Cadot
Messages: 66934
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator

1/ Does AR8MSWIN1256 which is "Microsoft Windows Code Page 1256 8-Bit Latin/Arabic" support Urdu characters?
2/ Does you Forms use this setting?
3/ Does your database support these characters (i.e. what is its character set)?

Re: Language [message #678877 is a reply to message #678770] Sat, 18 January 2020 10:39 Go to previous messageGo to next message
hissam78
Messages: 113
Registered: August 2011
Location: PAKISTAN
Senior Member
1/ Does AR8MSWIN1256 which is "Microsoft Windows Code Page 1256 8-Bit Latin/Arabic" support Urdu characters?
YES IT SUPPORT URDU BECAUSE NOT A BIG DIFFERENCE BETWEEN URDU AND ARABIC ALPHABETS.

2/ Does you Forms use this setting?
CAN YOU PLEASE TELL ME HOW TO CHECK FORM 6i SETTING.

3/ Does your database support these characters (i.e. what is its character set)?
FOLLOWING IS THE CHARACTER SET, I HAVE USED THE FOLLOWING SQL TO FIND THE VALUE

SELECT *
FROM v$nls_parameters
WHERE parameter LIKE '%CHARACTERSET';


PARAMETER VALUE

NLS_CHARACTERSET WE8MSWIN1252
NLS_NCHAR_CHARACTERSET AL16UTF16
Re: Language [message #678878 is a reply to message #678877] Sat, 18 January 2020 12:46 Go to previous messageGo to next message
Michel Cadot
Messages: 66934
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator

For 2. I can't tell but I know Littlefoot or cookiemonster can.
For 3. Do not check v$nls_parameters but NLS_DATABASE_PARAMETERS.

Also post the result of the following query from a client Forms workstation (not the database server):
Select distinct client_charset||' - '||client_version
from v$session_connect_info
where sid = sys_context('USERENV','SID')
  and client_charset is not null
/
Re: Language [message #679250 is a reply to message #678768] Wed, 19 February 2020 01:10 Go to previous messageGo to next message
hissam78
Messages: 113
Registered: August 2011
Location: PAKISTAN
Senior Member
Dear Respectful,
At last i have found some solution for urdu language setup in Oracle.
but when i execute the query from oracle 10g db, still few alphabet showing Question mark (???) sign. please see the attached jpg file for your kind reference.

following english alphabets still showing ? in place of urdu alphabet.

Upper case T
Upper Case D
lower case h
lower case k
lower case o
lower case y

i have setup AMERICAN_AMERICA.UTF8 in windows registry in NLS_LANG.
AND
setup characterset AMERICAN_AMERICA.AR8MSWIN1256 in oracle db 10g


somebody can help me to resolve this problem please. why few english alphabet showing ??? in Urdu alphabet.


grateful...

Re: Language [message #679251 is a reply to message #679250] Wed, 19 February 2020 01:24 Go to previous messageGo to next message
Michel Cadot
Messages: 66934
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator

Quote:
At last i have found some solution for urdu language setup in Oracle.
What is it?

Re: Language [message #679252 is a reply to message #679251] Wed, 19 February 2020 01:47 Go to previous message
hissam78
Messages: 113
Registered: August 2011
Location: PAKISTAN
Senior Member
very sorry if some embarrassment by using these words... i am feeling ashamed.

i am very much grateful to all my brilliant experts by helping or problems. i have seen nothing pending request from my dear experts ever. what ever request i sent to this forum solved promptly.

for the solution if this query i am specially thankful to our great expert Michel Cadot.

Sir, i have changed the characterset as UTF8 in place of AR8MSWIN1256 in oracle 10G db. and the problem resolved. now


Thankful

Previous Topic: Alert firing several times
Next Topic: sending email from forms with report in pdf as an attachment
Goto Forum:
  


Current Time: Sun Apr 05 02:58:48 CDT 2020