Home » Developer & Programmer » Forms » Forms 10g: builder crash while opening a Form even first connect (ctrl+j)
Forms 10g: builder crash while opening a Form even first connect (ctrl+j) [message #678422] Mon, 02 December 2019 00:04 Go to next message
oralover2006
Messages: 144
Registered: January 2010
Location: India
Senior Member
hi all,

I have build a Form module, it was successfully modified and run, now for some reason, re-installed the same OS (Win7 32 bit) as previously, Java 6u45, Dev 10g, but when trying to Open (just open) .fmb in builder it crashed every time even when first connect with same database schema, please help, how it can be resolved. Form contain PRE-FORM trigger to populate TREE ITEM which used to navigate through all Forms and Reports modules.

repeating: it was working fine previously.

regards
Re: Forms 10g: builder crash while opening a Form even first connect (ctrl+j) [message #678430 is a reply to message #678422] Tue, 03 December 2019 05:34 Go to previous messageGo to next message
oralover2006
Messages: 144
Registered: January 2010
Location: India
Senior Member
is there any hope this can resolved?
Re: Forms 10g: builder crash while opening a Form even first connect (ctrl+j) [message #678431 is a reply to message #678430] Tue, 03 December 2019 07:19 Go to previous messageGo to next message
cookiemonster
Messages: 13755
Registered: September 2008
Location: Rainy Manchester
Senior Member
Can you get a previous version from source control and open that?
Re: Forms 10g: builder crash while opening a Form even first connect (ctrl+j) [message #678432 is a reply to message #678431] Tue, 03 December 2019 07:20 Go to previous messageGo to next message
cookiemonster
Messages: 13755
Registered: September 2008
Location: Rainy Manchester
Senior Member
For that matter can it be opened on another pc?
Re: Forms 10g: builder crash while opening a Form even first connect (ctrl+j) [message #678436 is a reply to message #678432] Tue, 03 December 2019 22:50 Go to previous messageGo to next message
oralover2006
Messages: 144
Registered: January 2010
Location: India
Senior Member
thanks @cookiemonster for reply Smile

no, there is not from Previous Version now, the Form was modified and saved ( my bad I didn't create a backup )
as already mentioned, it was working fine on same OS, same Developer 10g version before re-installation of OS and all other things.

regards

[Updated on: Tue, 03 December 2019 22:53]

Report message to a moderator

Re: Forms 10g: builder crash while opening a Form even first connect (ctrl+j) [message #678443 is a reply to message #678436] Wed, 04 December 2019 06:00 Go to previous messageGo to next message
cookiemonster
Messages: 13755
Registered: September 2008
Location: Rainy Manchester
Senior Member
That doesn't answer my second question
Re: Forms 10g: builder crash while opening a Form even first connect (ctrl+j) [message #678444 is a reply to message #678443] Wed, 04 December 2019 06:19 Go to previous messageGo to next message
oralover2006
Messages: 144
Registered: January 2010
Location: India
Senior Member
oh, sorry, i didn't yet checked on another PC.
Re: Forms 10g: builder crash while opening a Form even first connect (ctrl+j) [message #678445 is a reply to message #678444] Wed, 04 December 2019 06:38 Go to previous messageGo to next message
cookiemonster
Messages: 13755
Registered: September 2008
Location: Rainy Manchester
Senior Member
That would be the place to start.
Re: Forms 10g: builder crash while opening a Form even first connect (ctrl+j) [message #678456 is a reply to message #678445] Thu, 05 December 2019 22:12 Go to previous messageGo to next message
oralover2006
Messages: 144
Registered: January 2010
Location: India
Senior Member
but already mentioned in my OP
repeating: it was working fine previously.
and all environment was same as current.

regards

EDIT: yes, I have checked now on another machine which is Win XP SP3 32bit, same Dev. 10g version, and it works fine - opened and also run from developer.

[Updated on: Fri, 06 December 2019 01:05]

Report message to a moderator

Re: Forms 10g: builder crash while opening a Form even first connect (ctrl+j) [message #678457 is a reply to message #678456] Fri, 06 December 2019 01:12 Go to previous messageGo to next message
John Watson
Messages: 8077
Registered: January 2010
Location: Global Village
Senior Member
So is the situation that your form runs on Windows XP but fails on Windows 7?
Re: Forms 10g: builder crash while opening a Form even first connect (ctrl+j) [message #678459 is a reply to message #678456] Fri, 06 December 2019 02:45 Go to previous messageGo to next message
cookiemonster
Messages: 13755
Registered: September 2008
Location: Rainy Manchester
Senior Member
oralover2006 wrote on Fri, 06 December 2019 04:12
but already mentioned in my OP
repeating: it was working fine previously.
and all environment was same as current.
That doesn't mean you don't need to check it on another PC.
The problem is either that the fmb is just corrupted - in which case it won't open in anything.
Or there's a forms builder issue on that machine.

oralover2006 wrote on Fri, 06 December 2019 04:12


EDIT: yes, I have checked now on another machine which is Win XP SP3 32bit, same Dev. 10g version, and it works fine - opened and also run from developer.

So it's a form builder issue.
Re: Forms 10g: builder crash while opening a Form even first connect (ctrl+j) [message #678461 is a reply to message #678459] Fri, 06 December 2019 05:56 Go to previous messageGo to next message
oralover2006
Messages: 144
Registered: January 2010
Location: India
Senior Member
you mean I have to re-install Dev 10g ? if yes, i can check on next week.
Re: Forms 10g: builder crash while opening a Form even first connect (ctrl+j) [message #678462 is a reply to message #678457] Fri, 06 December 2019 05:58 Go to previous message
oralover2006
Messages: 144
Registered: January 2010
Location: India
Senior Member
yes @John Watson, but this time only, previously on same Win 7 everything was working fine.
Previous Topic: LOGON function
Next Topic: FORMAT OF DATA IN FORMS 6i
Goto Forum:
  


Current Time: Mon Dec 09 20:37:38 CST 2019