Home » RDBMS Server » Enterprise Manager » EM Daemon is not running & no 'emctl start/stop agent' command (EM Oracle database control 11.2.0.1 )
EM Daemon is not running & no 'emctl start/stop agent' command [message #677131] Wed, 21 August 2019 00:09 Go to next message
blackfruit
Messages: 3
Registered: August 2019
Junior Member
I have successfully configured the EM with "emca -config dbcontrol db -repos recreate".

But when I ran "emctl status dbconsole" after I emctl start dbconsole",I received the following message:
Oracle Enterprise Manager 11g Database Control Release 11.2.0.1.0
Copyright (c) 1996, 2009 Oracle Corporation. All rights reserved.
.....
EM Daemon is not running.

I did the "emctl reload agent" and got the messages:
Oracle Enterprise Manager 11g Database Control Release 11.2.0.1.0
Copyright (c) 1996, 2009 Oracle Corporation. All rights reserved.
---------------------------------------------------------------
Agent is Not Running

When I tried to "emctl start agent", I found the "emctl start agent" is not supported:
------------------------------------------------------------------------
Oracle Enterprise Manager 11g Database Control Release 11.2.0.1.0
Copyright (c) 1996, 2009 Oracle Corporation. All rights reserved.
Oracle Enterprise Manager 10g Database Control commands:
emctl start | stop dbconsole
emctl status | secure | setpasswd dbconsole
emctl config dbconsole -heap_size <size_value> -max_perm_size <size_value>
emctl status agent
emctl status agent -secure [-omsurl ...*>]
emctl getversion
emctl reload | upload | clearstate | getversion agent
emctl reload agent dynamicproperties [<Target_name>:<Target_Type>]....
emctl config agent <options>
emctl config agent updateTZ
emctl config agent getTZ
emctl resetTZ agent
emctl config agent credentials [<Target_name>[:<Target_Type>]]
emctl gensudoprops
emctl clearsudoprops
Blackout Usage :
emctl start blackout <Blackoutname> [-nodeLevel] [<Target_name>[:<Target_Type>]].... [-d <Duration>]
emctl stop blackout <Blackoutname>
emctl status blackout [<Target_name>[:<Target_Type>]]....
...
from the help list ,I found the "emctl start/stop agent" is not supported at all!

I searched thru Google but it seems no one met the problem like me.

Could anyone help me with the two above issues?

Moreover:
my Oracle Version is 11.2 and I got the follwoing versions after I ran "emctl getversion agent":
___________________________________________________________________________
Oracle Enterprise Manager 11g Database Control Release 11.2.0.1.0
Copyright (c) 1996, 2009 Oracle Corporation. All rights reserved.
Enterprise Manager 10g Agent Version 10.2.0.4.0

Could anyone kindly help me? Thank you so much!
Re: EM Daemon is not running & no 'emctl start/stop agent' command [message #677136 is a reply to message #677131] Wed, 21 August 2019 08:14 Go to previous messageGo to next message
BlackSwan
Messages: 26595
Registered: January 2009
Location: SoCal
Senior Member
blackfruit wrote on Tue, 20 August 2019 22:09

Moreover:
my Oracle Version is 11.2 and I got the follwoing versions after I ran "emctl getversion agent":
___________________________________________________________________________
Oracle Enterprise Manager 11g Database Control Release 11.2.0.1.0
Copyright (c) 1996, 2009 Oracle Corporation. All rights reserved.
Enterprise Manager 10g Agent Version 10.2.0.4.0

Could anyone kindly help me? Thank you so much!
It appears that both V10.2 & V11.2 Oracle software have been installed on this system.
Is this correct? Two different ORACLE_HOME directories
Re: EM Daemon is not running & no 'emctl start/stop agent' command [message #677137 is a reply to message #677131] Wed, 21 August 2019 08:16 Go to previous messageGo to next message
John Watson
Messages: 8007
Registered: January 2010
Location: Global Village
Senior Member
Welcome to the forum. Please read the OraFAQ Forum Guide and How to use code tags and make your code easier to read

Have you run
emctl status dbconsole
enctl start dbconsole
if not that may be what you need to do.
Re: EM Daemon is not running & no 'emctl start/stop agent' command [message #677138 is a reply to message #677136] Wed, 21 August 2019 08:17 Go to previous messageGo to next message
John Watson
Messages: 8007
Registered: January 2010
Location: Global Village
Senior Member
No, that is the usual response. On my 11.2.0.4 install:
C:\Users\john>emctl getversion agent
Oracle Enterprise Manager 11g Database Control Release 11.2.0.4.0
Copyright (c) 1996, 2013 Oracle Corporation.  All rights reserved.
       Enterprise Manager 10g Agent Version 10.2.0.4.0

C:\Users\john>
Re: EM Daemon is not running & no 'emctl start/stop agent' command [message #677143 is a reply to message #677138] Wed, 21 August 2019 15:12 Go to previous messageGo to next message
JPBoileau
Messages: 68
Registered: September 2017
Member
It doesn't look right to me.

This is what mine gives:
(agent) D:\oracle_agent\agent_13.3.0.0.0>emctl getversion agent
Oracle Enterprise Manager Cloud Control 13c Release 3
Copyright (c) 1996, 2018 Oracle Corporation.  All rights reserved.
       Oracle Enterprise Manager Cloud Control Agent 13c Release 3

try this:
where emctl (Windows)
which emctl (Unix flavors)

JP
Re: EM Daemon is not running & no 'emctl start/stop agent' command [message #677144 is a reply to message #677136] Wed, 21 August 2019 20:48 Go to previous messageGo to next message
blackfruit
Messages: 3
Registered: August 2019
Junior Member
I downloaded Oracle 11.2.0.1 Software from OTN and EM is shipped with it.
So the EM agent version should be compatiable with Oracle Version.
Re: EM Daemon is not running & no 'emctl start/stop agent' command [message #677145 is a reply to message #677137] Wed, 21 August 2019 20:53 Go to previous messageGo to next message
blackfruit
Messages: 3
Registered: August 2019
Junior Member
I have run "emctl start dbconsole" and the message did show that EM .... started.
But when I ran "emctl status dbconsole" after that, I got the message:
EM Daemon is not running. And the EM can't be accessed via browser.

First,I wondered why the "emctl -help" tells me it has no "emctl start/stop agent" command(see my original post).
Re: EM Daemon is not running & no 'emctl start/stop agent' command [message #677146 is a reply to message #677145] Thu, 22 August 2019 01:34 Go to previous message
John Watson
Messages: 8007
Registered: January 2010
Location: Global Village
Senior Member
Stop trying to do anything with the Agent. The Agent is used by Cloud Control (as JP has shown), not by Database Control.

It looks as though (following my advice) you have attempted to start DB Control, but that "the EM can't be accessed via browser." What does that mean? You need to give some detail. Do you mean that you get an http-500 error? Or does it time out? Or anything else? You also need to show the URL you are using, and the output of the commands you are running to start/stop/status it. Use copy/paste from your shell, and use [code] tags to make it readable.

Previous Topic: EM Daemon is not running.
Goto Forum:
  


Current Time: Sun Sep 15 19:07:50 CDT 2019