Home » Infrastructure » Linux » set ORACLE_HOME (18cXE on Centos 7)
set ORACLE_HOME [message #675708] Mon, 15 April 2019 02:04 Go to next message
jkproperties
Messages: 15
Registered: April 2019
Junior Member
Good morning everyone,
I am a noob looking for a career change.

I keep running into the same problem.
I am running an iMac with Centos 7 on VirtualBox this is my 4th installation, I tried oracle Linux twice before, thought it was an installation issue.
I started completely fresh every time.

I get the following error when running./sqlplus from the files directory:

Error 6 initializing SQL*Plus
SP2-0667: Message file sp1<lang>.msb not found
SP2-0750: You may need to set ORACLE_HOME to your Oracle software directory

I find this error all over google and these forums but I am unable to resolve with suggested solutions(this could be that I am doing it wrong)

I am new to Linux and have never used ORACLE I am attempting to learn and experiment but have been trying to get it running for 5 days and just hitting this wall.

I would appreciate some help, please remember this is new to me, please be patient.
Re: set ORACLE_HOME [message #675709 is a reply to message #675708] Mon, 15 April 2019 02:07 Go to previous messageGo to next message
Michel Cadot
Messages: 66325
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator

Did you set ORACLE_HOME?
Did you export it?
Post the result of "env | sort".

Before, Please read How to use [code] tags and make your code easier to read.

Re: set ORACLE_HOME [message #675710 is a reply to message #675709] Mon, 15 April 2019 02:28 Go to previous messageGo to next message
jkproperties
Messages: 15
Registered: April 2019
Junior Member
Thank you for your reply Michel,
I have tried to set HOME on multiple occasions, with methods found all over google.

I have added the code tags but i doubt it was necessary for this post?

[jacoviljoen@localhost bin]$ env|sort
COLORTERM=truecolor
DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-Rai0aF5su2,guid=4635f6063c573a02498ba6525cb36a54
DBUS_STARTER_ADDRESS=unix:abstract=/tmp/dbus-Rai0aF5su2,guid=4635f6063c573a02498ba6525cb36a54
DBUS_STARTER_BUS_TYPE=session
DESKTOP_SESSION=gnome-classic
DISPLAY=:0
GDM_LANG=en_US.UTF-8
GDMSESSION=gnome-classic
GNOME_DESKTOP_SESSION_ID=this-is-deprecated
GNOME_SHELL_SESSION_MODE=classic
GNOME_TERMINAL_SCREEN=/org/gnome/Terminal/screen/ae4387da_3dce_41f7_86ff_440b79756d31
GNOME_TERMINAL_SERVICE=:1.141
HISTCONTROL=ignoredups
HISTSIZE=1000
HOME=/home/jacoviljoen
HOSTNAME=localhost.localdomain
IMSETTINGS_INTEGRATE_DESKTOP=yes
IMSETTINGS_MODULE=none
LANG=en_US.UTF-8
LESSOPEN=||/usr/bin/lesspipe.sh %s
LOGNAME=jacoviljoen
 LS_COLORS=rs=0:di=38;5;27:ln=38;5;51:mh=44;38;5;15:pi=40;38;5;11:so=38;5;13:do=38;5;5:bd=48;5;232;38;5;11:cd=48;5;232;38;5;3:or=48;5; 232;38;5;9:mi=05;48;5;232;38;5;15:su=48;5;196;38;5;15:sg=48;5;11;38;5;16:ca=48;5;196;38;5;226:tw=48;5;10;38;5;16:ow=48;5;10;38;5;21:s t=48;5;21;38;5;15:ex=38;5;34:*.tar=38;5;9:*.tgz=38;5;9:*.arc=38;5;9:*.arj=38;5;9:*.taz=38;5;9:*.lha=38;5;9:*.lz4=38;5;9:*.lzh=38;5;9: *.lzma=38;5;9:*.tlz=38;5;9:*.txz=38;5;9:*.tzo=38;5;9:*.t7z=38;5;9:*.zip=38;5;9:*.z=38;5;9:*.Z=38;5;9:*.dz=38;5;9:*.gz=38;5;9:*.lrz=38 ;5;9:*.lz=38;5;9:*.lzo=38;5;9:*.xz=38;5;9:*.bz2=38;5;9:*.bz=38;5;9:*.tbz=38;5;9:*.tbz2=38;5;9:*.tz=38;5;9:*.deb=38;5;9:*.rpm=38;5;9:* .jar=38;5;9:*.war=38;5;9:*.ear=38;5;9:*.sar=38;5;9:*.rar=38;5;9:*.alz=38;5;9:*.ace=38;5;9:*.zoo=38;5;9:*.cpio=38;5;9:*.7z=38;5;9:*.rz =38;5;9:*.cab=38;5;9:*.jpg=38;5;13:*.jpeg=38;5;13:*.gif=38;5;13:*.bmp=38;5;13:*.pbm=38;5;13:*.pgm=38;5;13:*.ppm=38;5;13:*.tga=38;5;13 :*.xbm=38;5;13:*.xpm=38;5;13:*.tif=38;5;13:*.tiff=38;5;13:*.png=38;5;13:*.svg=38;5;13:*.svgz=38;5;13:*.mng=38;5;13:*.pcx=38;5;13:*.mo v=38;5;13:*.mpg=38;5;13:*.mpeg=38;5;13:*.m2v=38;5;13:*.mkv=38;5;13:*.webm=38;5;13:*.ogm=38;5;13:*.mp4=38;5;13:*.m4v=38;5;13:*.mp4v=38 ;5;13:*.vob=38;5;13:*.qt=38;5;13:*.nuv=38;5;13:*.wmv=38;5;13:*.asf=38;5;13:*.rm=38;5;13:*.rmvb=38;5;13:*.flc=38;5;13:*.avi=38;5;13:*. fli=38;5;13:*.flv=38;5;13:*.gl=38;5;13:*.dl=38;5;13:*.xcf=38;5;13:*.xwd=38;5;13:*.yuv=38;5;13:*.cgm=38;5;13:*.emf=38;5;13:*.axv=38;5; 13:*.anx=38;5;13:*.ogv=38;5;13:*.ogx=38;5;13:*.aac=38;5;45:*.au=38;5;45:*.flac=38;5;45:*.mid=38;5;45:*.midi=38;5;45:*.mka=38;5;45:*.m p3=38;5;45:*.mpc=38;5;45:*.ogg=38;5;45:*.ra=38;5;45:*.wav=38;5;45:*.axa=38;5;45:*.oga=38;5;45:*.spx=38;5;45:*.xspf=38;5;45:
MAIL=/var/spool/mail/jacoviljoen
PATH=/usr/local/bin:/usr/local/sbin:/usr/bin:/usr/sbin:/bin:/sbin:/home/jacoviljoen/.local/bin:/home/jacoviljoen/bin
PWD=/opt/oracle/product/18c/dbhomeXE/bin
QT_IM_MODULE=xim
SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/13989,unix/unix:/tmp/.ICE-unix/13989
SHELL=/bin/bash
SHLVL=2
SSH_AGENT_PID=14225
SSH_AUTH_SOCK=/run/user/1000/keyring/ssh
TERM=xterm-256color
USER=jacoviljoen
USERNAME=jacoviljoen
_=/usr/bin/env
VTE_VERSION=5202
WINDOWPATH=1
XAUTHORITY=/run/gdm/auth-for-jacoviljoen-rrP75Y/database
XDG_CURRENT_DESKTOP=GNOME-Classic:GNOME
XDG_DATA_DIRS=/home/jacoviljoen/.local/share/flatpak/exports/share/:/var/lib/flatpak/exports/share/:/usr/local/share/:/usr/share/
XDG_MENU_PREFIX=gnome-
XDG_RUNTIME_DIR=/run/user/1000
XDG_SEAT=seat0
XDG_SESSION_DESKTOP=gnome-classic
XDG_SESSION_ID=1
XDG_SESSION_TYPE=x11
XDG_VTNR=1
XMODIFIERS=@im=none
[jacoviljoen@localhost bin]$ 

--moderator update: I've corrected the closong [/code] tag. And yes, they are necessary.

[Updated on: Mon, 15 April 2019 05:13] by Moderator

Report message to a moderator

Re: set ORACLE_HOME [message #675711 is a reply to message #675710] Mon, 15 April 2019 03:41 Go to previous messageGo to next message
jkproperties
Messages: 15
Registered: April 2019
Junior Member
I think I have found the problem.
I have restored to fresh linux installation, when i run the yum install prerequisite an error pops up quickly about permissions.
Should I log in as root to th gui to install oracle?
I do su in terminal but see this error pop up quickly
Re: set ORACLE_HOME [message #675715 is a reply to message #675710] Mon, 15 April 2019 05:16 Go to previous messageGo to next message
John Watson
Messages: 7871
Registered: January 2010
Location: Global Village
Senior Member
You have not set the ORACLE_HOME variable. You have not set your PATH correctly either, it must include $ORACLE_HOME/bin.

What did you do to set these? What and where are the "methods found all over google" to which you refer?
Re: set ORACLE_HOME [message #675717 is a reply to message #675715] Mon, 15 April 2019 05:35 Go to previous messageGo to next message
jkproperties
Messages: 15
Registered: April 2019
Junior Member
Hi John,
I have run:
export ORACLE_HOME=/opt/app/oracle/product/18c/dbhomexe/bin/
I then ran:
#echo $ORACLE_HOME$
still just returns
$ORACLE_HOME$

also tried #set ORACLE_HOME=/opt/app/oracle/product/18c/dbhomexe/bin/
I ran this command in terminal as my user name and as root
Re: set ORACLE_HOME [message #675718 is a reply to message #675717] Mon, 15 April 2019 05:41 Go to previous messageGo to next message
John Watson
Messages: 7871
Registered: January 2010
Location: Global Village
Senior Member
You have clearly NOT run
export ORACLE_HOME=/opt/app/oracle/product/18c/dbhomexe/bin/
or it would be visible in the output of env|sort. Furthermore, you have not set your search path.

Lastly, to expand an environment variable, you prefix it with a $. You do not suffix it with another $. May I suggest attending a basic Linux or Unix course? As you have discovered, you cannot change career without meeting some prerequisites. Alternatively, perhaps run on Windows: many beginners find this easier.
Re: set ORACLE_HOME [message #675720 is a reply to message #675718] Mon, 15 April 2019 06:54 Go to previous messageGo to next message
jkproperties
Messages: 15
Registered: April 2019
Junior Member
Thank you for your reply John,
I am enrolled in a linux course along with a list of others to follow one of which is Oracle.
as mentioned in my previous post I believe I have found a problem that might be causing this error.
When running the preinstallation yum command I see an error quickly pops up read/write error.

So I have rolled back my VBox Linux to pre Oracle installation just after Linux successfully installed.

I have a windows machine, but it is running windows 10 home and Oracle is not compatible with HOME,

I am trying a fresh installation on the system and will revert back as soon as I am back at this point with success or not.
Re: set ORACLE_HOME [message #675721 is a reply to message #675720] Mon, 15 April 2019 07:00 Go to previous messageGo to next message
John Watson
Messages: 7871
Registered: January 2010
Location: Global Village
Senior Member
All releases of Oracle run perfectly on Windows Home no problem. There is absolutely no difference between the Windows Home kernel and the Windows Pro kernel. You may be thinking of the fact that Oracle certifies its products on Windows Pro. This is not significant.

In general, since you are starting again, I would suggest that you throw away the idea of installing XE edition. Download and install the real thing, this is much better preparation for the real world and is permitted under the OTN developer licence.
Re: set ORACLE_HOME [message #675722 is a reply to message #675720] Mon, 15 April 2019 07:01 Go to previous messageGo to next message
jkproperties
Messages: 15
Registered: April 2019
Junior Member
I attempted to run the pre installation package from the terminal:

ok so the error/alert is:
SELinux has detected a problem.
The source process:/usr/bin/groupadd
Attempt this access: read
On this file:/0

Could this cause the issue?

I still get Complete! in terminal

[Updated on: Mon, 15 April 2019 07:03]

Report message to a moderator

Re: set ORACLE_HOME [message #675723 is a reply to message #675722] Mon, 15 April 2019 07:03 Go to previous messageGo to next message
John Watson
Messages: 7871
Registered: January 2010
Location: Global Village
Senior Member
It means that you should be asking that question on a Linux forum. However: The easiest solution is to disable SE Linux. Google that
Re: set ORACLE_HOME [message #675724 is a reply to message #675723] Mon, 15 April 2019 07:04 Go to previous messageGo to next message
jkproperties
Messages: 15
Registered: April 2019
Junior Member
Thank you,
I know how to do that, was suggested that it be set to permissive on ORACLE-Base
Re: set ORACLE_HOME [message #675725 is a reply to message #675708] Mon, 15 April 2019 08:32 Go to previous messageGo to next message
BlackSwan
Messages: 26483
Registered: January 2009
Location: SoCal
Senior Member
Consider to install pre-built VM that already contains Oracle database

https://www.oracle.com/technetwork/community/developer-vm/index.html
icon14.gif  Re: set ORACLE_HOME [message #675726 is a reply to message #675725] Mon, 15 April 2019 09:07 Go to previous messageGo to next message
jkproperties
Messages: 15
Registered: April 2019
Junior Member
Laughing

Embarassed

That would have saved me some time.

Thank you BlackSwan,
I am trying once more on a physical PC if it doesn't work I will use your method.
I am hoping to learn from the installation experience.

You are the man.
Re: set ORACLE_HOME [message #675727 is a reply to message #675721] Mon, 15 April 2019 09:19 Go to previous messageGo to next message
jkproperties
Messages: 15
Registered: April 2019
Junior Member
Hi John,
I didn't see your reply,
I did try installing oracle onto my windows 10 Home computer:
When it suggests an installation location and I Confirm to proceed it gives an error asking me to remove illegal characters.
I tried changing the location but keeps giving this error.

So I googled it and found:
multiple sites saying it can't be done.
Here is one i just googled:
https://blog.toadworld.com/2018/09/26/how-to-install-oracle-database-18c-on-windows
from above link
Moreover, Oracle Database 18c is only available for Windows 10 Professional, Enterprise and Education Editions. This means we can't install Oracle Database 18c if we are using Windows 10 Home Edition.

I will download the real version as you suggest.
Thank you,

[Updated on: Mon, 15 April 2019 09:20]

Report message to a moderator

Re: set ORACLE_HOME [message #675729 is a reply to message #675727] Mon, 15 April 2019 09:30 Go to previous messageGo to next message
John Watson
Messages: 7871
Registered: January 2010
Location: Global Village
Senior Member
That is wrong. As is a large amount of material on that website. All Oracle cares about is the kernel version:
C:\Users\john>ver

Microsoft Windows [Version 10.0.17134.706]

C:\Users\john>
Can you tell if that is home or pro? No, you can't. Neither can Uncle Oracle. as for your "illegal characters" error, well, if you don't show what you are doing, I don't see how anyone can advise.
Re: set ORACLE_HOME [message #675730 is a reply to message #675729] Mon, 15 April 2019 09:43 Go to previous messageGo to next message
jkproperties
Messages: 15
Registered: April 2019
Junior Member
John,
This was not the only website that incompatibility was stated, however you are an experienced user and I am not.
I will attempt installation on the windows machine again right now.
Will you still be online for a while?
Re: set ORACLE_HOME [message #675733 is a reply to message #675730] Mon, 15 April 2019 09:56 Go to previous messageGo to next message
jkproperties
Messages: 15
Registered: April 2019
Junior Member
Hi John,
I am downloading 11r2, this way I will be able to move through the process of upgrading, what are your thoughts?
I am downloading as per your advice, as I have xe downloaded from before
Should I abandon this thread and start a new one under Windows?
Thank you

[Updated on: Mon, 15 April 2019 10:05]

Report message to a moderator

Re: set ORACLE_HOME [message #675738 is a reply to message #675730] Tue, 16 April 2019 01:26 Go to previous messageGo to next message
John Watson
Messages: 7871
Registered: January 2010
Location: Global Village
Senior Member
jkproperties wrote on Mon, 15 April 2019 15:43
John,
This was not the only website that incompatibility was stated, however you are an experienced user and I am not.
I will attempt installation on the windows machine again right now.
Will you still be online for a while?
This "incompatible" nonsense it just that. Windows home is not certified, that's all. Neither is CentOS. Neither is a VirtualBox environment. So all your options are incompatible!To get started, install on whatever is easiest. I think Windows, followed by OEL. OEL is the RedHat kernel (as is CentOS) but it has a bit of pre-configuration that may make it easier.
Re: set ORACLE_HOME [message #675740 is a reply to message #675738] Tue, 16 April 2019 02:03 Go to previous message
jkproperties
Messages: 15
Registered: April 2019
Junior Member
Thank you John,
I have installed on Windows.
All seems to be in order except an issue on SQLDeveloper that BlackSwan helped me see the light.
Thank you again
Previous Topic: Need some Help on FTP File Uploading using Curl in Linux
Goto Forum:
  


Current Time: Mon Apr 22 03:03:03 CDT 2019