Home » Developer & Programmer » Forms » utl_tcp Error (10 g XE)
utl_tcp Error [message #671696] Fri, 14 September 2018 00:15 Go to next message
shahzad-ul-hasan
Messages: 525
Registered: August 2002
Senior Member
Form 6i, Xe Database
i want to connect ZTk-628 Finger print device to oracle. i have installed its driver. and using the following code in when button pressed..
DECLARE

  l_c_conn utl_tcp.connection;

  l_pi_ret pls_integer;

BEGIN

  l_c_conn := utl_tcp.open_connection(remote_host => '192.168.1.201', remote_port => 4370, charset => 'AL32UTF8');

  l_pi_ret := utl_tcp.write_line(l_c_conn, 'GET / HTTP/1.0');

  l_pi_ret := utl_tcp.write_line(l_c_conn);

  BEGIN

    LOOP

      dbms_output.put_line(utl_tcp.get_line(l_c_conn, TRUE));

    END LOOP;

  EXCEPTION

  WHEN utl_tcp.end_of_input THEN

    NULL;

  END;

  utl_tcp.close_connection(l_c_conn);

END;

ERROR at line 1:
ORA-00600: internal error code, arguments: [17069], [99726288], [], [], [], [], [], [], [], [], [], []


[Updated on: Fri, 14 September 2018 01:36]

Report message to a moderator

Re: utl_tcp Error [message #671702 is a reply to message #671696] Fri, 14 September 2018 03:48 Go to previous messageGo to next message
John Watson
Messages: 7545
Registered: January 2010
Location: Global Village
Senior Member
In the current release, it works for me (substituting an address:port to which I have access):
pdby1>
pdby1> DECLARE
  2
  3    l_c_conn utl_tcp.connection;
  4
  5    l_pi_ret pls_integer;
  6
  7  BEGIN
  8
  9    l_c_conn := utl_tcp.open_connection(remote_host => 'www.orafaq.com', remote_port => 80, charset => 'AL32UTF8');
 10
 11    l_pi_ret := utl_tcp.write_line(l_c_conn, 'GET / HTTP/1.0');
 12
 13    l_pi_ret := utl_tcp.write_line(l_c_conn);
 14
 15    BEGIN
 16
 17      LOOP
 18
 19        dbms_output.put_line(utl_tcp.get_line(l_c_conn, TRUE));
 20
 21      END LOOP;
 22
 23    EXCEPTION
 24
 25    WHEN utl_tcp.end_of_input THEN
 26
 27      NULL;
 28
 29    END;
 30
 31    utl_tcp.close_connection(l_c_conn);
 32
 33  END;
 34  /

PL/SQL procedure successfully completed.

pdby1>
so more than likely your problem is with that ancient XE edition. Time to upgrade.
Re: utl_tcp Error [message #671703 is a reply to message #671696] Fri, 14 September 2018 04:34 Go to previous messageGo to next message
Michel Cadot
Messages: 65756
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator

ORA-00600/ORA-07445/ORA-03113 = Oracle bug => search on Metalink/MOS and/or call Oracle support
Have a look at alert.log and trace files.
You can also read this article: Troubleshooting Internal Errors.
And MOS notes:
ORA-600/ORA-7445/ORA-700 Error Look-up Tool (Doc ID 153788.1)
Master Note for Diagnosing ORA-600 (Doc ID 1092832.1)

Re: utl_tcp Error [message #671704 is a reply to message #671703] Fri, 14 September 2018 07:52 Go to previous messageGo to next message
shahzad-ul-hasan
Messages: 525
Registered: August 2002
Senior Member
but i am using this code in When_button_pressed.not at SQL*PlUS. it works fine in Command Prompt.
Re: utl_tcp Error [message #671705 is a reply to message #671704] Fri, 14 September 2018 07:58 Go to previous messageGo to next message
shahzad-ul-hasan
Messages: 525
Registered: August 2002
Senior Member
how i can connect device of fingerprint with ip address.
Re: utl_tcp Error [message #671740 is a reply to message #671705] Mon, 17 September 2018 03:32 Go to previous message
cookiemonster
Messages: 13230
Registered: September 2008
Location: Rainy Manchester
Senior Member
If it works in sqlplus then move the code to stored procedure and call that from forms.
Previous Topic: Question with Pre-Insert trigger
Next Topic: frm-40405
Goto Forum:
  


Current Time: Tue Sep 18 16:19:47 CDT 2018