Home » Infrastructure » Linux » Problem with setting environment - oraenv (Oracle 12c, Oracle Linux)
Problem with setting environment - oraenv [message #667721] Thu, 11 January 2018 11:28 Go to next message
Andy1994
Messages: 5
Registered: January 2018
Location: Slovakia
Junior Member
Hello guys, I need your help. Smile
I installed database 12c, however when I want to set environment through command ". oraenv", I have error - "bash: oraenv: No such file or directory". I updated oratab and I have no idea, where is the problem. I use regullar 11g and there is no similar problem. Any ideas?

Re: Problem with setting environment - oraenv [message #667722 is a reply to message #667721] Thu, 11 January 2018 11:35 Go to previous messageGo to next message
Michel Cadot
Messages: 65317
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator

Does it work if you specify the file full path?

Do NOT post a screenshot for character lines.
Copy and paste the lines and put them inside the post.
Don't forget to format the post as specified in How to use [code] tags and make your code easier to read.

[Updated on: Thu, 11 January 2018 11:36]

Report message to a moderator

Re: Problem with setting environment - oraenv [message #667723 is a reply to message #667722] Thu, 11 January 2018 11:49 Go to previous messageGo to next message
Andy1994
Messages: 5
Registered: January 2018
Location: Slovakia
Junior Member
When I specify full path, I have the same error. :/
Re: Problem with setting environment - oraenv [message #667724 is a reply to message #667723] Thu, 11 January 2018 12:10 Go to previous messageGo to next message
John Watson
Messages: 7216
Registered: January 2010
Location: Global Village
Senior Member
oraenv will have been copied into /usr/local/bin when you ran the root.sh script. So either you didn't run it, or you have messed up you search path?
Re: Problem with setting environment - oraenv [message #667725 is a reply to message #667724] Thu, 11 January 2018 12:28 Go to previous messageGo to next message
Andy1994
Messages: 5
Registered: January 2018
Location: Slovakia
Junior Member
Thanks for help. I copied "oraenv" to path /usr/local/bin and it is running now. Smile
Re: Problem with setting environment - oraenv [message #667739 is a reply to message #667725] Fri, 12 January 2018 08:02 Go to previous messageGo to next message
EdStevens
Messages: 887
Registered: September 2013
Senior Member
Andy1994 wrote on Thu, 11 January 2018 12:28
Thanks for help. I copied "oraenv" to path /usr/local/bin and it is running now. Smile
Which makes one wonder why it wasn't there in the first place. Where did you copy it from?

[Updated on: Fri, 12 January 2018 08:03]

Report message to a moderator

Re: Problem with setting environment - oraenv [message #667742 is a reply to message #667739] Fri, 12 January 2018 08:27 Go to previous messageGo to next message
Michel Cadot
Messages: 65317
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator

Looks like, as John said, he did not run root.sh.

Re: Problem with setting environment - oraenv [message #667752 is a reply to message #667742] Fri, 12 January 2018 18:42 Go to previous messageGo to next message
EdStevens
Messages: 887
Registered: September 2013
Senior Member
Michel Cadot wrote on Fri, 12 January 2018 08:27

Looks like, as John said, he did not run root.sh.

If that's the case (which is the most likely explanation) then he also has a lot of ownership and permissions messed up
Re: Problem with setting environment - oraenv [message #667753 is a reply to message #667752] Sat, 13 January 2018 00:46 Go to previous messageGo to next message
Michel Cadot
Messages: 65317
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator

Indeed.

Re: Problem with setting environment - oraenv [message #667758 is a reply to message #667753] Sat, 13 January 2018 10:35 Go to previous messageGo to next message
Andy1994
Messages: 5
Registered: January 2018
Location: Slovakia
Junior Member
I am a woman, so right is "she", no "he". Smile After installation, I ran orainstRoot.sh and root.sh. I found "oraenv" in /app/oracle/product/12.1.0/ and then I moved it to /usr/local/bin. Now it's okay.
Re: Problem with setting environment - oraenv [message #667759 is a reply to message #667758] Sat, 13 January 2018 11:12 Go to previous messageGo to next message
Michel Cadot
Messages: 65317
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator

Sorry for misgender, you could specify it in your profile. Smile
Did you run the script with "root" account?

Re: Problem with setting environment - oraenv [message #667760 is a reply to message #667759] Sat, 13 January 2018 12:40 Go to previous message
Andy1994
Messages: 5
Registered: January 2018
Location: Slovakia
Junior Member
Smile
Yes, I used root. I installed oracle many times (11g), but I never had similar problem.

[Updated on: Sat, 13 January 2018 12:48]

Report message to a moderator

Previous Topic: Oracle Client on Virtual System
Goto Forum:
  


Current Time: Thu Jan 18 11:05:19 CST 2018

Total time taken to generate the page: 0.01840 seconds