Home » SQL & PL/SQL » Client Tools » ORA-00942: table or view does not exist (oracle 12c Windows 2012)
ORA-00942: table or view does not exist [message #667304] Wed, 20 December 2017 04:10 Go to next message
muthukrish104
Messages: 54
Registered: November 2017
Member
Hi,

In my toad login, I am getting this error message while accessing the tab of SCRIPT.
But other tabs like DATA, COLUMN, SYNONYMS are all working fine.

/foru/forum/fa/13719/0/


What could be the issue.


Regards
M.kRish
Re: ORA-00942: table or view does not exist [message #667305 is a reply to message #667304] Wed, 20 December 2017 04:30 Go to previous messageGo to next message
Littlefoot
Messages: 21439
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Which TOAD version do you use? Is it compatible with Windows 2012 and Oracle 12c?
Re: ORA-00942: table or view does not exist [message #667306 is a reply to message #667305] Wed, 20 December 2017 06:05 Go to previous messageGo to next message
muthukrish104
Messages: 54
Registered: November 2017
Member
Hi,

Yes, it is working for other schema's well.

The version of the Toad is 12.1.0.22

Regards
M.Krish
Re: ORA-00942: table or view does not exist [message #667307 is a reply to message #667306] Wed, 20 December 2017 06:12 Go to previous messageGo to next message
Littlefoot
Messages: 21439
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Yes, it is a new version, should be OK.

What kind of an object is it? A table? A view? Something else (materialized view, perhaps)? As if the current user lacks certain privileges on fetching metadata for that object ... On a second thought, I have no idea whether that's even possible - owner should see everything he owns. Maybe someone more experienced in the DBA field knows what's going on.
Re: ORA-00942: table or view does not exist [message #667308 is a reply to message #667307] Wed, 20 December 2017 06:24 Go to previous messageGo to next message
muthukrish104
Messages: 54
Registered: November 2017
Member
Hi,

Yes, that is the VIEW object only.

I hope, the owner of the schema should be able to have all the rights, right?

Regards
M.Krish
Re: ORA-00942: table or view does not exist [message #667311 is a reply to message #667308] Wed, 20 December 2017 07:40 Go to previous messageGo to next message
BlackSwan
Messages: 26183
Registered: January 2009
Location: SoCal
Senior Member
Please read and follow the forum guidelines, to enable us to help you:
OraFAQ Forum Guide
How to use {code} tags and make your code easier to read

How can we reproduce what you report?

You have a mystery & give us no clues.
Re: ORA-00942: table or view does not exist [message #667320 is a reply to message #667311] Wed, 20 December 2017 15:11 Go to previous messageGo to next message
Littlefoot
Messages: 21439
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
View's source can be viewed from USER_VIEWS. What do you get when you run

select text from user_views where view_name = 'some view here';

Do you still get the same error message? If so, as if you lack privileges on USER_VIEWS ...
Re: ORA-00942: table or view does not exist [message #667322 is a reply to message #667320] Wed, 20 December 2017 22:56 Go to previous messageGo to next message
muthukrish104
Messages: 54
Registered: November 2017
Member
Hi,

When I do run the query of:

select text from user_views where view_name = 'some view here';

It shows (WIDEMEMO).


The problem is simple:

In the same schema, we are able to see scripts of any other objects like DB LINK.

But, while trying for VIEWS, it shows above mentioned error.

Regards
M.Krish
Re: ORA-00942: table or view does not exist [message #667325 is a reply to message #667322] Thu, 21 December 2017 00:07 Go to previous messageGo to next message
Littlefoot
Messages: 21439
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
OK, if query you ran results in something, then USER_VIEWS is accessible to you. Which means that it might be a TOAD bug. However, as you said in a message #667306 said that "it is working for other schema's well", then it is probably not a TOAD bug.

What would it really be, I have no idea, sorry.
Re: ORA-00942: table or view does not exist [message #667326 is a reply to message #667325] Thu, 21 December 2017 00:41 Go to previous messageGo to next message
muthukrish104
Messages: 54
Registered: November 2017
Member
Hi,

Even I couldn't understand,
Because, i tried with creating a new view and tried. But the same error.

create view dummy_test as select * from user_tables;

I suspect about the column description (WIDEMEMO).

Regards
M.krish
Re: ORA-00942: table or view does not exist [message #667335 is a reply to message #667326] Thu, 21 December 2017 06:02 Go to previous message
muthukrish104
Messages: 54
Registered: November 2017
Member
Hi,

When I do these query in SQLPLUS with the setting of SET LONG 999, it works fine.
But not in TOAD, is it because the column's character data type.

select text from user_views
where view_name = upper('name');

But the data type of that view shows as below.



Thanks and Regards
Binoj
Previous Topic: Tools menu is missing in Toad 12.5.1.1
Next Topic: failure in testing a connection in 12c database
Goto Forum:
  


Current Time: Mon Oct 15 16:53:42 CDT 2018