Home » Developer & Programmer » Forms » FORMS 10G APP: SOME FORMS HANG AT OPENNING (WIN7 32BIT OC4J FORMS 10G ORACLE 11GR2 DB)
FORMS 10G APP: SOME FORMS HANG AT OPENNING [message #661469] Sun, 19 March 2017 10:10 Go to next message
lutin7812
Messages: 1
Registered: March 2017
Junior Member
Hello, I'm newbie to FORMS 10G but know a bit about OC4J technology and a lot about PL/SQL language.
We have picked up a new project for porting an old ORACLE FORMS 10G APP to a full WEB HTML dotnet plateform.
Problem is:

I've been able to install the whole forms app (we have the sources) onto a Win7 box.
I can compile and run the app fine with OC4J and access the app menu into a WEB browser (I use SUN Java Applet Plugin).
But some forms when loading/openning, hang.

With the SAME SOURCES compiled on the prod system every form open fine.

I've put traces (PL/SQL debug messages on the different events before form openning): I get PRE-FORM, PRE-BLOCK, PRE TEXT ITEM and then the form hangs. But orther forms work well.

I'm a bit lost... and don't know which direction to take to investigate.
Does someone have any idea of what's going on?

Thank's for help.

Olivier

Re: FORMS 10G APP: SOME FORMS HANG AT OPENNING [message #661474 is a reply to message #661469] Sun, 19 March 2017 14:45 Go to previous message
Littlefoot
Messages: 21123
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
First of all, try to recompile the form ("all" - <Ctrl + Shift + K>) and run it again in order to see whether there's any improvement.

If not, you could run the form in debug mode. In older Forms versions (such as 6i) you did have to put MESSAGE calls in order to debug a form, but later versions offer debugging - put a breakpoint into PRE-FORM or WHEN-NEW-FORM-INSTANCE trigger as they fire at the beginning (how? Right-click the left margin in trigger's PL/SQL window) and then run the form (you'll see the "Run in debug mode" green button right next to the "normal" run form button. Forms will lead you through the code and let you examine system and local variables etc. so you might be able to find the culprit.

Finally, based on what you've said so far, it appears that PRE-TEXT trigger might contain suspicious code. What is it?
Previous Topic: Installation of forms12c on developers system
Next Topic: Caution's Message With Variable Values
Goto Forum:
  


Current Time: Tue Jun 27 04:07:24 CDT 2017

Total time taken to generate the page: 0.07700 seconds